Bug 60883 - sawfish segfaults
Summary: sawfish segfaults
Status: CLOSED DUPLICATE of bug 60857
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-08 07:02 UTC by Chris Ricker
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-08 07:02:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2002-03-08 07:02:23 UTC
sawfish instantly dies with the error:

rep: received fatal signal: Illegal instruction
rep: received fatal signal: Segmentation fault
Segmentation fault

The interesting parts of the strace:

access("/root/.sawfish/lisp/sawfish/wm/state/wm-spec.jlc", R_OK) = -1 ENOENT (No
such file or directory)
access("/root/.sawfish/lisp/sawfish/wm/state/wm-spec.jl", R_OK) = -1 ENOENT (No
such file or directory)
access("/usr/share/sawfish/1.0.1/lisp/sawfish/wm/state/wm-spec.jlc", R_OK) = 0
stat64("/usr/share/sawfish/1.0.1/lisp/sawfish/wm/state/wm-spec.jlc",
{st_mode=S_IFREG|0644, st_size=9230, ...}) = 0
access("/usr/share/sawfish/1.0.1/lisp/sawfish/wm/state/wm-spec.jl", R_OK) = 0
stat64("/usr/share/sawfish/1.0.1/lisp/sawfish/wm/state/wm-spec.jl",
{st_mode=S_IFREG|0644, st_size=17103, ...}) = 0
stat64("/usr/share/sawfish/1.0.1/lisp/sawfish/wm/state/wm-spec.jl",
{st_mode=S_IFREG|0644, st_size=17103, ...}) = 0
stat64("/usr/share/sawfish/1.0.1/lisp/sawfish/wm/state/wm-spec.jlc",
{st_mode=S_IFREG|0644, st_size=9230, ...}) = 0
open("/usr/share/sawfish/1.0.1/lisp/sawfish/wm/state/wm-spec.jlc", O_RDONLY) = 7
fstat64(7, {st_mode=S_IFREG|0644, st_size=9230, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x4043c000
read(7, ";; Source file: sawfish/wm/state"..., 4096) = 4096
--- SIGILL (Illegal instruction) ---
rt_sigaction(SIGILL, {SIG_DFL}, {0x40054660, [ILL], SA_RESTART|0x4000000}, 8) = 0
open("/usr/share/locale/en_US/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)
open("/usr/share/locale/en/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such
file or directory)
write(2, "rep: received fatal signal: Ille"..., 48) = 48
--- SIGSEGV (Segmentation fault) ---
rt_sigaction(SIGSEGV, {SIG_DFL}, {0x40054660, [SEGV], SA_RESTART|0x4000000}, 8) = 0
getpid()                                = 19638
kill(19638, SIGSEGV)                    = 0
write(2, "rep: received fatal signal: Segm"..., 47) = 47
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

Comment 1 Havoc Pennington 2002-03-08 17:27:28 UTC
It doesn't do this on all machines; can you try a fresh user account maybe, 
maybe a different machine, maybe a different kernel, see if you can narrow down
what's different that gets it to appear...

Attach new info to #60857

*** This bug has been marked as a duplicate of 60857 ***


Note You need to log in before you can comment on or make changes to this bug.