Bug 608612 - [abrt] evolution-data-server-2.28.3-6.el6: get_c_method: Process /usr/libexec/evolution-data-server-2.28 was killed by signal 11 (SIGSEGV)
[abrt] evolution-data-server-2.28.3-6.el6: get_c_method: Process /usr/libexec...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
abrt_hash:bfd786e777cc3dd8010c5a55554...
:
: 651151 810516 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 05:52 EDT by Chris Ward
Modified: 2013-06-11 09:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 09:06:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (31.81 KB, text/plain)
2010-06-28 05:52 EDT, Chris Ward
no flags Details

  None (edit)
Description Chris Ward 2010-06-28 05:52:21 EDT
abrt version: 1.1.6
architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/evolution-data-server-2.28 --oaf-activate-iid=OAFIID:GNOME_Evolution_DataServer_InterfaceCheck --oaf-ior-fd=30
component: evolution-data-server
crash_function: get_c_method
executable: /usr/libexec/evolution-data-server-2.28
global_uuid: bfd786e777cc3dd8010c5a55554a9c9b6ca07f5f
kernel: 2.6.32-36.el6.x86_64
package: evolution-data-server-2.28.3-6.el6
rating: 4
reason: Process /usr/libexec/evolution-data-server-2.28 was killed by signal 11 (SIGSEGV)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)
time: 1277718254
uid: 501

How to reproduce
-----
1. I have no idea. I'm just using evolution as usual... and this report popped up. Sorry. I didn't notice any failures personally...
2.
3.
Comment 1 Chris Ward 2010-06-28 05:52:25 EDT
Created attachment 427369 [details]
File: backtrace
Comment 3 RHEL Product and Program Management 2010-06-28 06:22:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 RHEL Product and Program Management 2010-07-15 10:31:07 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Milan Crha 2010-11-16 05:43:09 EST
*** Bug 651151 has been marked as a duplicate of this bug. ***
Comment 6 RHEL Product and Program Management 2011-04-03 21:52:39 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 7 Milan Crha 2013-05-09 08:34:08 EDT
No exact hit upstream. The only thing I see from the backtrace is that the process crashed when an LDAP was stopping a book view (there was some request for contacts, either in the background or in foreground), but the book view seem to be released already.

Thread 1 (Thread 3691):
#0  0x00007f6543ba7415 in get_c_method (obj=0x7f6520007eb0, 
    methods=0x7f6547095c28, method_index=4, ret=0x0, args=0x7f6538b16a40, 
    ctx=0x0, ev=0x7f6538b16a60, class_id=15, method_offset=40, 
    skel_impl=0x7f6546e7d290 <_ORBIT_skel_small_GNOME_Evolution_Addressbook_BookViewListener_notifyProgress>) at poa.c:2568
        epv_start = <value optimized out>
        pobj = 0xaaaaaaaaaaaaaaaa
#1  ORBit_c_stub_invoke (obj=0x7f6520007eb0, methods=0x7f6547095c28, 
    method_index=4, ret=0x0, args=0x7f6538b16a40, ctx=0x0, ev=0x7f6538b16a60, 
    class_id=15, method_offset=40, 
    skel_impl=0x7f6546e7d290 <_ORBIT_skel_small_GNOME_Evolution_Addressbook_BookViewListener_notifyProgress>) at poa.c:2622
        method_impl = 0x7f654291d81d
        servant = 0x7f6528017cc0
#2  0x00007f6546e80338 in GNOME_Evolution_Addressbook_BookViewListener_notifyProgress (_obj=<value optimized out>, message=0x7f653edf91e2 "", percent=0, 
    ev=<value optimized out>) at Evolution-DataServer-Addressbook-stubs.c:41
        _args = {0x7f6538b16a38, 0x7f6538b16a34}
#3  0x00007f6546e8a4e6 in e_data_book_view_notify_status_message (
    book_view=0x7f652800aea0, message=0x7f653edf91e2 "")
    at e-data-book-view.c:440
        ev = {_id = 0x0, _major = 0, _any = {_type = 0x0, _value = 0x0, 
            _release = 0 '\000'}}
#4  0x00007f653edca5ae in ldap_op_finished (op=0x7f652804aa40)
    at e-book-backend-ldap.c:1177
        backend = <value optimized out>
        bl = 0x7f6528017b90
#5  0x00007f653edcb1e4 in e_book_backend_ldap_stop_book_view (
    backend=<value optimized out>, view=<value optimized out>)
    at e-book-backend-ldap.c:4641
        op = 0x7f652804aa40
#6  0x00007f6543b9af6a in ORBit_small_invoke_adaptor (
    adaptor_obj=<value optimized out>, recv_buffer=<value optimized out>, 
    m_data=<value optimized out>, data=<value optimized out>, 
    ev=<value optimized out>) at orbit-small.c:846
        ctx = {parent = {interface = 0x7f65280258e0, refs = 1138552704}, 
          mappings = 0x7f6534003cc8, children = 0x2, 
          the_name = 0x10 <Address 0x10 out of bounds>, 
          parent_ctx = 0x7f6534003cb0}
        args = <value optimized out>
        scratch = <value optimized out>
        pretval = 0x0
        retval = <value optimized out>
        send_buffer = 0x1b749e0
        orb = 0x1b749e0
        tc = 0x7f6543dd4ee0
        i = <value optimized out>
#7  0x00007f6543baae7d in ORBit_POAObject_handle_request (
    pobj=0x7f6520018980, opname=0x7f6534003a9c "stop", 
    ret=<value optimized out>, args=<value optimized out>, ctx=0x0, 
    recv_buffer=0x7f6534003b10, ev=<value optimized out>) at poa.c:1357
        invoke_data = {
          small_skel = 0x7f6546e7d2c0 <_ORBIT_skel_small_GNOME_Evolution_Addressbook_BookView_stop>, imp = 0x7f6546e8a350}
        poa = 0x7f65280258e0
        cookie = 0x0
        oid = <value optimized out>
        m_data = 0x7f6547095cc0
        small_skel = <value optimized out>
        imp = 0x7f6546e8a350
        __PRETTY_FUNCTION__ = "ORBit_POAObject_handle_request"
#8  0x00007f6543bab4a1 in ORBit_POAObject_invoke_incoming_request (
    pobj=0x7f6520018980, recv_buffer=0x7f6534003b10, opt_ev=0x0) at poa.c:1427
        opname = <value optimized out>
        real_ev = {_id = 0x0, _major = 0, _any = {_type = 0x0, _value = 0x0, 
            _release = 0 '\000'}}
        ev = 0x7f6538b16ca0
#9  0x00007f6543b942cc in giop_thread_queue_process (tdata=0x7f6534004150)
    at giop.c:792
        ent = <value optimized out>
        qe = 0x7f6534003280
        request = 0x0
        no_policy = 1
#10 0x00007f6543b94638 in giop_request_handler_thread (data=0x7f6534004150, 
    user_data=<value optimized out>) at giop.c:502
        done = <value optimized out>
        l = <value optimized out>
        tdata = 0x7f6534004150
#11 0x00007f65429565db in g_thread_pool_thread_proxy (
    data=<value optimized out>) at gthreadpool.c:265
        task = 0x7f6534004150
        pool = 0x1b73d40
#12 0x00007f6542955044 in g_thread_create_proxy (data=0x7f6534003810)
    at gthread.c:635
        thread = 0x7f6534003810
        __PRETTY_FUNCTION__ = "g_thread_create_proxy"
#13 0x00007f654209a761 in start_thread (arg=0x7f6538b17710)
    at pthread_create.c:301
        __res = <value optimized out>
        pd = 0x7f6538b17710
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140072719578896, 
                -759940159656167243, 140072966662464, 140072719579600, 0, 3, 
                846209513221781685, 846292314056030389}, 
              mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, 
            data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#14 0x00007f65411d14fd in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
No locals.
Comment 8 Milan Crha 2013-05-09 10:11:29 EDT
*** Bug 810516 has been marked as a duplicate of this bug. ***
Comment 10 RHEL Product and Program Management 2013-06-11 09:06:17 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.