Bug 60862 - grub breaks APM when booting windows
grub breaks APM when booting windows
Status: CLOSED DUPLICATE of bug 54375
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2002-03-07 18:46 EST by Bill Kilgallon
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-07 18:46:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Kilgallon 2002-03-07 18:46:11 EST
Description of Problem:
When I allow grub to boot my windows partition (both 98se2 and me) apm 
support is then broken in windows.  Switching back to lilo and allowing it 
to boot the windows partition, apm then works.

Version-Release number of selected component (if applicable):

How Reproducible:
100% reproducible on my thinkpad 570

Steps to Reproduce:

Actual Results:

Expected Results:

Additional Information:
At one point after windows trashed my mbr, and I had rebooted my linux 
partition with the recovery disk, I restored the MBR with lilo out of force 
of habit.  Once I rebooted and noticed the graphical eye candy was gone, I 
went back into my linux partition and reinstalled grub.  At that point, I 
probably putzed with the config file a little, but not much, and reinstalled 
grub.  I am not sure if this same problem happens with the normal installed 
image, or if it happens on lots of platforms, but it happens like clockwork 
on mine.  Doing a google search shows one minor reference to it from a grub 
developer, and suggests finding a "newer version of grub".  My newer version 
of grub will be lilo until I hear otherwise, this wasted a BUNCH of my time 
(whoda thunk of looking at my linux setup to understand why my Windows setup 
broke... its usually the other way around :( ).
Comment 1 Jeremy Katz 2002-03-07 18:51:03 EST
It's fixed in GRUB CVS and our current packages have the fix included.  Updated
packages with the fix can be found at http://people.redhat.com/~katzj/grub/

*** This bug has been marked as a duplicate of 54375 ***

Note You need to log in before you can comment on or make changes to this bug.