Bug 60887 - Floppy device not found on ASUS P4T-E
Floppy device not found on ASUS P4T-E
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
: 57253 64046 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-08 05:23 EST by Andreas Manschke
Modified: 2007-04-18 12:40 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 23:57:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Manschke 2002-03-08 05:23:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
Hi,

I've got a PC with ASUS P4T-E Mainboard.
Kickstart-Installation with:
linux ks=floppy doesn't work: /tmp/ks.cfg: No such file or directory
(but it is on the floppy !)
ALT-F3 says:
     * probing for floppy devices
     * no floppy devices found
     * going to insmod fat.o (path is NULL)
     * going to insmod vfat.o (path is NULL)
     * failed to mount floppy: No such device
Installing RH7.2 from DVD also gives: no such device for /dev/fd0.
Creating a bootdiskette during installation also doesn't work.
No diskette-Picture on KDE desktop after installation.

Remarks:
I tried RedHat Linux 7.0 and the creation of a bootdisk during installation
failed again, but after installation, the floppy drive works fine ! 

Booting (netboot.img) from the diskette drive works, 
initrd.img and vmlinuz are loaded properly.

BIOS updated to latest level (1005e) doesn't help.

The same problem with SUSE 7.2.
DOS and WIN98 work with the diskette without problems.

BIOS says: Legacy Diskette A: 1.44M , 3.5 in.
I tried also "Floppy 3 Mode Support" disabled and enabled
BIOS - advanced - I/O Device Configuration: 
  "Floppy Disk Access Control [R/W]"
  Plug & Play O/S [No]

Mikael (http://linux-kernel.skylab.org/20011021/msg01481.html)
seems to describe and solve just this problem. Unfortunately,
his solution doesn't work at my side or I made a mistake

The Problem is reproducable on all 12 machines I have with this
motherboard. No problems on those with other motherboards.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Buy a ASUS P4T-E motherboard
2.Try a kickstart installation of RedHat Linux 7.2 from floppy
3.See if it works
	

Actual Results:  as described above

Expected Results:  Access to floppy 

Additional info:

I had several contacts to RedHat Support and they finally
gave the advice to bring this problem to bugzilla
Comment 1 Jeremy Katz 2002-03-08 10:57:02 EST
Reassigning to kernel
Comment 2 Alan Cox 2002-03-08 11:28:13 EST
They seem to have a very weird floppy. The change in the email is in current 2.4
kernels so the problem should vanish in newer releases
Comment 3 Howard Susman 2002-03-08 19:49:03 EST
I was about to report the identical bug.  I have the same motherboard and the same problem. 
Additional Information: useful or not, I don't know.
          Redhat 7.2 reports:  floppy0:  no floppy controllers found
          LinuXcare bootable recovery disk v1.5: floppy works normally with no problem
          Mandrake Linux, current version reports:  port busy. On searching /proc to see what was using port, it said it was used by
                                                                                     some plug and play module. 
          One inconsistant result: I was able to access floppy for a while with just the plug and play turned off in the BIOS. That no longer works.
          Installation kernel has same problem.
          I was also referred here by Redhat technical support.

howard@scsurplus.com
Comment 4 Michael Kearey 2002-03-19 19:01:56 EST
I have a P4t-E Asus motherboard too, with similar problem - no floppy controller
found.

Have upgraded the Bios to 1005E, with no success. 

Saw the comment from alan@redhat.com, that the change is in current 2.4 Kernels,
so should be in the next release. So I tried RawHide 2.4.18-04 Kernel. Still no
success. Had a look at the source for the 2.4.18-04 Kernel, and found that yes,
the change to bootsect.S has been made.

I suspect there are two problems

 -- During install of RH 7.2 , the "Make Boot Disk" fails as does kickstart
facility, as described originally in this Bug No' (Fixed with the bootsect.S
patch??)

 -- After install, the floppy controller still locks up so no controllers found.

Cheers,
Michael
Comment 5 Howard Susman 2002-04-03 03:29:04 EST
I have stumbled onto a work around that seems to work for me. If I recompile the kernel with the floppy driver as a module rather than part of the 
kernel, the problem seems to go away.  If this works for others, I would still be interested to know the real nature of the problem as this work around 
should really have no effect.
Comment 6 Andreas Manschke 2002-04-04 03:06:20 EST
Howards solution (Floppy as module) also works for me
with kernel 2.4.9-31. Thanks !!

Andreas
Comment 7 Need Real Name 2002-05-23 20:38:29 EDT
 I have the same problem, i.e. floppy device not found after installation.   
 
ASUS P4T-E motherboard. 
BIOS version 1005. 
Red Hat Linux version 7.3 
Kernel 2.4.18-4.
Comment 8 Need Real Name 2002-05-24 12:42:54 EDT
asus P4T-E P4 motherboard
same problem 7.2
same problem 7.3 - More $$ to upgrade and still broke!

I am bracing myself to figure out Howards recompile the kernel (crap!) "with 
the floppy driver as a module rather than part of the kernel" and? turn off the 
Plug & Play in the BIOS?  If anyone has a newbie simple description on how to 
do this please post or email me!


Comment 9 Alan Cox 2002-05-24 13:54:34 EDT
Before you try recompiling anything, set the BIOS to non Plug & Play, save the
settings and see if that makes a difference. Basically this board appears to
have some weird, unique and non standard floppy compatibility problem
Comment 10 Need Real Name 2002-05-24 14:11:05 EDT
Alan - Thanks:  Here are the results so far:

7.2 Plug & Play      Floppy device not found  
7.2 Non Plug & Play  Floppy device not found  
7.3 Plug & Play      Floppy device not found  
7.3 Non Plug & Play  Not tested yet - I will test this weekend and advise

The only variable in each case is Plug & Play.  When I installed 7.3 I did a 
complete reinstall (not an upgrade).
Comment 11 Need Real Name 2002-05-24 21:08:20 EDT
My BIOS is already set to Non Plug & Play.  Floppy device still not found.
Comment 12 Need Real Name 2002-05-25 19:18:23 EDT
Alan:  Ok so I turned off Plug & Play and just as noted by krcomp above still 
no luck - :  Here are the results so far:

7.2 Plug & Play      Floppy device not found  
7.2 Non Plug & Play  Floppy device not found  
7.3 Plug & Play      Floppy device not found  
7.3 Non Plug & Play  Floppy device not found  
Comment 13 Need Real Name 2002-06-09 13:26:58 EDT
I recompiled my kernel with the floppy driver as a module as recommended by
howard@scsurplus.com and I can now access my floppy drive.
Comment 14 Need Real Name 2002-06-10 11:29:07 EDT
I dumped the asus board - I don't have time for this so I am looking at an MSI 
845E MAX2 LR P4 board or an MSI 845 Ultra-ARU P4 Mboard with Raid.  I would 
prefer the RDRAM (MSI uses DDR) and faster frontside bus of the asus P4T but I 
cannot wait for a fix and I do not want to recompile - I need a stock working 
version of RedHat.  In the meantime I am using an old 200MHz gateway which used 
to be rock solid on RedHat 6.1 but mostly works on RedHat 7.3 (the MCOPY floppy 
access sometimes failes to acknowledge an overwrite confirm).  As far as I can 
see there is no complaints on MSI but if anyone knows otherwise please advise.
Comment 15 Per Steinar Iversen 2002-07-02 05:29:05 EDT
The problem is still present with latest RH 7.3 kernel update, 2.4.18-5
Comment 16 Need Real Name 2002-07-05 23:03:30 EDT
I am having the same problem on an HP Pavilion 7960, which I think has the same 
Asus motherboard.  On tech support's suggestion, I have tried compiling the 
driver as a module, and it seems to have caused Linux to recognize the floppy 
controller, but I could not complete the Kudzu procedure when the system 
recognized the device (at boot) because ... now it no longer recognized any USB 
devices! -- and those include my mouse and keyboard!  So I had no input and 
could not complete either the Kudzu procedure or login.
Comment 17 Need Real Name 2002-07-31 18:45:09 EDT
Can anyone help me with this problem? I have the same problem as mention above. 
I have an ASUS P4T-E motherboard and I am running Linux 7.3. 
The problem that I am having is not being able to copy to and from the floppy 
drive. In fact, the Linux system does not recognize the floppy drive at all.

After reading the comments above, I turned off and on the Plug and Play option 
in my BIOS, however, nothing changed.

I am not sure how to recompile my BIOS as mentioned above. I could use some 
help on that as well.

The bottom line problem that I am trying to resolve is getting the Linux system 
to recognize the floppy drive so I can copy to and from a floppy.

Any advice?
Comment 18 Alan Cox 2002-07-31 19:01:51 EDT
The current situation is that the ASUS P4T-E floppy isnt detected at boot, but
is detected by identical code if used at module load time. Why this occurs I
have no idea, and it seems to be an ASUS P4T-E specific problem.

I have a couple of fairly off the wall guesses at what might be the problem if
someone wants to grab a test kernel image, write it to floppy and try booting it
on an afflicted board. The odds of it working are not brilliant but it might be
worth the experiment to find out what is up
Comment 19 Need Real Name 2002-07-31 19:44:07 EDT
I am not real experienced with this stuff, however, if someone can explain to 
me how to get a kernel image, write it to a floppy and booting it, I will be 
happy to try.
Comment 20 Mike A. Harris 2002-08-19 21:39:54 EDT
Bug #64046 might shed some light, looks like potential dupe here,
with patch of possible solution..
Comment 21 Alan Cox 2002-08-20 07:57:22 EDT
*** Bug 64046 has been marked as a duplicate of this bug. ***
Comment 22 Alan Cox 2002-08-20 07:58:40 EDT
The change should not make any difference but if it does then its good news. The
change Mikael proposes is needed anyway for legacy free PC systems which don't
have a conventional floppy controller.
Comment 23 Need Real Name 2002-08-20 14:44:42 EDT
Here's the problem -- bootsect.S has the patch applied -- and the floppy drive
doesn't work.  When I recompile the kernel making the floppy modular.  Then the
floppy drive works.  --> BUT THIS IS NOT A FIX!! <--

Reality is that it works if you've already installed the OS, and recompiled the
kernel -- it DOES NOT work if you're trying to do an NFS based kickstart install
of a large number of networked systems.  Or if you have to read from the floppy
on an install.  The bootnet.img that comes on the stock 7.3 disks is not setup
with a kernel that has a modular floppy.  I'd have to go back, unpack the
bootnet.img, try and compile a bootable kernel (w/ modular floppy support), edit
the initrd.img adding the appropriate floppy.o, and rebuild the img... UGH...

Please note: I'm trying to automate an NFS based install using kickstart, and
not being able to read from the floppy on install is killing me.  I first tried
passing the ks.cfg to the install process via floppy (i.e. -- dumped ks.cfg onto
bootnet.img with vmlinuz, edited syslinux.cfg making default ks, and ks=floppy)
-- Obviously once the install kernel loads, it kills the floppy drive, therefore
ks.cfg isn't able to be read. The whole process simply stops at this point.
 
Next I tried passing the ks.cfg file to install process via dhcpd.conf -- 
example:
host whatever{
	filename "/nfsmountable/directory/ks.cfg";
	etc.  (mac address, options etc)
}

The bootnet.img file -- syslinux.cfg is edited to reflect nfs server has ks.cfg
file  -- ala -->  ks=nfs:192.168.1.1:/kickstart  
Problem is that as the install process dies when trying to read the
ks.cfg,saying something like:  Error no such file or directory "/tmp/ks.cfg".

Next had the bright idea of unpacking the bootnet.img, unpacking initrd.img, and
dumping the ks.cfg in the /tmp directory within the ramdisk image, then
repacking everything.  Everything appears to work but install process is not
automated -- (and I do have skipx set, and don't have interactive install turned
on).  Plus, the install process doesn't work all the time... i.e. -- non
repeatable events.  Sometimes anaconda crashes, sometimes I get a "blue screen"
(YIKES Blue screens YIKES) and can see that the nfs/dhcp servers cpu/network is
being hammered on, etc, etc, etc...  Seems like the floppy drive "issue" is not
a completed issue at all...

NEED INPUT PLEASE!!
Comment 24 Need Real Name 2002-08-20 17:01:23 EDT
Please also note this is a duplicate of a "closed" problem --

see Bug #57253
Comment 25 Mike A. Harris 2002-08-23 23:57:53 EDT
*** Bug 57253 has been marked as a duplicate of this bug. ***
Comment 26 Mike A. Harris 2002-10-01 20:44:49 EDT
<Sim> mharris: good news though, the bugzilla problem #60887 has gone away with
8.0 ... HAVE NO IDEA WHY... but it's not an issue with 8.0 install w/ Asus P4T-E
motherboards...

I'm closing this bug now as fixed in Red Hat Linux 8.0.
Comment 27 Alan Cox 2002-10-01 20:48:55 EDT
8.0 doesnt assume and use legacy I/O for the floppy reset, it uses the bios
during boot up. I assume whatever was weird about the P4T-E happens to be worked
around by the bios
Comment 28 Michael Kearey 2002-10-07 09:15:34 EDT
I am running Redhat 8.0 on a P4TE, and the problem is still present.

I don't think it's gone away at all. Is there NOTFORME atribute in Bugzilla ??
I might try a BIOS update from ASUS if there is one..Am still original 1005 version.

Cheers,
Michael
Comment 29 Patrick M. Wanner 2003-01-06 14:36:21 EST
I'm using RH8 on an Asus P4T-E and am also still having the problem. I'm running
the 2.4.18-19.8.0 kernel. Has RH released some patch for this or has anyone
confirmed if the BIOS is responsible for the bug?

Thanks,

Patrick
Comment 30 Michael Kearey 2003-01-07 04:34:23 EST
The BIOS upgrade didn't fix the problem.

I have, after being given sound advice, opened a new Bug
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75687

I am hoping that was the right thing to do. Since I cannot re-open this closed
bug....
Comment 31 Need Real Name 2003-01-31 19:02:44 EST
This is still a problem in RedHat 8.0 and SuSE.  When asked to create a boot
disk during install, one was created and there was no problem.  When I boot up
the Linux kernel, I cannot mount my floppy still.  Mandrake does not seem to
have this problem, but there are a few little quirks I have with it.

Why the floppy drive will work when creating a boot disk during installation and
not when X starts, I have no idea.  If you try running RedHat at runlevel 3, you
may be able to mount the floppy drive (somehow it seems the /dev/fd0
reappears???), but there will be numerous errors when writing to/from the floppy.

Hope this gets fixed; I'm highly satisfied for the most part with 8.0.
Comment 32 Need Real Name 2003-01-31 19:14:08 EST
Guessing this will be fixed by redhat 12.0
Comment 33 Alan Cox 2003-02-01 07:05:40 EST
Fixing it is tricky. The P4T-E board seems to have something very odd and not
quite PC compatible in its floppy hardware.  There simply isnt sufficient
information available 

Note You need to log in before you can comment on or make changes to this bug.