Bug 64046 - The installation disk does not work with ASUS P4T-E Floppy controller
The installation disk does not work with ASUS P4T-E Floppy controller
Status: CLOSED DUPLICATE of bug 60887
Product: Red Hat Linux
Classification: Retired
Component: syslinux (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-24 08:17 EDT by Lars Berntzon
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 04:56:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Berntzon 2002-04-24 08:17:21 EDT
Description of Problem:

The boot disk for redhat (which uses syslinux as boot manager) will turn off
the floppy controlled in a way that causes ASUS P4T-E motherboard floppy 
controllers to stop responding.

I applied the patch patch below to ldlinux.asm in the syslinux-1.52 
distribution, compile syslinux and use this new syslinux for creating a
new bootdisk. 

Note, this type of change is also needed for lilo, since the floppy is not 
usable after installing Linux. I have no patch for this though.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. Boot with the boot floppy to get up some kind of Linux running.
2. Try to access the floppy

Actual Results:


Expected Results:


Additional Information:
	
Patch to be applied to syslinux-1.52 and the file ldlinux.asm:
--------------------- BEGIN PATCH ----------------------
*** ldlinux.asm.org     Mon Jan 28 13:37:34 2002
--- ldlinux.asm Mon Jan 28 13:39:57 2002
***************
*** 2195,2203 ****
--- 2195,2209 ----
  ; at least bootsect.S seems to imply so
  ;
  kill_motor:
+ %if 1
+               xor ax, ax                      ; reset FDC
+                       xor dl, dl
+               int 13h
+ %else
                mov dx,03F2h
                xor al,al
                call slow_out
+ %endif
  ;
  ; If we're debugging, wait for a keypress so we can read any debug messages
  ;
--------------------- END PATCH ----------------------
Comment 1 Michael Fulbright 2002-04-24 11:47:37 EDT
Reassigning to syslinux.

Comment 2 Mike A. Harris 2002-08-19 21:38:42 EDT
This bug looks similar, possibly a dupe of bug #60887

I'm trying to help a user who is trying to install on a large network
of machines which experience this problem.

Arjan, Alan - can you comment on this?
Comment 3 Lars Berntzon 2002-08-20 04:56:40 EDT
Mikael Pettersson original post of the patch is here:
http://linux-kernel.skylab.org/20011021/msg01481.html
Comment 4 Alan Cox 2002-08-20 07:57:26 EDT

*** This bug has been marked as a duplicate of 60887 ***

Note You need to log in before you can comment on or make changes to this bug.