Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 608954 - Computer freezes when enabling external monitor using xrandr on an Intel GMA HD integrated in core i5
Computer freezes when enabling external monitor using xrandr on an Intel GMA ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 22:39 EDT by Johannes Goller
Modified: 2018-04-11 10:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 08:39:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johannes Goller 2010-06-28 22:39:48 EDT
Description of problem:
When running

xrandr --ouput VGA1 --mode 1920x1200

after plugging in an external monitor that supports that resolution (tested on an F11 installation on a different machine), the entire system freezes, i.e. nothing moves, no sound and no reaction to keyboard input.

However, "xrandr -q" works and prints 1920x1200 as a possible resolution.
It also lists other resolutions, and I tried several, which also lead to the same result.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.9.1-1.fc12
kernel-2.6.31.5-127.fc12

Note that with a newer kernel (I tried 2.6.32.14-127.fc12 as well as upgrading to fc13) even the built-in monitor does not work and the system freezes right during the installation of the OS (see Bug 607864).

How reproducible:
With 1920x1200 the freeze occurred every time I tried. With a lower resolution, it happened once that the system did not freeze, but the external monitor was not activated either.

Steps to Reproduce:
1. Start the system and log on
2. Then plug in the monitor
3. Run the xrandr command (alternatively, use System Settings -> Display) to enable the external monitor

Note that plugging in the monitor before starting up the computer, or during boot, causes the log-in screen not to be displayed, the system apparently freezing before log-in is possible.

Actual results:
Total freeze

Expected results:
Activation of the external monitor
Comment 1 Matěj Cepl 2010-06-29 10:57:10 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Johannes Goller 2010-06-29 22:18:37 EDT
Sorry I am confused about where to add "drm.debug=0x04". In the Grub menu I get with F12, there are two things that can be changed: The boot commands ('e') and the Kernel arguments ('a').

I tried both, but when the booting sequence started, I got an error message both times, saying that "drm.debug=0x04" was an unknown argument and would be ignored.
Comment 3 Johannes Goller 2010-07-07 04:41:08 EDT
Anyway.

The problem is solved by applying the two patches below to the 2.6.32.14-127.fc12 kernel sources, rebuilding, and installing the new kernel.

http://lists.freedesktop.org/archives/intel-gfx/2010-June/007216.html
http://lists.freedesktop.org/archives/intel-gfx/2010-June/007232.html

Using the new kernel does not only allow me to plug-in an external monitor and use it, but also helps to accelerate graphic rendering enormously. Switching between windows is a lot faster now.

Note that I plug the external monitor in after starting X. According to somebody else's report, plugging in the monitor before starting X sometimes still causes problems.

It would be very nice if the patch could be included in an updated kernel version for yum.
Comment 4 Johannes Goller 2010-07-07 21:38:36 EDT
Regarding the final remark above: Indeed X does not start up when the monitor is plugged in at boot time. But plugging later and using xrandr works without problems.
Comment 5 Bug Zapper 2010-11-03 08:45:38 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2010-12-03 08:39:03 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.