Bug 608957 - Can't play fullscreen flash video when compiz is enabled.
Can't play fullscreen flash video when compiz is enabled.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
: 624425 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 22:56 EDT by Y-H
Modified: 2011-05-23 16:10 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 05:26:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Y-H 2010-06-28 22:56:35 EDT
Description of problem:

Unable to play Flash video within internet browsers when Compiz is enabled. Video freezes a couple seconds after selecting fullscreen, though audio continues. Able to return to website at this point by un-selecting the fullscreen option.

Version-Release number of selected component (if applicable):

compiz-0.8.6-1.fc13 (i686)

How reproducible:

Always

Steps to Reproduce:
1. Make sure Compiz is activated (System > Preferences > Desktop Effects > Compiz)
2. Visit a website on which a Flash video can be found (e.g., Hulu or YouTube). 
3. Play the video.
4. Look for the fullscreen option within the flash player, and select it.
  
Actual results:

The video plays in fullscreen.

Expected results:

The video stops playing after 1-2 seconds. The audio continues playing, and it's possible to return to the website (normal view) by un-selecting the fullscreen option.

Additional info:

-- xorg-x11-drv-intel-2.11.0-4.fc13 (i686)
-- flash-plugin-10.1.53.64-release.i386
-- problem persists regardless of whether Compiz option "Undirect Fullscreen Windows" is selected
-- problem persists regardless of whether Flash option "Enable hardware acceleration" is selected
-- see also http://forums.fedoraforum.org/showthread.php?p=1374551 and http://forums.fedoraforum.org/showthread.php?p=1375691
Comment 1 Y-H 2010-06-28 22:57:51 EDT
Oops, please switch "Actual" and "Expected" results above.
Comment 2 Adel Gadllah 2010-07-06 16:40:31 EDT
I cannot reproduce this, flash works just fine here with compiz.

What hardware / driver are you using?
Comment 3 Y-H 2010-07-06 17:11:34 EDT
-- Intel Graphics Media Accelerator 950
-- xorg-x11-drv-intel-2.11.0-4.fc13 (i686)
Comment 4 G. Buechner 2010-07-07 11:41:34 EDT
Same here:

-Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

-xorg-x11-drv-intel-2.11.0-5.fc13.x86_64 

Flash plugin is running using nspluginwrapper (latest version, if needed, i will look it up).
Comment 5 Y-H 2010-07-07 14:03:37 EDT
(In reply to comment #2)
> I cannot reproduce this, flash works just fine here with compiz.

You checked fullscreen playback?
Comment 6 Adel Gadllah 2010-07-08 02:57:59 EDT
(In reply to comment #5)
> (In reply to comment #2)
> > I cannot reproduce this, flash works just fine here with compiz.
> 
> You checked fullscreen playback?    

Yes, I manged to reproduce it now.

The reason why it was working fine for me was that I forced it to use hw accel.

Please try the following:

mkdir -p /etc/adobe
echo "OverrideGPUValidation=1" > /etc/adobe/mms.cfg

Make sure to close all firefox / npviewer.bin processes and try again.

Does this fix your issue?
Comment 7 G. Buechner 2010-07-08 03:40:10 EDT
(In reply to comment #6)
> 
> Yes, I manged to reproduce it now.
> 
> The reason why it was working fine for me was that I forced it to use hw accel.
> 
Which graphic card do you use? I think this fix will only work with Intel graphic chipsets due to the problems related with ATI&NVIDIA-drivers.
Maybe somebody may try this with an ATI/NVIDIA-adapter.
Comment 8 Adel Gadllah 2010-07-08 03:52:22 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > 
> > Yes, I manged to reproduce it now.
> > 
> > The reason why it was working fine for me was that I forced it to use hw accel.
> Which graphic card do you use? 

Tested both INTEL GM45 and NVIDIA GTX 285 using the proprietary driver.

> I think this fix will only work with Intel
> graphic chipsets due to the problems related with ATI&NVIDIA-drivers.
> Maybe somebody may try this with an ATI/NVIDIA-adapter.    

No sure what you are talking about here, the problem is that for some reasons the software path does not trigger damage events which results into compiz not redrawing because it does not _know_ that it is supposed too.

The OpenGL path works which I would recommend for power efficiency and performance reasons anyway.

So please stop the hand weaving "it might not work due to some problems".

Anyway this is a flash bug, that Adobe should fix, I am just waiting for someone else to confirm that enabling OpenGL for flash (using the config file I mentioned above) fixes it.
Comment 9 Y-H 2010-07-08 04:50:05 EDT
The fix recommended in comment #6 fixes the issue for me. Thanks a bunch!
Comment 10 Adel Gadllah 2010-07-08 05:26:20 EDT
(In reply to comment #9)
> The fix recommended in comment #6 fixes the issue for me. Thanks a bunch!    

OK, thanks for testing ... that confirms that it is a flash bug that I can't fix unless Adobe sends me the source; so closing.
Comment 11 G. Buechner 2010-07-08 11:11:20 EDT
(In reply to comment #6)
> (In reply to comment #5)
> 
> Please try the following:
> 
> mkdir -p /etc/adobe
> echo "OverrideGPUValidation=1" > /etc/adobe/mms.cfg
> 
> Make sure to close all firefox / npviewer.bin processes and try again.
> 
> Does this fix your issue?    

Thank you. It works for me, too on X86_64.
My previous post was not meant to blame you for anything; anyway, thanks for the workaround.
Comment 12 Y-H 2010-07-08 14:10:16 EDT
AG, at your convenience, do you think you could file a bug report at http://bugs.adobe.com/flashplayer/? I suspect you'll be able to provide better information than I can.
Comment 13 Adel Gadllah 2010-07-08 16:23:53 EDT
(In reply to comment #12)
> AG, at your convenience, do you think you could file a bug report at
> http://bugs.adobe.com/flashplayer/? I suspect you'll be able to provide better
> information than I can.    

Filed http://bugs.adobe.com/jira/browse/FP-4993
Comment 14 Y-H 2010-07-08 18:25:09 EDT
This is great, thanks!
Comment 15 Felix Möller 2010-07-10 15:01:55 EDT
info from comment #6 helps here. will this file somehow be delivered as an update, i think there are a lot of people suffering from this ... Just from the pragmatic point of view ...
Comment 16 Dan O'Brien 2010-07-10 15:34:20 EDT
Same problem here with 64 bit F13.  I tried the work around it fixes the problem for me.
Comment 17 crazydreamer 2010-07-12 16:45:32 EDT
Hi All,

Thanks for all the help on this bug. I tried the above described fix. It did not work for me. I am running fc13 on my Alienware M11x. I am used to Ubuntu although I switched to Fedora recently as Ubuntu requires the bios graphics setting on my notebook to be set to discrete (with nvidia drivers installed for compiz). I am currently running compiz with the nouveau driver. I do not know how to check which driver the kernel is using as both xorg-intel driver as well as nouveau nvidia-driver are installed on my box.

What did work for me was when I turned the indirect rendering option on using the compiz fusion icon.

I don't know why this works. But I just thought it might be useful to let you guys know. Thanks.
Comment 18 James 2010-07-17 16:54:09 EDT
Anyone else find fullscreen Flash *does* work with xorg-x11-drv-intel-2.12.0-1.fc13.x86_64, even without the mms.cfg hack?
Comment 19 Felix Möller 2010-07-17 16:59:59 EDT
James where did you get the intel 2.12 from? I do not even see it at <https://admin.fedoraproject.org/updates/search/intel> yet ...
Comment 20 James 2010-07-17 17:24:43 EDT
(In reply to comment #19)
> James where did you get the intel 2.12 from? I do not even see it at
> <https://admin.fedoraproject.org/updates/search/intel> yet ...    

http://koji.fedoraproject.org/koji/buildinfo?buildID=179735
Comment 21 Felix Möller 2010-07-17 17:52:42 EDT
yes, I can confirm that the intel update makes the workarround unnecessary.

Btw. the driver update is really great!! This is the first time with F13 I can now switch to my external monitor. Hopefully this will go into updates soon.
Comment 22 Adel Gadllah 2010-07-18 05:04:51 EDT
(In reply to comment #21)
> yes, I can confirm that the intel update makes the workarround unnecessary.

But you want the "workaround" anyway (as I pointed out above it has other benefits than just "fixing" this bug).
Comment 23 Johannes Postler 2010-07-28 10:47:00 EDT
(In reply to comment #18)
> Anyone else find fullscreen Flash *does* work with
> xorg-x11-drv-intel-2.12.0-1.fc13.x86_64, even without the mms.cfg hack?    

I can confirm that. And, indeed, I can feel the performance increase!
Comment 24 Adel Gadllah 2010-08-16 13:33:31 EDT
*** Bug 624425 has been marked as a duplicate of this bug. ***
Comment 25 Erik M Jacobs 2010-08-16 20:41:44 EDT
with 2.12.0-1.fc13 running on Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller, full-screen flash (youtube) + desktop effects still freezes/doesn't play.

disabling desktop effects makes flash full screen work.

the work-around in comment #6 makes it work with desktop effects enabled.
Comment 26 MoDeM 2010-09-23 22:07:46 EDT
Excelente bajo Fedora 13 32 bits me funciono lo posteado en el comentario Nº6
lo probé bajo Opera 10.62 y Firefox 3.6.7 en un ThinkPad r61

Gracias
Comment 27 steve mold 2010-10-30 06:00:24 EDT
The fix in comment #6 worked a treat!
Comment 28 cnestor 2011-01-22 11:57:42 EST
fix in comment#6 works great for me! fedora 14 x64.
2.6.35.10-74.fc14.x86_64 #1 SMP

Note You need to log in before you can comment on or make changes to this bug.