Bug 609032 - kvm: 9480: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 9480: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jes Sorensen
Virtualization Bugs
: Reopened
: 812413 (view as bug list)
Depends On: 507085
Blocks: 816308
  Show dependency treegraph
 
Reported: 2010-06-29 04:57 EDT by Ales Kozumplik
Modified: 2015-05-20 09:34 EDT (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 507085
: 816308 (view as bug list)
Environment:
Last Closed: 2010-06-30 08:41:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Ales Kozumplik 2010-06-29 04:58:34 EDT
I'm seeing lots of these on our RHEL6 kvm server too:

kvm: 29697: cpu0 unhandled wrmsr: 0x198 data 0
kvm: 11602: cpu0 unhandled wrmsr: 0x198 data 0
kvm: 30050: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0x0
kvm: 30050: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 30050: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffe7a453
kvm: 30050: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
kvm: 29697: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0x0
kvm: 29697: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 29697: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffe7a453
kvm: 29697: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
kvm: 11602: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0x0
kvm: 11602: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 11602: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffe7a453
kvm: 11602: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
kvm: 29697: cpu0 unhandled wrmsr: 0x198 data 0
kvm: 29697: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0x0
kvm: 29697: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 29697: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffe7a453
kvm: 29697: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
Comment 3 RHEL Product and Program Management 2010-06-29 05:23:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Jes Sorensen 2010-06-29 07:13:57 EDT
Question, in every case when you see these error messages, is that with windows guests, or does it happen with Linux guests as well?

I need to know which guest OSes show this behavior, and if you have a RHEL6 guest on one of the systems showing it, please include the output of /proc/cpuinfo from within the guest.

Thanks,
Jes
Comment 5 Ales Kozumplik 2010-06-29 11:15:10 EDT
All of the guests are rhel6:

/proc/cpuinfo:
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 2
model name	: QEMU Virtual CPU version 0.12.1
stepping	: 3
cpu MHz		: 1595.715
cache size	: 4096 KB
fpu		: yes
fpu_exception	: yes
cpuid level	: 4
wp		: yes
flags		: fpu de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pse36 clflush mmx fxsr sse sse2 syscall nx lm up rep_good unfair_spinlock pni cx16 hypervisor lahf_lm
bogomips	: 3191.43
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management:


It's a 2.6.32-37.el6.x86_64 kernel.

The exact dmesg output corresponding to an exactly one machine start is:
kvm: 5156: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0x0
kvm: 5156: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 5156: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffe7a6bd
kvm: 5156: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079

kvm: 5156: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0x0
kvm: 5156: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 5156: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffe7a6bd
kvm: 5156: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079

I hope that helps.
Ales
Comment 6 John Priddy 2010-06-29 14:31:30 EDT
Per the old bug, also seeing the same on a 5.5 machine (different hardware now, though):

HOST:
--------------------
[jpriddy@rector ~]$ dmesg | grep unimplemented
kvm: 7770: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
...
kvm: 7660: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
...
kvm: 7701: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
...
kvm: 7730: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
...
kvm: 8361: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
...
kvm: 7770: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079

...etc, etc.

Pattern seems to be the those lines repeating 3 times each, sometimes more.

[jpriddy@rector ~]$ cat /proc/cpuinfo | grep "model name"
model name	: Genuine Intel(R) CPU                  @ 2.40GHz

[jpriddy@rector ~]$ uname -r
2.6.18-194.3.1.el5

[jpriddy@rector ~]$ cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.5 (Tikanga)


[jpriddy@rector ~]$ rpm -qa | grep kvm
kvm-83-164.el5_5.9
etherboot-zroms-kvm-5.4.4-13.el5
kmod-kvm-83-164.el5_5.9
kvm-qemu-img-83-164.el5_5.9
--------------------




Guests on this system are mostly RHEL5.5 (6 vms total) all are RHEL, but no RHEL6.

GUEST:
--------------------
[jpriddy@sat01 ~]$ cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 6
model name	: QEMU Virtual CPU version 0.9.1
stepping	: 3
cpu MHz		: 2393.888
cache size	: 32 KB
fpu		: yes
fpu_exception	: yes
cpuid level	: 4
wp		: yes
flags		: fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx lm up pni
bogomips	: 4787.77
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management:
--------------------


I can stand up a RHEL6 guest on this if that helps.
Comment 7 John Priddy 2010-06-29 15:16:29 EDT
If it helps...  just confirmed, *all* vm systems on this host are at least RHEL5.5.
Comment 8 Jes Sorensen 2010-06-30 08:41:38 EDT
Ok, did a bit more checking of this.

From the adds above:
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model  : 6

All the instances of writes to MSR 0xc1 and 0x186 as the ones you report
are done in the guest kernel via native_write_msr_safe() which is a safe
function for probing. Note that with cpu_family 6 which is P6, PMU support
is not specified via CPUID leaf 0xa, so the kernel has to probe for it,
which is what you are seeing.

This is harmless and expected behaviour.

Closing

Jes
Comment 9 Harold Miller 2012-04-13 14:02:09 EDT
*** Bug 812413 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.