Bug 816308 - kvm: 9480: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 9480: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.4
All Linux
high Severity high
: rc
: 6.4
Assigned To: Karen Noel
Virtualization Bugs
: Reopened
Depends On: 507085 609032
Blocks: 782183 810856
  Show dependency treegraph
 
Reported: 2012-04-25 14:48 EDT by Amador Pahim
Modified: 2013-02-21 01:09 EST (History)
29 users (show)

See Also:
Fixed In Version: kernel-2.6.32-301.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 609032
Environment:
Last Closed: 2013-02-21 01:09:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amador Pahim 2012-04-25 14:48:04 EDT
This bug has been copied from  bug #609032.

Solved in upstream and proposed to be backported to 6.4, in order to reduce support load.

Patch successful applied and tested to kernel-2.6.32-220.4.1:


commit c94c3ba901f87115cf574044e7faabfb1d0251fb
Author: Avi Kivity <avi@redhat.com>
Date:   Wed Sep 1 10:23:35 2010 +0300

    KVM: Don't save/restore MSR_IA32_PERF_STATUS

    It is read/only; restoring it only results in annoying messages.

    Signed-off-by: Avi Kivity <avi@redhat.com>

--- a/x86/x86.c	2011-04-07 13:49:17.000000000 +0200
+++ b/x86/x86.c	2011-04-07 13:49:33.000000000 +0200
@@ -715,7 +715,7 @@
 #ifdef CONFIG_X86_64
 	MSR_CSTAR, MSR_KERNEL_GS_BASE, MSR_SYSCALL_MASK, MSR_LSTAR,
 #endif
-	MSR_IA32_TSC, MSR_IA32_PERF_STATUS, MSR_IA32_CR_PAT, MSR_VM_HSAVE_PA
+	MSR_IA32_TSC, MSR_IA32_CR_PAT, MSR_VM_HSAVE_PA
 };
 
 static unsigned num_msrs_to_save;
Comment 1 Przemyslaw Sztoch 2012-06-08 18:19:44 EDT
?!
Comment 2 RHEL Product and Program Management 2012-07-10 03:49:41 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 22:06:35 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Suqin Huang 2012-07-12 05:35:31 EDT
Hi avi,
Can you give some suggestion how to verify this bug.

no stable step to get message: 

"9480: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079"

Thanks
Suqin
Comment 5 Avi Kivity 2012-07-12 08:17:05 EDT
Starting a Linux guest should work, perhaps need to 'info registers' to trigger it.
Comment 6 Suqin Huang 2012-07-12 22:21:31 EDT
update the component to kernel according to the patch in comment0
Comment 7 RHEL Product and Program Management 2012-07-12 22:39:57 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 8 Karen Noel 2012-08-01 19:15:55 EDT
Posted patch to RHEL6.4 on 07/31/2012:

[RHEL6.4 PATCH][x86] KVM: Don't save/restore MSR_IA32_PERF_STATUS
Comment 9 Jarod Wilson 2012-08-24 15:26:16 EDT
Patch(es) available on kernel-2.6.32-301.el6
Comment 12 Shaolong Hu 2012-12-14 02:49:00 EST
Test with qemu-kvm-0.12.1.2-2.340.el6.x86_64:

we won't see following message any more:
"9480: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079"

however we still get:
kvm: 6149: cpu0 unhandled wrmsr 0x40000000 data 0
kvm: 6149: cpu0 unhandled rdmsr 0x40000000


Hope this is enough to verify the bug.
Comment 15 errata-xmlrpc 2013-02-21 01:09:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2013-0496.html

Note You need to log in before you can comment on or make changes to this bug.