Bug 609359 - kernel refused to let me enter luks password, preventing boot
Summary: kernel refused to let me enter luks password, preventing boot
Status: CLOSED DUPLICATE of bug 609377
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 609377
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-30 05:07 UTC by Eric Blake
Modified: 2010-07-01 15:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 15:10:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Blake 2010-06-30 05:07:22 UTC
Description of problem:
After 'yum updated' installed kernel 2.6.35-0.13.rc3.git2.fc14.i686.PAE, I was no longer able boot, because I have / mounted on an encrypted partition and I was unable to enter the luks password.  Using grub to revert back to kernel 2.6.35-0.2.rc3.git0.fc14.i686.PAE let me boot again.

Version-Release number of selected component (if applicable):
kernel-2.6.35-0.13.rc3.git2.fc14.i686.PAE

How reproducible:
100%


Steps to Reproduce:
1. Boot
2. Try to enter password at prompt about luks opening encrypted partition /dev/sda3
3.
  
Actual results:
No keyboard response, and no * were echoed - I could not enter a password, and without /, I could not boot.  Not even ctrl-alt-delete would reboot; I had to hard power cycle to get back to keyboard response at the grub menu.

Expected results:
Allow password entry to unlock / and complete booting

Additional info:
I have /dev/sda2 mounted as /boot unencrypted, and /dev/sda4 encrypted as an lvm group with both / and swap as lvm partitions within that group.

Comment 1 Paul Bolle 2010-06-30 07:56:17 UTC
Probably same issue as bug #609377 (which was files shortly after this bug).

Comment 2 Eric Blake 2010-06-30 12:13:53 UTC
Yes, this was on a Thinkpad laptop.

Comment 3 sd.domrep 2010-06-30 12:41:22 UTC
bug #609377 is my bug, and my laptop made of Lenovo = 3000 C100.

New kernel announced on rawhide mail list:
kernel-2.6.35-0.15.rc3.git3.fc14
--------------------------------
* Tue Jun 29 2010 Kyle McMartin <kyle at redhat.com> 2.6.35-0.15.rc3.git3
- 2.6.35-rc3-git3
- i915-fix-crt-hotplug-regression.patch: attempt to solve the gm45 hotplug
  irq storm.

* Mon Jun 28 2010 Chuck Ebbert <cebbert at redhat.com>
- ppc64: enable active memory sharing and DLPAR memory remove (#607175)

Nothing about our bug, so I will try later.

Comment 4 Chuck Ebbert 2010-07-01 15:10:23 UTC

*** This bug has been marked as a duplicate of bug 609377 ***


Note You need to log in before you can comment on or make changes to this bug.