Bug 609377 - 2.6.35-0.13.rc3.git2.fc14 = laptop keyboard doesn't function.
2.6.35-0.13.rc3.git2.fc14 = laptop keyboard doesn't function.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 609359 609787 (view as bug list)
Depends On:
Blocks: 609359
  Show dependency treegraph
 
Reported: 2010-06-30 02:26 EDT by sd.domrep
Modified: 2010-07-01 11:11 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 11:11:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of 2.6.35-0.13.rc3.git2.fc14.i686 booting (41.64 KB, text/plain)
2010-06-30 05:39 EDT, Paul Bolle
no flags Details
Dmesg of the kernel-2.6.35-0.2.rc3.git0.fc14 (34.55 KB, text/plain)
2010-06-30 13:08 EDT, sd.domrep
no flags Details
dmesg of 2.6.35-0.2.rc3.git0.fc14.i686 booting (41.58 KB, text/plain)
2010-06-30 13:51 EDT, Paul Bolle
no flags Details

  None (edit)
Description sd.domrep 2010-06-30 02:26:54 EDT
Description of problem:
After kernel update from 2.6.35-0.2.rc3.git0.fc14 to 2.6.35-0.13.rc3.git2.fc14, my laptop keyboard became dead. It doesn't react on "capslock" key = LED doesn't turn on, "enter" doesn't work also.
It is impossible to change tty.


Version-Release number of selected component (if applicable):
kernel 2.6.35-0.13.rc3.git2.fc14
SLIM

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Paul Bolle 2010-06-30 03:51:51 EDT
0) Similar issue here (kernel-2.6.35-0.2.rc3.git0.fc14.i686 on IBM ThinkPad T41, both runlevel 3 and 5).

1) Note that input from the mouse is also ignored (for lack of a better term). So maybe all input is lost somehow.
Comment 2 Paul Bolle 2010-06-30 04:48:34 EDT
For what it's worth, logging in and typing over a serial line and over ssh both work (serial line feels rather sluggish, but that's probably to be expected at 9600 baud).
Comment 3 sd.domrep 2010-06-30 05:11:43 EDT
Can you get console and check any error messages?
Comment 4 Paul Bolle 2010-06-30 05:39:39 EDT
Created attachment 427926 [details]
dmesg of 2.6.35-0.13.rc3.git2.fc14.i686 booting

0) Would dmesg do? 

1) Some errors there, but nothing that is obviously related to this issue.
Comment 5 Paul Bolle 2010-06-30 08:25:01 EDT
(In reply to comment #0)
> Description of problem:
> After kernel update from 2.6.35-0.2.rc3.git0.fc14 to 2.6.35-0.13.rc3.git2.fc14,
> my laptop keyboard became dead. [...]    

Bug #609359 is about another ThinkPad with a similar problem. Is your laptop perhaps a ThinkPad too?
Comment 6 sd.domrep 2010-06-30 08:43:40 EDT
My laptop as well Lenovo, but it is 3000 C100.

The question is - how to install or update new kernel through "yum upadate" and do not remove previous one?

Otherwise I won't be able to boot.
Comment 7 Stanislaw Gruszka 2010-06-30 09:14:12 EDT
(In reply to comment #6)
> My laptop as well Lenovo, but it is 3000 C100.
> 
> The question is - how to install or update new kernel through "yum upadate" and
> do not remove previous one?

Normally previous kernel is not removed, you can choose kernel during boot. 
See if you have "timeout=5" line in /boot/grub/grub.conf - this is 5 second deley to before automatic boot of default kernel.

Could you check if blacklisting thinkpad_acpi module helps?
Comment 8 sd.domrep 2010-06-30 09:25:31 EDT
Yum deletes third kernel, which actually I use to boot from, and yum will remove it, because it installs new one and good one will be come "third".
My laptop is not ThinkPad, it is Lenovo 3000 C100.
I will think about to disable ACPI.
Comment 9 Paul Bolle 2010-06-30 11:43:32 EDT
(In reply to comment #7)
> > Could you check if blacklisting thinkpad_acpi module helps?

On my IBM ThinkPad T41 that doesn't help.
Comment 10 Paul Bolle 2010-06-30 11:45:51 EDT
(In reply to comment #8)
> Yum deletes third kernel, which actually I use to boot from, and yum will
> remove it, because it installs new one and good one will be come "third".

Can't you just manually install an rpm of a working kernel?
Comment 11 Stanislaw Gruszka 2010-06-30 11:55:12 EDT
Please attach dmesg from working kernel for compare.
Comment 12 sd.domrep 2010-06-30 13:06:09 EDT
Ok, kernel-2.6.35-0.15.rc3.git3.fc14 did not make any difference. Keyboard doesn't show any sign of life.
Booted on 2.6.35-0.2.rc3.git0.fc14.

Dmesg of the kernel-2.6.35-0.15.rc3.git3.fc14 is attached.
Comment 13 sd.domrep 2010-06-30 13:08:48 EDT
Created attachment 428046 [details]
Dmesg of the kernel-2.6.35-0.2.rc3.git0.fc14
Comment 14 Paul Bolle 2010-06-30 13:51:46 EDT
Created attachment 428054 [details]
dmesg of 2.6.35-0.2.rc3.git0.fc14.i686 booting

(In reply to comment #11)
> Please attach dmesg from working kernel for compare.

_working_ kernel dmesg attached.
Comment 15 Karsten Roch 2010-06-30 14:53:35 EDT
Same issue here, but not on a laptop. I have a standard desktop AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ with an nvidia card GS8400.

kernel-2.6.35-0.15.rc3.git3.fc14 and kernel2.6.35-0.13.rc3.git2.fc14 are not working, Keyboard and mouse (both are PS/2) are dead. 

I include a diff between dmesg and dmesg.old here:

http://pastebin.com/syKUKvQb

Regards
Karsten
Comment 16 sd.domrep 2010-06-30 15:23:14 EDT
New kernel may solve our problem, will see soon:

Changelog	
* Wed Jun 30 2010 Kyle McMartin <kyle@redhat.com> 2.6.35-0.19.rc3.git4
- 2.6.35-rc3-git4

* Tue Jun 29 2010 Chuck Ebbert <cebbert@redhat.com>
- Disable Intel Moorestown support -- it breaks PC keyboard controllers.
Comment 17 Stanislaw Gruszka 2010-07-01 04:15:30 EDT
Yes, please check out:
http://koji.fedoraproject.org/koji/buildinfo?buildID=180549
Comment 18 Paul Bolle 2010-07-01 04:43:44 EDT
(In reply to comment #17)
> http://koji.fedoraproject.org/koji/buildinfo?buildID=180549    

That build (2.6.35-0.19.rc3.git4.fc14.i686) seems to fix it over here.
Comment 19 sd.domrep 2010-07-01 07:55:44 EDT
Yes, I confirm that 2.6.35-0.19.rc3.git4.fc14.i686 solved keyboard problem on my Lenovo 3000.

I think, time to close this bug.
Comment 20 Paul Bolle 2010-07-01 08:13:18 EDT
Administrative nit picking: I'm not sure this can already be closed (is a kernel with the fix we tested scheduled to be shipped already?). Moreover, NOTABUG is clearly wrong: "The problem described is not a bug. An [explanation] of why this resolution has been chosen should be supplied." (see: https://bugzilla.redhat.com/page.cgi?id=fields.html#status ).
Comment 21 sd.domrep 2010-07-01 09:19:59 EDT
Sorry about this, I change it.

Update of this kernel in the mail list:
http://lists.fedoraproject.org/pipermail/devel/2010-July/138109.html
Comment 22 Chuck Ebbert 2010-07-01 11:10:23 EDT
*** Bug 609359 has been marked as a duplicate of this bug. ***
Comment 23 Chuck Ebbert 2010-07-01 11:10:49 EDT
*** Bug 609787 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.