Bug 609443 - syslinux-4.05 is available
syslinux-4.05 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks: 563527 603277
  Show dependency treegraph
 
Reported: 2010-06-30 06:23 EDT by Upstream Release Monitoring
Modified: 2012-04-04 07:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 07:31:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2010-06-30 06:23:25 EDT
Latest upstream release: 4.00
Current version in Fedora Rawhide: 3.84
URL: http://www.kernel.org/pub/linux/utils/boot/syslinux/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 1 Upstream Release Monitoring 2010-07-03 06:22:20 EDT
Latest upstream release: 4.01
Current version in Fedora Rawhide: 3.84
URL: http://www.kernel.org/pub/linux/utils/boot/syslinux/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 2 Upstream Release Monitoring 2010-07-22 06:24:33 EDT
Latest upstream release: 4.02
Current version in Fedora Rawhide: 3.84
URL: http://www.kernel.org/pub/linux/utils/boot/syslinux/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 3 Jasper O'neal Hartline 2010-08-05 00:49:17 EDT
I would be glad to see an update for this package.
It would help livecd-tools move along since there have been reports since July of 2009 where people were wanting to use Ext4 filesystems.

https://admin.fedoraproject.org/pkgdb/acls/bugs/livecd-tools?_csrf_token=e077005608e99f2683ea9d5a1835e9d6fd5f3ea3

In particular:
https://bugzilla.redhat.com/show_bug.cgi?id=563527
https://bugzilla.redhat.com/show_bug.cgi?id=603277
Comment 4 Upstream Release Monitoring 2010-10-26 15:27:33 EDT
Latest upstream release: 4.03
Current version in Fedora Rawhide: 4.02
URL: http://www.kernel.org/pub/linux/utils/boot/syslinux/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 5 Perazim 2010-12-01 08:35:22 EST
There is a bug in 4.02 that is fixed in 4.03. This is in isohybrid and it prevents livecd-iso-to-disk from creating larger iso images. Pushing this through would help those needing to create live custom images for f-14.
Comment 6 Account closed by user 2011-01-08 05:01:48 EST
Changes in 4.03

    * Don't hang if no configuration file is found.
    * Better support for booting from MBRs which don't pass handover information.
    * EXTLINUX: Try to be smarter about finding the partition offset.
    * chain.c32: support chainloading Dell Real Mode Kernel (Gene Cumm).
    * chain.c32: fix booting in CHS mode.
    * rosh.c32 updated (Gene Cumm).
    * Fix the -s option to the syslinux/extlinux installer (Arwin Vosselman).
    * isohybrid: fix padding of large images (PJ Pandit).
Comment 7 Account closed by user 2011-02-15 16:13:58 EST
ping!

Any chance of having 4.03 in f-15 ?
Comment 8 Upstream Release Monitoring 2011-04-19 06:54:26 EDT
Latest upstream release: 4.04
Current version in Fedora Rawhide: 4.02
URL: http://www.kernel.org/pub/linux/utils/boot/syslinux/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 9 Account closed by user 2011-04-19 08:02:46 EDT
Changes in 4.04:

	* PXELINUX: Fix handling of unqualified DNS names.
	* PXELINUX: Fix timer bug when PXELINUX might be unloaded
	  (Gene Cumm).
	* core/writedec.inc: Fix duplicate declaration and overflow
	  (Gene Cumm).
	* GCC 4.5 fixes.
	* sample directory: Fix Makefile include (Gene Cumm).
	* ver.com: New universal DOS/COMBOOT application to display
	  version information (includes DRMK) (Gene Cumm).
	* rosh.c32: updated; Using getopt() for internal commands to aid
	  parsing options; Fix bugs in ls; add warm reboot and echo
	  (Gene Cumm).
	* com32: fix a file descriptor leak.
	* gfxboot.c32: handle TEXT..ENDTEXT; error out on no LABELs
	  found (Sebastian Herbszt).
	* Fix booting on non-partitioned devices.
	* MBR, isohybrid: Workaround for a BIOS issue on Acer
	  Travelmate and possibly other machines.
        * COM32: Adding ACPI parsing libary
        * HDT: Release 0.4.1 to support ACPI parsing, 
          improved mutli-core/cpu reporting 
	* LUA: Updating to 5.1.4-2
	* SYSLINUX: core/diskstart.inc: Reset DS after checksum in case
	  it isn't 0 (Gene Cumm).
	* win64: Script update for additional mingw compiler names
	  (Gene Cumm).
	* diag: New directory for diagnostic-related tools.  Add a
	  handoff MBR/VBR and geometry display images (Gene Cumm).
	* MEMDISK: use "mem=" parameter to mark available memory above
	  this point as reserved (core already does alignment) (Gene Cumm).
	* MEMDISK: Additional disk probe checks and debug output
	  (Shao Miller, Gene Cumm).
	* gpxe: add gpxelinuxk.0, based off of undionly.kpxe + new
	  script (Gene Cumm).
	* isohybrid: install the isohdpfx*.bin/isohdppx*.bin files to
	  make isohybrid images in one step with GNU xorriso.
	* PXELINUX: disable a hack that would make localboot work on
	  some machines, but break just about as many.  Some machines
	  which worked with "localboot 0" in previous versions may
	  need "localboot -1" in this one.  If you have a machine
	  which requires "localboot -1", a copy of the dmidecode
	  or sysdump output would be appreciated.
	* Include a set of diagnostics by Gene Cumm.
	* Fixes for gcc 4.6 and binutils 2.21.51.
	* chain.c32: Allow "uuid" as a synonym to "guid".
	* Handle directory names starting with .. for vfat and
	  iso9660.
	* New MENU HIDDENKEY command to provide a one-keystroke way to
	  activate a boot option from a hidden menu intro screen.
Comment 10 Account closed by user 2011-10-26 18:55:10 EDT
ping!

Is there anything wrong in 4.04 ?
Comment 11 Perazim 2011-11-02 03:41:23 EDT
Tested and it fixes the problem reported in comment 5. Now somebody needs to put this in updates.
Comment 12 Upstream Release Monitoring 2011-12-10 07:18:23 EST
Latest upstream release: 4.05
Current version in Fedora Rawhide: 4.02
URL: http://www.kernel.org/pub/linux/utils/boot/syslinux/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 13 Account closed by user 2011-12-10 07:23:15 EST
Changes in 4.05:

	* HDT updated, and now supports uploading data to a TFTP
	  server.
	* ISOLINUX: remove the .img file support; it has been broken
	  on virtually all systems since the beginning, and has been
	  totally broken since 4.00 at least.  Use MEMDISK instead.
	* chain.c32: Support chaining ReactOS' FreeLdr (Shao Miller)
	* isohybrid: -m option to add support for Mac EFI booting.
        * ifmemdsk.c32: Choose boot option based on presence of
	  MEMDISK.
	* Remove bogus distributed mk-lba-img binary.
	* The Syslinux project has a new, cool logo by Abi
	  "ixxvil" Rasheed (doc/logo/*).
Comment 14 Account closed by user 2012-02-15 14:08:11 EST
done, thanks.

Note You need to log in before you can comment on or make changes to this bug.