Bug 609784 - RHEL6 cannot get ip if keep network 'Connect Automatically' not selected as default during installation
Summary: RHEL6 cannot get ip if keep network 'Connect Automatically' not selected as d...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
high
Target Milestone: rc
: ---
Assignee: Ruediger Landmann
QA Contact: ecs-bugs
URL:
Whiteboard:
Keywords: Documentation, Regression, Reopened
: 592071 615208 (view as bug list)
Depends On:
Blocks: 563347
TreeView+ depends on / blocked
 
Reported: 2010-07-01 05:58 UTC by zhanghaiyan
Modified: 2010-11-11 15:34 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In version 6 of Red Hat Enterprise Linux, network interface configuration screen was replaced with NetworkManger Connection Editor which lead to a change concerning cases of DVD installs where network is not enabled or configured explicitly during install. In version 5, first network device was activated after reboot using DHCP, as preselected by default in network configuration screen. In version 6, a device has to be configured during install to be activated automatically after reboot, which can be done by checking "Connect Automatically" in Connection Editor invoked by "Configure Network" button. Another option is to use kickstart network command.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 15:34:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description zhanghaiyan 2010-07-01 05:58:03 UTC
Description of problem:
RHEL6-20100622.1 guest cannot get ip if don't select network 'Connect Automatically' during installation process

Version-Release number of selected component (if applicable):
- libvirt-0.8.1-12.el6.x86_64
- kernel-2.6.32-40.el6.x86_64
- qemu-img-0.12.1.2-2.90.el6.x86_64
- qemu-kvm-0.12.1.2-2.90.el6.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Local download RHEL6.0-20100622.1-Server-i386-DVD1.iso from http://porkchop.devel.redhat.com/brewroot/repos
2. Launch virt-manager to install rhel6-20100622 guest from iso image
3. During guest installation process, keep Configure Network -> System eth0 -> Edit -> Connect Automatically NOT selected as default
4. After guest is installed, login the guest, 
# cat /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE="eth0"
HWADDR="00:21:9B:7D:F9:71"
NM_CONTROLLED="yes"
ONBOOT="no"
5. Edit ONBOOT="no" to ONBOOT="yes"
6. # service network restart  
7. # ifconfig

Actual results:
step7, eth0 cannot get ip address, and there lack of 1 line code 'BOOTPROTO='dhcp'' in 
/etc/sysconfig/network-scripts/ifcfg-eth0. After add this line then restart network service, eth0 can get ip successfully 

Expected results:
step7, eth0 could get ip address and 'BOOTPROTO='dhcp'' should be automatically generated in /etc/sysconfig/network-scripts/ifcfg-eth0

Additional info:
1. Exactly the same step, no such bug is found on such as rhel5 guest
2. If select Configure Network -> System eth0 -> Edit -> Connect Automatically manually during guest installation process, after login guest, eth0 can get ip automatically 
# cat /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE="eth0"
BOOTPROTO='dhcp'
HWADDR="00:21:9B:7D:F9:71"
NM_CONTROLLED="yes"
ONBOOT="yes"

Comment 3 RHEL Product and Program Management 2010-07-01 06:23:19 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Yan Tian 2010-07-01 06:24:30 UTC
The default network 'Connect Automatically' is unchecked.

Comment 5 zhanghaiyan 2010-07-01 07:11:44 UTC
Install host with rhel6-i386-snapshot6 CD image, found the same bug. So this should be anaconda bug.

Comment 6 Hans de Goede 2010-07-01 09:30:00 UTC
Hi,

If you are installing from an iso you are not using the network during installation, so logically the network is not configured after installation.

If you want to configure the network, either do so after installation using the usual tools, or press the configure network button on the screen in the installer 
where you can enter the hostname.

Regards,

Hans

Comment 11 wangyimiao 2010-07-14 08:45:51 UTC
Reproduce this issue with build: 'RHEL6.0-20100701.3-Server-x86_64'.

Comment 12 wangyimiao 2010-07-14 08:55:53 UTC
Reproduce this issue with latest build: 'RHEL6.0-20100707.4-Server-x86_64'.

Comment 13 David Cantrell 2010-07-14 15:36:04 UTC
Please see comments #6 and #8 for an explanation of the behavior in RHEL-6.  Setting devel_ack to -

Comment 14 zhanghaiyan 2010-07-15 03:22:17 UTC
(In reply to comment #13)
> Please see comments #6 and #8 for an explanation of the behavior in RHEL-6. 
> Setting devel_ack to -    

As mentioned in comment 9,
For rhel5 installation, eth0 'Active on boot' is *checked* as default during installation process
But for rhel6 installation, eth0 'Active on boot' is 'unchecked' as default during installation process. This cause the host/guest cannot get ip after installation. This should be a bad experience for customers.

This should be a regression bug as mentioned in comment 10

Comment 16 Hans de Goede 2010-07-16 08:40:16 UTC
*** Bug 615208 has been marked as a duplicate of this bug. ***

Comment 17 Radek Vykydal 2010-07-26 13:22:52 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
In version 6 of Red Hat Enterprise Linux, network interface configuration screen was replaced with NetworkManger Connection Editor which lead to a change concerning cases of DVD installs where network is not enabled or configured explicitly during install.  In version 5, first network device was activated after reboot using DHCP, as preselected by default in network configuration screen.
In version 6, a device has to be configured during install to be activated automatically after reboot, which can be done by checking "Connect Automatically" in Connection Editor invoked by "Configure Network" button.
Another option is to use kickstart network command.

Comment 18 Denise Dumas 2010-07-29 19:20:27 UTC
This needs to be added to the Install Guide and it should also have a technical note since it has caused confusion.

Comment 19 Michael Hideo 2010-07-29 22:50:56 UTC
Rudi, ping, can you add this in?

Comment 20 Ruediger Landmann 2010-07-29 23:16:16 UTC
(In reply to comment #19)
> Rudi, ping, can you add this in?    

Absolutely; will take care of this today.

Comment 21 Ruediger Landmann 2010-07-30 04:54:18 UTC
(In reply to comment #20)
> (In reply to comment #19)
> > Rudi, ping, can you add this in?    
> 
> Absolutely; will take care of this today.    

The fix needed here is more significant than I thought. ETA is Tuesday 3 Aug.

Comment 23 Ruediger Landmann 2010-08-08 17:12:45 UTC
Note added in new section in build 0-84 (the whole "Configure Network" procedure was previously missing): 

9.6.1. Edit Network Connections

Important — Manual configuration is often needed
When a Red Hat Enterprise Linux 6 installation boots for the first time, it activates any network interfaces that you configured during the installation process. However, the installer does not prompt you to configure network interfaces on some common installation paths, for example, when you install Red Hat Enterprise Linux from a DVD to a local hard drive.
When you install Red Hat Enterprise Linux from a local installation source to a local storage device, be sure to configure at least one network interface manually if you require network access when the system boots for the first time.

Comment 26 David Cantrell 2010-09-07 13:59:31 UTC
*** Bug 592071 has been marked as a duplicate of this bug. ***

Comment 27 releng-rhel@redhat.com 2010-11-11 15:34:22 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.