Bug 610003 - [abrt] gnome-settings-daemon-2.28.2-6.el6: convert_clipboard: Process /usr/libexec/gnome-settings-daemon was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnome-settings-daemon-2.28.2-6.el6: convert_clipboard: Process /usr/li...
Status: CLOSED DUPLICATE of bug 717739
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-settings-daemon (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: x86_64 Linux
low
medium
Target Milestone: rc
: ---
Assignee: Bastien Nocera
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard: abrt_hash:a851fcad0a2744dc527899c27e9...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-01 12:02 UTC by David Kutálek
Modified: 2011-09-28 12:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-28 12:48:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (56.83 KB, text/plain)
2010-07-01 12:02 UTC, David Kutálek
no flags Details
proposed patch based on upstream code (1.07 KB, patch)
2011-09-28 12:44 UTC, ritz
no flags Details | Diff

Description David Kutálek 2010-07-01 12:02:38 UTC
abrt version: 1.1.7
architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/gnome-settings-daemon
component: gnome-settings-daemon
crash_function: convert_clipboard
executable: /usr/libexec/gnome-settings-daemon
kernel: 2.6.32-37.el6.x86_64
package: gnome-settings-daemon-2.28.2-6.el6
rating: 4
reason: Process /usr/libexec/gnome-settings-daemon was killed by signal 11 (SIGSEGV)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)
time: 1277984246
uid: 501

How to reproduce
-----
Not sure how to reproduce. 
It happened after closing two (all) Opera windows (Opera 10.60 rpm for Other Linux)
Trying this again does not reproduce, some something more had to happen.
It could be also in connection with BZ#609793 - at-spi-registryd crash about 10 seconds later (again).

Comment 1 David Kutálek 2010-07-01 12:02:41 UTC
Created attachment 428366 [details]
File: backtrace

Comment 3 RHEL Product and Program Management 2010-07-01 12:23:11 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 RHEL Product and Program Management 2010-07-15 14:56:43 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 6 RHEL Product and Program Management 2011-01-07 15:59:04 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 7 ritz 2011-09-28 12:44:37 UTC
Created attachment 525332 [details]
proposed patch based on upstream code

commit 89b4c4ca25f282a0440414a9ba55b12364b681b8
Author: Krzysztof Klimonda <kklimonda@ubuntu.com>
Date:   Wed Sep 15 12:29:17 2010 +0200

    Check whether XGetWindowProperty returns no items, and return if so.
    
    Fixes https://bugzilla.gnome.org/show_bug.cgi?id=628526

Comment 8 ritz 2011-09-28 12:48:11 UTC

*** This bug has been marked as a duplicate of bug 717739 ***


Note You need to log in before you can comment on or make changes to this bug.