Bug 610012 - Pressing Ctrl-Alt-F2 and back -> suspend
Summary: Pressing Ctrl-Alt-F2 and back -> suspend
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-power-manager (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-01 12:37 UTC by Taunus
Modified: 2011-11-15 13:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-15 13:17:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Taunus 2010-07-01 12:37:24 UTC
Description of problem:
Redhat 6 beta 2 goes to suspend by itself.

Version-Release number of selected component (if applicable):
rhel 6 beta 2

How reproducible:
In login screen, Press Ctrl-Alt-F2, Press Ctrl-Alt-F1, your laptop is sleepy

Steps to Reproduce:
1. Pressing Ctrl-Alt-F2 in login screen to go to the terminal
2. Press Ctrl-Alt-F1 to come back to the graphical view
3. Thinkpad t400 goes to suspend
  
Actual results:
Goes to suspend

Expected results:
stays awake

Additional info:
Thinkpad t400, ati mobility radeon hd 4370 discrete graphics

Comment 2 RHEL Product and Program Management 2010-07-01 13:03:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Matthew Garrett 2010-07-06 14:22:29 UTC
The kernel doesn't initiate suspend requests - the only thing that does is gnome-power-manager, so reassigning there for the moment to try to get some idea of where the request is coming from.

Comment 4 Richard Hughes 2010-07-06 14:30:19 UTC
Sounds odd. It's most likely g-p-m initiating the suspend, but without logs I can't be sure. Could you please do (as a user):

killall gnome-power-manager
gnome-power-manager --verbose

And then try to reproduce the problem. If it happens, can you attach the full logs to this bug please. Thanks.

Comment 5 Christopher Aillon 2010-07-10 18:08:48 UTC
Possibly a dupe of bug 591935

Comment 6 RHEL Product and Program Management 2010-07-15 14:23:13 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 7 Taunus 2010-08-26 12:43:24 UTC
Yes the bug 591935 has better description about the problem. This bug is duplicate of that bug.

Comment 8 Taunus 2010-08-26 13:10:13 UTC
If I kill gnome-power-manager the laptop does not go into suspend anymore when switching to terminal and back. If I run manually "gnome-power-manager --verbose" and switch back and forth it does not go into suspend anymore either.

Comment 9 Taunus 2010-12-03 13:38:18 UTC
This is still an issue with rhel 6 final. Pretty annoying one too. This bug is duplicate of bug 591935

Comment 10 RHEL Product and Program Management 2011-04-04 01:50:53 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 11 Taunus 2011-09-07 10:21:43 UTC
Seems to be fixed.

Comment 12 Richard Hughes 2011-11-15 13:17:49 UTC
(In reply to comment #11)
> Seems to be fixed.

Okay, closing. Thanks for reporting back on the bug.


Note You need to log in before you can comment on or make changes to this bug.