Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 610197 - gnome-system-monitor segfaults at startup
gnome-system-monitor segfaults at startup
Status: CLOSED DUPLICATE of bug 609758
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-system-monitor (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Søren Sandmann Pedersen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 14:19 EDT by Paul Batkowski
Modified: 2014-06-18 05:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-06 10:11:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core file captured from segfault of gnome-system-monitor (3.02 MB, application/octet-stream)
2010-07-01 14:19 EDT, Paul Batkowski
no flags Details

  None (edit)
Description Paul Batkowski 2010-07-01 14:19:02 EDT
Created attachment 428518 [details]
core file captured from segfault of gnome-system-monitor

Description of problem:
When I attempt to launch gnome-system-monitor either from gnome-terminal or if I attempt to add it to my gnome-panel, it segfaults.

Version-Release number of selected component (if applicable):

gnome-system-monitor-2.28.0-5.el6.x86_64
from RHEL 6 beta nightly


How reproducible:
100% Always reproduces after updating to 6/30/2010 nightly.


Steps to Reproduce:
Open a terminal and attempt to start 'gnome-system-monitor'
-or-
Attempt to add gnome-system-monitor to gnome-panel
  
Actual results:
gnome-system-monitor segfaults and leaves behind a nice juicy core file.


Expected results:
gnome-system-monitor starts and docks into the gnome-panel

Additional info:

gdb output:

Core was generated by `                    '.
Program terminated with signal 11, Segmentation fault.
#0  memset () at ../sysdeps/x86_64/memset.S:1016
1016		movdqa %xmm0,(%rdi)
(gdb) bt
#0  memset () at ../sysdeps/x86_64/memset.S:1016
#1  0x0000003f552074f3 in glibtop_get_cpu_s (server=0x3f5540fc60, buf=0x7fff653c7200) at /usr/include/bits/string3.h:86
#2  0x0000003f55205e6a in glibtop_get_cpu_l (server=0x3f5540fc60, buf=0x7fff653c7200) at lib.c:70
#3  0x0000000000410d52 in procman_data_new (client=0x1e241e0 [GConfClient]) at procman.cpp:384
#4  0x0000000000000000 in ?? ()
Comment 2 RHEL Product and Program Management 2010-07-01 14:43:08 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Paul Batkowski 2010-07-06 10:09:15 EDT
Latest build looks good: 

gnome-system-monitor-2.28.0-6.el6.x86_64

gnome-system-monitor starts up and does not crash.
Comment 4 Paul Batkowski 2010-07-06 10:11:07 EDT

*** This bug has been marked as a duplicate of bug 609758 ***

Note You need to log in before you can comment on or make changes to this bug.