Bug 609758 - [abrt] gnome-applets-1:2.28.0-5.el6: memset: Process /usr/libexec/multiload-applet-2 was killed by signal 11 (SIGSEGV)
[abrt] gnome-applets-1:2.28.0-5.el6: memset: Process /usr/libexec/multiload-a...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libgtop2 (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Søren Sandmann Pedersen
desktop-bugs@redhat.com
abrt_hash:36f5a7e596cbe11641c21255ef6...
:
: 609545 610197 611146 613588 617248 621005 622038 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 22:23 EDT by Alex Williamson
Modified: 2014-06-18 05:12 EDT (History)
17 users (show)

See Also:
Fixed In Version: gnome-applets-2.28.0-6.el6 gnome-system-monitor-2.28.0-6.el6 gnome-utils-2.28.1-9.el6 gnome-python2-2.28.0-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 09:46:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (45.88 KB, text/plain)
2010-06-30 22:23 EDT, Alex Williamson
no flags Details
yum list installed (139.48 KB, text/plain)
2010-06-30 23:38 EDT, Alex Williamson
no flags Details
yum history 74 (latest) (8.25 KB, text/plain)
2010-06-30 23:39 EDT, Alex Williamson
no flags Details

  None (edit)
Description Alex Williamson 2010-06-30 22:23:05 EDT
abrt version: 1.1.7
architecture: x86_64
Attached file: backtrace
cmdline: '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' ''
comment: Recent breakage, worked until updates that came in the past couple days.
component: gnome-applets
crash_function: memset
executable: /usr/libexec/multiload-applet-2
kernel: 2.6.32-37.el6.x86_64
package: gnome-applets-1:2.28.0-5.el6
rating: 0
reason: Process /usr/libexec/multiload-applet-2 was killed by signal 11 (SIGSEGV)
release: Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)
time: 1277950713
uid: 500

How to reproduce
-----
1. Try to add system monitor applet to gnome task bar
2.
3.
Comment 1 Alex Williamson 2010-06-30 22:23:07 EDT
Created attachment 428149 [details]
File: backtrace
Comment 3 RHEL Product and Program Management 2010-06-30 22:43:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Ray Strode [halfline] 2010-06-30 23:12:40 EDT
Does it work with and older kernel?
Comment 5 Alex Williamson 2010-06-30 23:38:12 EDT
The kernel hasn't been updated in a while.  yum history & last say I updated yesterday and rebooted, and then today and rebooted.  I only remember this happening today, so I'll attach my installed list and update history for today.
Comment 6 Alex Williamson 2010-06-30 23:38:48 EDT
Created attachment 428161 [details]
yum list installed
Comment 7 Alex Williamson 2010-06-30 23:39:26 EDT
Created attachment 428162 [details]
yum history 74 (latest)
Comment 8 Ray Strode [halfline] 2010-06-30 23:55:59 EDT
ah i didn't realize libgtop2 had been updated recently.  That's almost certainly the culprit.
Comment 9 Ray Strode [halfline] 2010-07-01 00:04:34 EDT
looking at the change, GLIBTOP_NCPU got bumped.

That number is used a public structure definition, so it changed abi.  I think all that needs to happen here is a rebuild of all things that link against libgtop2.
Comment 10 Ray Strode [halfline] 2010-07-02 16:25:26 EDT
packages needing rebuilds:

[rstrode@halfline-d630] (/home/rstrode) <04:24 PM>
$ repoquery --alldeps --whatrequires libgtop2
libgtop2-0:2.28.0-3.el6.x86_64
libgtop2-0:2.28.0-3.el6.i686
gnome-python2-libgtop2-0:2.28.0-4.el6.x86_64
gnome-applets-1:2.28.0-5.el6.x86_64
libgtop2-devel-0:2.28.0-3.el6.x86_64
libgtop2-devel-0:2.28.0-3.el6.i686
gnome-utils-1:2.28.1-8.el6.x86_64
gnome-system-monitor-0:2.28.0-5.el6.x86_64
Comment 11 Ray Strode [halfline] 2010-07-02 17:08:10 EDT
i've confirmed this affects both gnome-system-monitor and the applet.  And I've also confirmed rebuilds fix the issue.
Comment 13 Paul Batkowski 2010-07-06 10:11:07 EDT
*** Bug 610197 has been marked as a duplicate of this bug. ***
Comment 14 Ray Strode [halfline] 2010-07-06 15:50:18 EDT
*** Bug 609545 has been marked as a duplicate of this bug. ***
Comment 15 Christopher Aillon 2010-07-08 09:51:21 EDT
*** Bug 611146 has been marked as a duplicate of this bug. ***
Comment 16 Ray Strode [halfline] 2010-07-12 10:47:46 EDT
*** Bug 613588 has been marked as a duplicate of this bug. ***
Comment 17 Vladimir Benes 2010-07-12 11:02:57 EDT
both of them works now
-> VERIFIED
Comment 18 Ray Strode [halfline] 2010-07-22 12:44:06 EDT
*** Bug 617248 has been marked as a duplicate of this bug. ***
Comment 19 Chad Feller 2010-07-25 15:25:42 EDT
Package: gnome-applets-1:2.28.0-5.el6
Architecture: x86_64
OS Release: Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)


How to reproduce
-----
1. add/load/reload multiload-applet-2 to panel
2.
3.


Comment
-----
This applet stopped working after the RHEL6 beta2 "refresh"  It worked on the first beta, and the 
inital beta2.  After the refresh it crashed the first time I logged into the desktop.  Attempting to 
re-add the applet caused subsequent crashes.
Comment 20 Mihai Harpau 2010-07-27 07:56:23 EDT
Package: gnome-applets-1:2.28.0-5.el6
Architecture: x86_64
OS Release: Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)


How to reproduce
-----
1. I tried to add "System Monitor" applet to upper panel
2.
3.
Comment 21 Ray Strode [halfline] 2010-08-06 17:07:31 EDT
*** Bug 622038 has been marked as a duplicate of this bug. ***
Comment 22 Steven Mercurio 2010-08-10 11:55:03 EDT
Package: gnome-applets-1:2.28.0-5.el6
Architecture: x86_64
OS Release: Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)


How to reproduce
-----
1. Try to add system monitor to panel

** Running in VNC **


Comment
-----

I am running a VNC session
Comment 23 Kevin E. Martin 2010-08-13 14:48:15 EDT
*** Bug 621005 has been marked as a duplicate of this bug. ***
Comment 24 releng-rhel@redhat.com 2010-11-11 09:46:50 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.