Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 610198 - BugZilla install fails. checksetup.pl "Creating contrib/.htaccess... No such file or directory at Bugzilla/Install/Filesystem.pm line 485."
BugZilla install fails. checksetup.pl "Creating contrib/.htaccess... No such ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bugzilla (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 14:19 EDT by Brian LaMere
Modified: 2011-04-23 00:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: bugzilla-3.4.8-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 747772 (view as bug list)
Environment:
Last Closed: 2010-08-26 23:07:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian LaMere 2010-07-01 14:19:12 EDT
Description of problem:

checksetup.pl fails:
"Creating contrib/.htaccess...
No such file or directory at Bugzilla/Install/Filesystem.pm line 485."

Version-Release number of selected component (if applicable):


How reproducible:

every time

Steps to Reproduce:
1. remove previous failed install of bugzilla
2. create new database for bugzilla (note:  I'm not using "bugs")
3. "yum install bugzilla" with db info in /etc/bugzilla/localconfig
  
Actual results:


Expected results:

bugzilla installs

Additional info:

the install of bugzilla attempts to connect to the DB, and acts surprised that it can't; "rpm -e bugzilla" left the "/etc/bugzilla/localconfig" file so I just filled it in.  Recommend making the error a little more meaningful, since it might confuse people who are just installing the package.  No mention of running checksetup.pl is mentioned, for instance.

Creating the contrib directory caused the install to just hang; commenting out the connect info in /etc/bugzilla/localconfig and then installing caused it to complete the install.  At that point I set the connect info again, ran checksetup.pl, and it worked fine.

Which is to say, the contrib directory (/usr/share/bugzilla/contrib) should be created by the package.
Comment 1 Brian LaMere 2010-07-01 14:55:43 EDT
note that due to the fact that the install hangs when the contrib directory exists, I can't think of a way that the install would actually be successful if it runs checksetup.pl?  I'd recommend just displaying text at the end of the package install that tells the user to run the script.

I imagine that the "hanging" was really the checksetup.pl script prompting me for an admin email, but since I don't get all of stdout during a yum install, I wasn't seeing it.  This is the reason I suggest just not running checksetup.pl in the post-install section (assuming) of the rpm at all; just have the user run it after.
Comment 2 Jan ONDREJ 2010-07-06 02:00:46 EDT
Same problem from cron, when yum-cron updated bugzilla to bugzilla-3.4.7-1.fc12.noarch.

No such file or directory at Bugzilla/Install/Filesystem.pm line 485, <DATA>
line 228.

Although it's present in rpm package, this error was displayed. Is it possible, that it was displayed before file was moved?
Comment 3 Emmanuel Seyman 2010-08-18 17:33:09 EDT
Taking.
Comment 4 Fedora Update System 2010-08-18 18:20:50 EDT
bugzilla-3.6.2-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/bugzilla-3.6.2-1.fc14
Comment 5 Fedora Update System 2010-08-18 18:24:10 EDT
bugzilla-3.4.8-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bugzilla-3.4.8-2.fc13
Comment 6 Fedora Update System 2010-08-18 18:24:28 EDT
bugzilla-3.4.8-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/bugzilla-3.4.8-1.fc12
Comment 7 Fedora Update System 2010-08-19 21:29:34 EDT
bugzilla-3.4.8-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bugzilla'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/bugzilla-3.4.8-1.fc12
Comment 8 Fedora Update System 2010-08-26 23:07:09 EDT
bugzilla-3.6.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-08-27 02:51:53 EDT
bugzilla-3.4.8-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-08-27 02:54:53 EDT
bugzilla-3.4.8-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Mitch Davis 2011-04-23 00:18:28 EDT
I am still having this problem on Fedora ARM F13 beta.  Bugzilla in that release is 3.4.5, so it doesn't have this fix.

For anyone in this situation, a workaround is:

  mkdir /usr/share/bugzilla/contrib

Note You need to log in before you can comment on or make changes to this bug.