Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 610239 - [abrt] control-center-1:2.28.1-20.el6: raise: Process /usr/bin/gnome-display-properties was killed by signal 6 (SIGABRT)
[abrt] control-center-1:2.28.1-20.el6: raise: Process /usr/bin/gnome-display-...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-desktop (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
abrt_hash:b1c5d1eaeec34acfe990052676c...
:
: 609061 611794 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 16:00 EDT by David Kutálek
Modified: 2011-10-20 14:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: gnome-desktop-2.28.2-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:30:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (28.02 KB, text/plain)
2010-07-01 16:00 EDT, David Kutálek
no flags Details
Display Preferences dialog (736.25 KB, image/png)
2010-07-01 16:40 EDT, David Kutálek
no flags Details

  None (edit)
Description David Kutálek 2010-07-01 16:00:48 EDT
abrt version: 1.1.7
architecture: x86_64
Attached file: backtrace
cmdline: gnome-display-properties
component: control-center
crash_function: raise
executable: /usr/bin/gnome-display-properties
kernel: 2.6.32-37.el6.x86_64
package: control-center-1:2.28.1-20.el6
rating: 4
reason: Process /usr/bin/gnome-display-properties was killed by signal 6 (SIGABRT)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)
time: 1278013181
uid: 501

comment
-----
Actions taken before this happened:
 - laptop in a dock, connected to external monitor via this dock
 - System -> Shutdown -> Suspend
 - button no. 1 on dock (first step to remove from dock) - caused wake up of laptop
 - button no. 2 on dock (physical remove of laptop from dock)
 - System -> Shutdown -> Suspend again
 - wake up outside the dock, without monitor
 - desktop still "two displays wide", programs displayd outside laptop screen (going to attach a screenshot)
 - therefore trying to fix it via Display preferences...

How to reproduce
-----
1. In Gnome: System -> Preferences -> Display
2. Click Detect Monitors
3. Crash
It happens everytime now - I repeated this crash five times now...
Don't know, whether will be able to reproduce eg. after logout, reboot...
Comment 1 David Kutálek 2010-07-01 16:00:51 EDT
Created attachment 428540 [details]
File: backtrace
Comment 3 RHEL Product and Program Management 2010-07-01 16:23:05 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 David Kutálek 2010-07-01 16:40:04 EDT
Created attachment 428559 [details]
Display Preferences dialog

Just before clicking Detect Monitors button, making it crash.
Note the size of the screenshot - desktop is still enlarged for already disconnected monitor.
Comment 5 Ray Strode [halfline] 2010-07-01 17:38:35 EDT
This is probably a bug in the fix for bug 582564
Comment 6 Ray Strode [halfline] 2010-07-08 13:37:33 EDT
*** Bug 611794 has been marked as a duplicate of this bug. ***
Comment 10 Ray Strode [halfline] 2010-07-08 17:20:07 EDT
So, this crash is from the fix in bug 582564.  The patch basically does 

SetMonitorConfig(GetMonitorConfig ())

to make the server update its internal timestamps.  This is failing with a "BadMatch" error after suspend.  I'm assuming this error is getting caused because the config is changing between the "getting" part and "setting" part as things are waking up.

I'm building a package now that ignores errors in the call which will hopefully be "good enough"
Comment 12 Lubos Kocman 2010-08-05 10:27:15 EDT
Verified on gnome-desktop-2.28.2-8.el6

I haven't faced to this issue while trying to reproduce it according to steps in C#1. Please feel free to reopen this issue if you'll meet this problem again.
Comment 13 releng-rhel@redhat.com 2010-11-10 15:30:29 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.
Comment 14 Ray Strode [halfline] 2011-10-20 14:41:22 EDT
*** Bug 609061 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.