Bug 610255 - Hangs doing dependency calculation when VM given 1GB of RAM
Summary: Hangs doing dependency calculation when VM given 1GB of RAM
Keywords:
Status: CLOSED DUPLICATE of bug 607650
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-01 20:42 UTC by Richard W.M. Jones
Modified: 2010-07-12 20:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-12 20:19:52 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2010-07-01 20:42:57 UTC
Description of problem:

If I give the VM "only" 1 GB of memory then it hangs doing the
dependency calculation.  Upping memory to 2 GB fixes the issue.

Version-Release number of selected component (if applicable):

RHEL 6 beta 2

How reproducible:

Happened once.

Steps to Reproduce:
1. Install RHEL 6 beta 2 in a 1 GB VM from DVD ISO.
2. Select "Desktop".
  
Actual results:

Hangs (or takes many hours) doing dependency calculation.

Expected results:

Should be able to install in what is really quite a lot of memory.

Additional info:

x86_64

Comment 2 RHEL Product and Program Management 2010-07-01 21:03:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Luc de Louw 2010-07-02 06:59:12 UTC
Here it hangs on "Writing storage configuration to disk"
I configured 2GB RAM. With 1GB RAM BZ #610261 applies.

When switching to a console cat /proc/loadavg shows about 1.07. Meminfo shows about 1.6Gbyte free memory.

The lvm command shot off by anaconda went to be a zombie.

Comment 4 Luc de Louw 2010-07-05 14:17:59 UTC
There three related bugs filed: This one, #610261 and #610510.

All of them have in common that the installation failed with this or similar behaviour when installed as a KVM guest. It seems that this bugs are not related to anaconda but with virtio or other KVM related drivers.

Using ESX 4.0 as a virtualization platform, the installation goes trough smoothly, even with only 512Mbyte of RAM.

I'll try to figure out what the problem can be...

Comment 5 Michael Young 2010-07-06 15:46:03 UTC
I had a similar failure installing RHEL6 beta2 under citrix xen with 512MB memory. It got as far as "Transfering image to disk" then froze there. It did work when I increased the memory to 2GB. The first RHEL6 public beta didn't show this problem.

Comment 6 Chris Lumens 2010-07-12 14:09:03 UTC
Is anyone seeing an "Installer exited abnormally" message on tty1?  Can you even switch VTs when the machine hangs?

Comment 7 Richard W.M. Jones 2010-07-12 14:26:35 UTC
Yes, very strange.  I just tried this process again, and this
time the error is as Chris describes:

install exited abnormally [1/1]
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

This however is *not* what I saw when I first reported this bug.

Comment 8 Richard W.M. Jones 2010-07-12 14:30:52 UTC
Now I tried it a third time, and the install proceeds perfectly normally.
So I gather the original bug report is very intermittent.  I will try it over
again a few times.

Comment 9 Richard W.M. Jones 2010-07-12 14:39:30 UTC
I tried it another 3 times, and it worked fine each time.

I did notice that the kernel we shipped in RHEL 6 beta 2 does
tend to cause random segfaults in user applications when
run on top of KVM.  There was a suspicion that this is caused
by KSM.  There's a great deal of randomness in what I'm
seeing in this bug, so it could well be down to the same thing.

Comment 10 Hans de Goede 2010-07-12 20:19:52 UTC
(In reply to comment #9)
> I tried it another 3 times, and it worked fine each time.
> 
> I did notice that the kernel we shipped in RHEL 6 beta 2 does
> tend to cause random segfaults in user applications when
> run on top of KVM. 

Ah, yes, that would make this a dup of bug 607650

> There was a suspicion that this is caused
> by KSM.  There's a great deal of randomness in what I'm
> seeing in this bug, so it could well be down to the same thing.    

Correct, sometimes up to 10 kvm installs are needed to get one to fail.

*** This bug has been marked as a duplicate of bug 607650 ***


Note You need to log in before you can comment on or make changes to this bug.