Bug 610261 - rhel6beta2 - anaconda graphic install exited abnormally
Summary: rhel6beta2 - anaconda graphic install exited abnormally
Status: CLOSED DUPLICATE of bug 607650
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-01 20:56 UTC by Marc Sauton
Modified: 2010-07-12 20:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 20:11:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc Sauton 2010-07-01 20:56:45 UTC
Description of problem:

anaconda seem to fail for me in graphical mode, when trying to install el6b2 as a KVM guest (1GB ram guest) using virt-install


Version-Release number of selected component (if applicable):
RHEL6.0-20100622.1-Server-x86_64-DVD1.iso
trying to install el6 beta2 as a 64bits KVM guest with 1GB ram on a el5.5 64bits KVM host

Red Hat Enterprise Linux Server release 5.5 (Tikanga)
Linux dirsec2-seg.lab.sjc.redhat.com 2.6.18-194.el5 #1 SMP Tue Mar 16 21:52:39 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
libvirt-0.6.3-33.el5


How reproducible:
always


Steps to Reproduce:
1. have a el5.5 64bits KVM host
2. get RHEL6.0-20100622.1-Server-x86_64-DVD1.iso
3. run on KVM host:
virt-install --accelerate  --name=el6b2 --vcpus=1 --ram=1024 --vnc --location=http://... -s 6 --file=...
4. in console, pass language and network config in text mode
5. anaconda starts in graphical mode
6. pass welcome screen, install anyway, select basic storage, hostname, timezone, root password all in graphical mode
7. then fails like below:
  

Actual results:
error message in text mode / console
"
20:47:45 Starting graphical installation.
install exited abnormally [1/1]
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.
"


Expected results:
ability to continue...


Additional info:
had been trying to install el6 beta 2 as a KVM guest on a el5.5 KVM host using virt-install

resulting config file was like:

less /etc/libvirt/qemu/el6b2.xml
<domain type='kvm'>
  <name>el6b2</name>
  <uuid>e6509a4a-8f6d-7ad8-a2f5-f648e858554d</uuid>
  <memory>1048576</memory>
  <currentMemory>1048576</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='x86_64' machine='rhel5.4.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='block' device='disk'>
      <driver name='qemu' cache='none'/>
      <source dev='/dev/VolGroup00/el6b2'/>
      <target dev='hda' bus='ide'/>
    </disk>
    <interface type='bridge'>
      <mac address='54:52:00:14:10:14'/>
      <source bridge='br0'/>
    </interface>
    <serial type='pty'>
      <target port='0'/>
    </serial>
    <console type='pty'>
      <target port='0'/>
    </console>
    <input type='tablet' bus='usb'/>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes' keymap='en-us'/>
  </devices>
</domain>

Comment 1 Chris Lumens 2010-07-01 21:03:32 UTC
What happens if you increase the memory given to the guest?

Comment 3 RHEL Product and Program Management 2010-07-01 21:23:05 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Marc Sauton 2010-07-01 21:30:30 UTC
--ram=1025 fails too
--ram=2028 works ok
--ram=1100 works ok

wondering what should be the very minimum I can use with virt-manager for a KVM
guest (was expecting 1GB ram)

virt-install --accelerate  --name=el6b2test --vcpus=1 --ram=1100 --vnc
--location=http://... -s 6 --file=/dev/VolGroup00/el6b2test

May be the previous --ram=1024 was not exactly 1GB to meet all the minimum
requirements?

If I do not virt-install, but the virt-manager gui, it all works fine as
expected (I prefer the cli)

Comment 5 Brian Lane 2010-07-01 21:56:43 UTC
How are you pointing the install to the .iso? Using --location=http:// will pull from wherever you point to, not the DVD image. This will require additional RAM since it downloads the install.img to the virt (about 120M).

Comment 6 Marc Sauton 2010-07-01 22:32:57 UTC
to a tree vi http, the full command was like:
virt-install --accelerate  --name=el6b2 --vcpus=1 --ram=1024 --vnc --location=http://10.14.7.221/rhel6b2/tree/ -s 6 --file=/dev/VolGroup00/el6b2

Comment 7 Marc Sauton 2010-07-01 22:33:09 UTC
to a tree via http, the full command was like:
virt-install --accelerate  --name=el6b2 --vcpus=1 --ram=1024 --vnc --location=http://10.14.7.221/rhel6b2/tree/ -s 6 --file=/dev/VolGroup00/el6b2

Comment 8 Brian Lane 2010-07-02 00:05:06 UTC
This works fine for me on f13, I even tried with --ram=768

If you can get to tty2 could you cd to /tmp, hit the up-arrow until you see the history line with kill -USR2 in it and execute that. 

It will create a full traceback file named something like anaconda-tb-xHfP8E, attach that file to this bug and I'll see if I can figure out why it is acting differently on your setup.

Comment 9 Hans de Goede 2010-07-02 13:39:21 UTC
Note This is very, very likely a dup of bug 607650.

Comment 10 Luc de Louw 2010-07-05 14:21:34 UTC
I think it is related to virtio drivers, please also see my comment here: https://bugzilla.redhat.com/show_bug.cgi?id=610255#c4

Comment 11 David Cantrell 2010-07-12 20:11:48 UTC

*** This bug has been marked as a duplicate of bug 607650 ***


Note You need to log in before you can comment on or make changes to this bug.