Bug 61043 - "kmod: failed to exec /sbin/modprobe" during hampton beta2 bootup
Summary: "kmod: failed to exec /sbin/modprobe" during hampton beta2 bootup
Status: CLOSED DUPLICATE of bug 62145
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-12 16:36 UTC by Clay Cooper
Modified: 2007-04-18 16:40 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-22 20:28:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg from bigmem kernel (13.74 KB, text/plain)
2002-03-12 16:37 UTC, Clay Cooper
no flags Details

Description Clay Cooper 2002-03-12 16:36:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
On a 6450 w/ hampton beta2 (2.4.9-0.1bigmem), w/ bios A10, 5GB ram, 2GB swap,
and Perc3/SC boot controller. 

Dmesg reports:
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2 

Occurs in up, smp, and bigmem kernels.

Attaching dmesg output from bigmem kernel


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install hampton beta2 on a 6450 w/ Perc3/SC boot controller
2.  Check dmesg for kmod error
3.
	

Actual Results:  Kmod error in dmesg

Expected Results:  No error

Additional info:

Comment 1 Clay Cooper 2002-03-12 16:37:27 UTC
Created attachment 48285 [details]
Dmesg from bigmem kernel

Comment 2 Clay Cooper 2002-03-21 17:36:59 UTC
Not fixed in beta3

Comment 3 Michael K. Johnson 2002-03-28 16:49:46 UTC
Something in user space, I think mkinitrd, is opening a scsi device that
doesn't (yet) exist, and kmod is trying to load the scsi host adapter.  I
do not know what scsi device is being accessed, but in any case this is
not a kernel bug.  The kernel is doing the right thing as far as I can tell.

Comment 4 Clay Cooper 2002-04-04 21:27:53 UTC
Reproduced in beta4

Comment 5 Clay Cooper 2002-04-22 20:28:45 UTC
Reproduced in Hampton gold.

Comment 6 Erik Troan 2002-05-21 21:29:34 UTC

*** This bug has been marked as a duplicate of 62145 ***


Note You need to log in before you can comment on or make changes to this bug.