Bug 62145 - kmod failed to exec /sbin/modprobe
Summary: kmod failed to exec /sbin/modprobe
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mkinitrd   
(Show other bugs)
Version: skipjack-beta1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 61043 62270 (view as bug list)
Depends On:
Blocks: 61901
TreeView+ depends on / blocked
 
Reported: 2002-03-27 21:42 UTC by jmbastia
Modified: 2007-04-18 16:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-21 21:29:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jmbastia 2002-03-27 21:42:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310

Description of problem:
During boot-up, shortly before the init scripts start running, the kernel prints
out:
  kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno=2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot a computer running Skipjack
2. Note kernel messages
3. Watch for "kmod: failed to exec /sbin/modprobe ..." line
4. If you missed the message, run "dmesg | grep modprobe"
	

Actual Results:  The error message appeared on screen.

Expected Results:  The error message should not have appeared.

Additional info:

I tried using both the plain i386 kernel and the i686 kernel, and the error
message existed with both.

Comment 1 Jim Hayward 2002-03-27 22:47:47 UTC
I also am receiving a similiar error on boot. 

SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kernel: scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.5
kernel:         <Adaptec 2930CU SCSI adapter>
kernel:         aic7860: Ultra Single Channel A, SCSI Id=7, 3/253 SCBs

Seems to be harmless my SCSI controller works fine.

Comment 2 Arjan van de Ven 2002-03-28 14:19:34 UTC
Something is touching /dev/sda before it's supposed to; but it ain't the kernel

Comment 3 Bill Nottingham 2002-04-01 20:23:41 UTC
*** Bug 62270 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2002-04-05 16:43:30 UTC
Arjan -- what's happening is that we do the following
1) Load scsi_mod
2) Load sd_mod
3) Load scsi_hostadapter

Between 2 and 3 is when kmod spews errors, which is a definite change in
upstream behavior of loading sd_mod.   Loading sd_mod causing a kmod of
scsi_hostadapter seems a bit strange to me.

Comment 5 David Kobler 2002-05-20 21:00:05 UTC
This shows up on my machine also.  I am running 7.3.  it does not show up on my 
7.2 machine unless I install the kernel rpm from 7.3 on it.  What is the 
difference between the 7.2 kernel and the 7.3 kernel?

Comment 6 Alessandro Vioni 2002-05-21 10:27:08 UTC
I have the same problem with a RH7.3 and initio scsi.

loading scsi_mod module
SCSI subsystem driver revision : 1.00
loading sd_mod module
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter , errno = 2
loading initio module

with RH7.2 i didn't have this little problem.

Comment 7 Erik Troan 2002-05-21 21:29:28 UTC
*** Bug 61043 has been marked as a duplicate of this bug. ***

Comment 8 Erik Troan 2002-05-21 21:45:06 UTC
fixed in mkinitrd 3.3.11 (modprobe symlink was broken; should be a noop)

Comment 9 David Kobler 2002-05-22 01:03:46 UTC
where can I find mkinitrd 3.3.11?

Comment 10 David Kobler 2002-05-23 01:05:39 UTC
I found the updated package in the rawhide dir.  It does NOT fix the 
problem!!!!  I still get "kmod: failed to exec /sbin/modprobe -s -k 
scsi_hostadapter, errno = 2"



Note You need to log in before you can comment on or make changes to this bug.