Bug 610749 - PartitionException: Attempting to remove a partition that is not owned by any disk.
PartitionException: Attempting to remove a partition that is not owned by any...
Status: CLOSED DUPLICATE of bug 592339
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
anaconda_trace_hash:976f2aeffac5fbdb3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 07:08 EDT by Alexander Todorov
Modified: 2010-07-02 07:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 07:11:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (217.47 KB, text/plain)
2010-07-02 07:08 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2010-07-02 07:08:48 EDT
The following was filed automatically by anaconda:
anaconda 13.21.50 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 269, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib64/python2.6/site-packages/parted/decorators.py", line 31, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in removePartition
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 277, in removePartition
    self.partedDisk.removePartition(partition)
  File "/usr/lib/anaconda/storage/devices.py", line 1352, in destroy
    self.disk.originalFormat.removePartition(self.partedPartition)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 218, in execute
    self.device.destroy()
  File "/usr/lib/anaconda/storage/devicetree.py", line 705, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 293, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1335, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1473, in keyRelease
    self.nextClicked()
PartitionException: Attempting to remove a partition that is not owned by any disk.
Comment 1 Alexander Todorov 2010-07-02 07:08:53 EDT
Created attachment 429030 [details]
Attached traceback automatically from anaconda.
Comment 2 Alexander Todorov 2010-07-02 07:09:22 EDT
Steps to reproduce with 0603.1/anaconda 13.21.50

1) On 10G disk create this layout
  1.1) /boot - 500M
  1.2) swap - 2048M
  1.3) / - 4096M
The layout as shown in anaconda UI is:
vda1 - /boot
vda2 - /
vda3 - swap
Free space

2) Start a second install and do this
  2.1) Format vda1 for /boot
  2.2) Delete vda2
  2.3) Format vda3 for swap
  2.4) Create new partition for / and make it occupy all available space. It will occupy the free space left from vda2. There will be free space after vda3 left as well.
  2.5) Delet swap - vda2 will extend to all available space. 
  2.6) Delete vda2
  2.7) Create swap - 2048 which will become vda2
  2.8) Create / with all remaining space - this will becomde vda3
  2.9) Proceed with writing changes to disk
Comment 3 Alexander Todorov 2010-07-02 07:11:10 EDT

*** This bug has been marked as a duplicate of bug 592339 ***

Note You need to log in before you can comment on or make changes to this bug.