Bug 610873 - No sound from HDMI port on 2010 mac mini (NVIDIA GPU GeForce 320M)
No sound from HDMI port on 2010 mac mini (NVIDIA GPU GeForce 320M)
Status: CLOSED DUPLICATE of bug 619873
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 12:20 EDT by Jurgen Kramer
Modified: 2010-08-01 14:42 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-01 14:42:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch created from current ALSA git (3.14 KB, text/plain)
2010-07-28 14:51 EDT, Jurgen Kramer
no flags Details

  None (edit)
Description Jurgen Kramer 2010-07-02 12:20:31 EDT
Description of problem:
With the current kernel and alsa drivers I can not get sound over the HDMI interface.

Version-Release number of selected component (if applicable):
2.6.34-45.fc13.x86_64 (from koji, needed to get ethernet working)

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
no sound from any of the listed HDMI devices

Expected results:
Sound from one of the listed HDMI devices

Additional info:
aplay -l output:
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: Cirrus Analog [Cirrus Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: Cirrus Digital [Cirrus Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

aplay -L output:
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=NVidia
    HDA NVidia, Cirrus Analog
    Default Audio Device
front:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    Front speakers
surround40:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, NVIDIA HDMI
    HDMI Audio Output

From dmesg:
HDMI hot plug event: Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI hot plug event: Pin=5 Presence_Detect=0 ELD_Valid=1

Normally I would expect it to list the connected device.

Video card is:
05:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:08a4] (rev a2)
aka NVIDIA GPU GeForce 320M

BTW I tried building newer ALSA drivers to see if it would solve my problem but compiling the driver no longer works on F13 (BZ#610751)
Comment 1 Jurgen Kramer 2010-07-16 05:54:05 EDT
Newer alsa drivers do not seem to have updated patch_nvhdmi.c, hda_eld.c so no help here.
The main problem seems to be that there a connected TV of Receiver is not detected. None of the /proc/asound/eld#?.0 lists a connected device:

[kramer@macmini2010 card0]$ more eld#3.0 
monitor_present		0
eld_valid		0
monitor_name		
connection_type		HDMI
eld_version		[0x0] reserved
edid_version		[0x0] no CEA EDID Timing Extension block present
manufacture_id		0x0
product_id		0x0
port_id			0x0
support_hdcp		0
support_ai		0
audio_sync_delay	0
speakers		[0x0]
sad_count		0

[kramer@macmini2010 card0]$ more eld#4.0 
monitor_present		0
eld_valid		1
monitor_name		
connection_type		HDMI
eld_version		[0x0] reserved
edid_version		[0x0] no CEA EDID Timing Extension block present
manufacture_id		0x0
product_id		0x0
port_id			0x0
support_hdcp		0
support_ai		0
audio_sync_delay	0
speakers		[0x0]
sad_count		0

[kramer@macmini2010 card0]$ more eld#5.0 
monitor_present		0
eld_valid		0
monitor_name		
connection_type		HDMI
eld_version		[0x0] reserved
edid_version		[0x0] no CEA EDID Timing Extension block present
manufacture_id		0x0
product_id		0x0
port_id			0x0
support_hdcp		0
support_ai		0
audio_sync_delay	0
speakers		[0x0]
sad_count		0

Any help would be very appreciated.

Output of alsa-info.sh:
http://www.alsa-project.org/db/?f=296d7f8647a8503c7430c730faa61cad25d10904

From a working system for comparison (GT220):
http://www.alsa-project.org/db/?f=cc5729ca4434c802ec06d5ea6bf8d11dafb30324
Comment 2 Jaroslav Kysela 2010-07-16 06:26:57 EDT
Note that ELD information must be filled with the video driver. Ask xorg developers (if you use the xorg driver) what's wrong.
Comment 3 Jarod Wilson 2010-07-16 17:02:05 EDT
(In reply to comment #2)
> Note that ELD information must be filled with the video driver. Ask xorg
> developers (if you use the xorg driver) what's wrong.    

Ben, any feedback on that? Thanks much...
Comment 4 Ben Skeggs 2010-07-18 18:24:19 EDT
The problem is that Nouveau has no support whatsoever for HDMI audio at this time.
Comment 5 Jurgen Kramer 2010-07-21 12:54:36 EDT
I've reported the bug to nvidia (via nvnews.net forum). The Nvidia ALSA guys have acknowledged the problem and are working on a fix.

http://www.nvnews.net/vbulletin/showthread.php?t=153075

http://mailman.alsa-project.org/pipermail/alsa-devel/2010-July/029658.html
Comment 6 Jurgen Kramer 2010-07-28 14:50:33 EDT
A proper patch is now in the current ALSA git repo and daily snapshots. I am building a kernel 'as we speak'. I will report back after testing. I hop this patch will make it to a coming F13 kernel updated.

I've attached a patch I've created from a F13 2.6.34 kernel from koji.
Comment 7 Jurgen Kramer 2010-07-28 14:51:45 EDT
Created attachment 435104 [details]
Proposed patch created from current ALSA git
Comment 8 Chuck Ebbert 2010-08-01 14:42:48 EDT

*** This bug has been marked as a duplicate of bug 619873 ***

Note You need to log in before you can comment on or make changes to this bug.