Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 619873 - [PATCH] NVIDIA GPU audio-over-HDMI: Patch required to support recent GPUs
[PATCH] NVIDIA GPU audio-over-HDMI: Patch required to support recent GPUs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 610873 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-30 14:42 EDT by Stephen Warren
Modified: 2010-08-30 14:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: kernel-2.6.34.6-47.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-30 14:23:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Warren 2010-07-30 14:42:48 EDT
The kernel ALSA driver needs a patch applied to make audio-over-HDMI operate correctly on most supported GPUs.

The exact patch is available at http://git.alsa-project.org/?p=alsa-kernel.git;a=commitdiff;h=4289bc9c818ece46f8034616b232caaef4622984

It'd be great if this patch could be included in the standard Fedora kernel(s) for any/all recent or supported distro versions.

Note 1: I believe only the nvidia driver (not nv nor nouveau) support setting up audio-over-HDMI.

Note 2: Very recent GPUs (Fermi class) are not yet supported by the driver. A second patch will be forthcoming for this at some point in time, but we have to validate operation under Linux before releasing this.
Comment 1 Stephen Warren 2010-07-30 14:46:43 EDT
Note: I also filed this against RHEL as bug 619877. I assume filing against
both Red Hat and Fedora separately makes sense? If not, please do let me know.
Thanks.
Comment 3 Chuck Ebbert 2010-08-01 14:42:48 EDT
*** Bug 610873 has been marked as a duplicate of this bug. ***
Comment 4 Stephen Warren 2010-08-10 12:07:59 EDT
A second patch is required to support various new GPUs in the ALSA driver:

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound-2.6.git;a=commit;h=9cf2657d05f9f9e04c3e113d68bf7cef5a942070

Thanks.
Comment 5 Fedora Update System 2010-08-10 19:54:23 EDT
kernel-2.6.34.3-37.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kernel-2.6.34.3-37.fc13
Comment 6 Stephen Warren 2010-08-10 20:09:03 EDT
Thanks!

One note: 2.6.34.4 only includes the first of those two patches; I imagine the 2nd isn't in that new package?
Comment 7 Fedora Update System 2010-08-11 03:26:43 EDT
kernel-2.6.34.3-37.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.34.3-37.fc13
Comment 8 Fedora Update System 2010-08-27 07:23:52 EDT
kernel-2.6.34.6-47.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/kernel-2.6.34.6-47.fc13
Comment 9 Fedora Update System 2010-08-30 14:22:37 EDT
kernel-2.6.34.6-47.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.