Bug 610875 - virt-v2v fails when executed with umask 077
Summary: virt-v2v fails when executed with umask 077
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v   
(Show other bugs)
Version: 5.7
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 610880 624963
TreeView+ depends on / blocked
 
Reported: 2010-07-02 16:20 UTC by Matthew Booth
Modified: 2011-01-13 18:28 UTC (History)
8 users (show)

Fixed In Version: virt-v2v-0.6.3-1.el5
Doc Type: Bug Fix
Doc Text:
Priviously, the conversion process failed if virt-v2v was run from a shell with a umask more restrictive than 0022. This update resolves this issue.
Story Points: ---
Clone Of:
: 610880 624963 (view as bug list)
Environment:
Last Closed: 2011-01-13 18:28:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0147 normal SHIPPED_LIVE virt-v2v and libguestfs bug fix update 2011-01-13 18:28:09 UTC

Description Matthew Booth 2010-07-02 16:20:56 UTC
Description of problem:
# rm /var/lib/virt-v2v/transfer.iso
# umask 0077
# virt-v2v -ic esx://yellow.rhev.marston/?no_verify=1 -o rhev -osd blue:/nfs/export --network rhevm RHEL3-32
qemu: could not open disk image /var/lib/virt-v2v/transfer.iso
child process died unexpectedly at /usr/bin/virt-v2v line 483.
...

The reason for this is that virt-v2v creates transfer.iso with permissions 600, owned by root:root. When writing to RHEV, the libguestfs appliance is launched as 36:36, which doesn't have permissions to read this file.

Version-Release number of selected component (if applicable):
virt-v2v-0.6.0-6.el5

Comment 2 RHEL Product and Program Management 2010-08-09 19:11:47 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 3 Matthew Booth 2010-09-06 09:44:43 UTC
This is already upstream.

Comment 4 RHEL Product and Program Management 2010-09-06 09:56:51 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 5 RHEL Product and Program Management 2010-09-07 11:56:51 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 7 koka xiong 2010-09-30 03:16:27 UTC
Verified with virt-v2v-0.6.3-2.el5
1.rm /var/lib/virt-v2v/transfer.iso
2.umask 077
3.virt-v2v -ic xen+ssh://10.66.72.123  -o rhev -osd 10.66.90.115:/vol/v2vrwu1/xen_export rhel6-32b-pv-raw-intel
virt-v2v: rhel6-32b-pv-raw-intel configured with virtio drivers

Verification is passed.

Comment 8 Florian Nadge 2011-01-12 17:24:04 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Priviously, the conversion process failed if virt-v2v was run from a shell with a umask more restrictive than 0022. This update resolves this issue.

Comment 10 errata-xmlrpc 2011-01-13 18:28:42 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0147.html


Note You need to log in before you can comment on or make changes to this bug.