Bug 610880 - libguestfs should set broader read perms on tmpdir, so works in some situations when executed with umask 077
Summary: libguestfs should set broader read perms on tmpdir, so works in some situatio...
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 610875 624963
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-02 16:39 UTC by Richard W.M. Jones
Modified: 2010-10-16 13:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 610875
Environment:
Last Closed: 2010-10-16 13:25:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard W.M. Jones 2010-07-02 16:39:09 UTC
In virt-v2v the appliance is run as another uid:gid, and this does
not have access to read the kernel and initrd in the temporary
directory.

Although we want to stop other people from trying to write to
the tmpdir, there is no danger or secret in the files in this
directory and so there is no problem allowing anyone to read
these files (but not the socket).

+++ This bug was initially created as a clone of Bug #610875 +++

Description of problem:
# rm /var/lib/virt-v2v/transfer.iso
# umask 0077
# virt-v2v -ic esx://yellow.rhev.marston/?no_verify=1 -o rhev -osd blue:/nfs/export --network rhevm RHEL3-32
qemu: could not open disk image /var/lib/virt-v2v/transfer.iso
child process died unexpectedly at /usr/bin/virt-v2v line 483.
...

The reason for this is that virt-v2v creates transfer.iso with permissions 600, owned by root:root. When writing to RHEV, the libguestfs appliance is launched as 36:36, which doesn't have permissions to read this file.

Version-Release number of selected component (if applicable):
virt-v2v-0.6.0-6.el5

Comment 1 Richard W.M. Jones 2010-07-02 18:17:44 UTC
Patch posted upstream:
https://www.redhat.com/archives/libguestfs/2010-July/msg00000.html

Comment 2 Bug Zapper 2010-07-30 12:24:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Richard W.M. Jones 2010-10-16 13:25:10 UTC
Moved to Virtualization Tools product.  This is
fixed upstream as far as I know.


Note You need to log in before you can comment on or make changes to this bug.