Bug 610891 - [abrt] crash in NetworkManager-gnome-1:0.8.1-0.1.git20100510.fc13: cell_editing_canceled: Process /usr/bin/nm-connection-editor was killed by signal 11 (SIGSEGV)
[abrt] crash in NetworkManager-gnome-1:0.8.1-0.1.git20100510.fc13: cell_editi...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:58008edeec905e9061a86a02d87...
:
: 625323 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 12:58 EDT by Derek Jones
Modified: 2010-09-26 00:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-4.git20100817.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 18:06:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (24.08 KB, text/plain)
2010-07-02 12:58 EDT, Derek Jones
no flags Details

  None (edit)
Description Derek Jones 2010-07-02 12:58:46 EDT
abrt 1.1.0 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/nm-connection-editor
component: NetworkManager
crash_function: cell_editing_canceled
executable: /usr/bin/nm-connection-editor
global_uuid: 58008edeec905e9061a86a02d873a9066422bd66
kernel: 2.6.33.3-85.fc13.i686
package: NetworkManager-gnome-1:0.8.1-0.1.git20100510.fc13
rating: 4
reason: Process /usr/bin/nm-connection-editor was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Attempted to "Apply" changes after setting a manual IP address with an associated DNS and domain references
2.
3.
Comment 1 Derek Jones 2010-07-02 12:58:51 EDT
Created attachment 429113 [details]
File: backtrace
Comment 2 Jirka Klimes 2010-07-26 05:11:30 EDT
I can confirm the crash. Actually it doesn't crash on "Apply", rather when dismissing the window by clicking on "x" icon in the upper right corner.

Steps to reproduce:
1. run nm-connection-editor
2. choose a connection and click "Edit"
3. go to "IPv4 Settings" of "IPv6 Settings"
4. method "manual", edit "Addresses"
5. when you are in a cell, close the "Editing ..." window by clicking "x" icon
   in the upper right corner
6. crash occurs
Comment 3 Jirka Klimes 2010-07-26 05:14:01 EDT
Fixed upstream:

1f2d25bc605006e7efd06cf0ee7264c854ccc209 (master)
5665421edc73c47571a945c278646d097abb1cbb (NMA_0_8_1)
Comment 4 Fedora Update System 2010-08-17 13:10:42 EDT
NetworkManager-0.8.1-4.git20100817.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-4.git20100817.fc12
Comment 5 Fedora Update System 2010-08-17 13:12:28 EDT
NetworkManager-0.8.1-4.git20100817.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-4.git20100817.fc13
Comment 6 Fedora Update System 2010-08-17 13:14:20 EDT
NetworkManager-0.8.1-4.git20100817.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-4.git20100817.fc14
Comment 7 Fedora Update System 2010-08-19 16:32:51 EDT
NetworkManager-0.8.1-5.git20100818.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-5.git20100818.fc14
Comment 8 Fedora Update System 2010-08-19 22:13:56 EDT
NetworkManager-0.8.1-4.git20100817.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-4.git20100817.fc13
Comment 9 Jirka Klimes 2010-08-23 10:44:57 EDT
*** Bug 625323 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2010-08-23 18:05:23 EDT
NetworkManager-0.8.1-4.git20100817.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-08-23 21:20:28 EDT
NetworkManager-0.8.1-5.git20100818.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-08-31 21:26:11 EDT
NetworkManager-0.8.1-6.git20100831.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.1-6.git20100831.fc13
Comment 13 Fedora Update System 2010-08-31 21:43:12 EDT
NetworkManager-0.8.1-6.git20100831.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.1-6.git20100831.fc12
Comment 14 Fedora Update System 2010-09-26 00:34:48 EDT
NetworkManager-0.8.1-6.git20100831.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.