Bug 610986 - varobj_create uses stale frame_info
Summary: varobj_create uses stale frame_info
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb   
(Show other bugs)
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7193b3c09aafd00fe1d09cde762...
Keywords:
: 618014 625127 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-02 23:46 UTC by Priyank
Modified: 2010-08-24 01:35 UTC (History)
5 users (show)

Fixed In Version: gdb-7.0.1-50.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 01:32:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (10.42 KB, text/plain)
2010-07-02 23:46 UTC, Priyank
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 11788 None None None Never

Description Priyank 2010-07-02 23:46:15 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: gdb --interpreter mi2 --nx
component: gdb
crash_function: get_frame_type
executable: /usr/bin/gdb
global_uuid: 7193b3c09aafd00fe1d09cde76225ffa9195093c
kernel: 2.6.32.14-127.fc12.x86_64
package: gdb-7.0.1-48.fc12
rating: 4
reason: Process /usr/bin/gdb was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Priyank 2010-07-02 23:46:17 UTC
Created attachment 429195 [details]
File: backtrace

Comment 2 Jan Kratochvil 2010-07-25 17:14:05 UTC
*** Bug 618014 has been marked as a duplicate of this bug. ***

Comment 3 Jan Kratochvil 2010-08-06 14:23:48 UTC
Post:
[patch] [mi] Fix crash on stale frame_info * - PR 11788
http://sourceware.org/ml/gdb-patches/2010-08/msg00065.html

Comment 4 Jan Kratochvil 2010-08-18 16:43:23 UTC
*** Bug 625127 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2010-08-19 09:11:58 UTC
gdb-7.1-33.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gdb-7.1-33.fc13

Comment 6 Fedora Update System 2010-08-19 09:13:14 UTC
gdb-7.1.90.20100806-11.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/gdb-7.1.90.20100806-11.fc14

Comment 7 Fedora Update System 2010-08-19 09:13:36 UTC
gdb-7.0.1-50.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gdb-7.0.1-50.fc12

Comment 8 Fedora Update System 2010-08-20 01:32:24 UTC
gdb-7.0.1-50.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-08-20 02:03:28 UTC
gdb-7.1-33.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-08-24 01:35:28 UTC
gdb-7.1.90.20100806-11.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.