Bug 61113 - Man page / actual behaviour variance - netstat
Summary: Man page / actual behaviour variance - netstat
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 102769 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-13 20:10 UTC by R P Herrold
Modified: 2015-03-05 01:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-25 15:07:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description R P Herrold 2002-03-13 20:10:45 UTC
net-tools-1.60-3
Man page states:

  netstat {--interfaces|-i} [iface] [--all|-a] [--extend|-e[--extend|-e]]
       [--verbose|-v]      [--program|-p]      [--numeric|-n]      [--numeric-
       hosts][--numeric-ports][--numeric-ports] [--continuous|-c]
---------

later

   --interface=iface , -i
       Display a table of all network interfaces, or the specified iface).

=============================

(these are mutually inconsistent -- the use of the "=" in the second 
example errors out)

===============================

More importantly -- 

[herrold@oldnews herrold]$ netstat --interface eth0
Kernel Interface table
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0  248878      0      0      0  244924      0      0      0 BMRU
lo    16436   0    1762      0      0      0    1762      0      0      0 LRU
[herrold@oldnews herrold]$ netstat -i eth0
Kernel Interface table
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0  253087      0      0      0  248979      0      0      0 BMRU
lo    16436   0    1780      0      0      0    1780      0      0      0 LRU
[herrold@oldnews herrold]$

that is -- LO information is appearing, improperly.

Comment 1 Phil Knirsch 2003-02-11 14:20:30 UTC
OK, bug in manpage. The -i option prints out stats for all interfaces. Will see
if i can do a round of updated for the manpages sometime soon.

Read ya, Phil

Comment 2 Steve Coile 2003-05-22 15:12:25 UTC
This bug persists in RHL 9.

Comment 3 Phil Knirsch 2003-08-25 14:37:37 UTC
*** Bug 102769 has been marked as a duplicate of this bug. ***

Comment 4 Phil Knirsch 2003-08-25 14:48:31 UTC
As just written in the latest bugreport i actually like the idea of monitoring a
single interface, so i patched netstat over the weekend.

Next version of net-tools will contain fix.

Read ya, Phil

Comment 5 Phil Knirsch 2003-08-25 15:07:36 UTC
To be more precise, net-tools-1.60-20 and later will contain the fix.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.