Bug 611270 - [abrt] crash in whaawmp-0.2.12.1-3.fc13: gstPlayer.py:224:setVideoSink:ElementNotFoundError: videobalance
[abrt] crash in whaawmp-0.2.12.1-3.fc13: gstPlayer.py:224:setVideoSink:Elemen...
Status: CLOSED DUPLICATE of bug 600248
Product: Fedora
Classification: Fedora
Component: whaawmp (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:9048cd9f
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-04 11:41 EDT by Need Real Name
Modified: 2010-07-04 16:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-04 16:29:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (888 bytes, text/plain)
2010-07-04 11:41 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2010-07-04 11:41:39 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: python /usr/lib/python2.6/site-packages/whaawmp/whaawmp.py
component: whaawmp
executable: /usr/lib/python2.6/site-packages/whaawmp/whaawmp.py
kernel: 2.6.33.3-85.fc13.i686
package: whaawmp-0.2.12.1-3.fc13
reason: gstPlayer.py:224:setVideoSink:ElementNotFoundError: videobalance
release: Fedora release 13 (Goddard)

backtrace
-----
gstPlayer.py:224:setVideoSink:ElementNotFoundError: videobalance

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/whaawmp/whaawmp.py", line 89, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/whaawmp/whaawmp.py", line 84, in __init__
    self.mainWindow = whaawmp.mainWindow()
  File "/usr/lib/python2.6/site-packages/whaawmp/gui/main.py", line 804, in __init__
    self.preparePlayer()
  File "/usr/lib/python2.6/site-packages/whaawmp/gui/main.py", line 266, in preparePlayer
    player.setVideoSink()
  File "/usr/lib/python2.6/site-packages/whaawmp/common/gstPlayer.py", line 224, in setVideoSink
    colourBalance = gst.element_factory_make('videobalance')
ElementNotFoundError: videobalance

Local variables in innermost frame:
bin: <gst.Bin object (bin0) at 0x9630644>
sinkName: None
self: <common.gstPlayer.Player instance at 0x9232a8c>

How to reproduce
-----
1.Tried to run whaamp
2.
3.
Comment 1 Need Real Name 2010-07-04 11:41:42 EDT
Created attachment 429387 [details]
File: backtrace
Comment 2 Thomas Spura 2010-07-04 16:29:07 EDT
Hi,

thanks for the bug report.

Unfortunately I don't know how to fix this, because it's gstreamer doing something wrong here and not whaawmp.


Please try to move the folder ~/.gstreamer-0.10 out there and whawmp should work again.
(This works at least in bug #600248.)

So please run this command in a console and it should run again:

"mv ~/.gstreamer-0.10 ~/.gstreamer-0.10-backup"

(If it doesn't please make a not in the bug mentioned above.)

*** This bug has been marked as a duplicate of bug 600248 ***

Note You need to log in before you can comment on or make changes to this bug.