Bug 611400 - [abrt] crash in python-twisted-core-8.2.0-5.fc13: _twistd_unix.py:80:checkPID:OSError: [Errno 1] Operation not permitted: '/tmp/vmc.pid'
[abrt] crash in python-twisted-core-8.2.0-5.fc13: _twistd_unix.py:80:checkPID...
Status: CLOSED DUPLICATE of bug 702841
Product: Fedora
Classification: Fedora
Component: python-twisted-core (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Vander Stichele
Fedora Extras Quality Assurance
abrt_hash:ff0ea250
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-05 02:27 EDT by Giovanni Bacaro
Modified: 2011-05-08 02:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-15 05:38:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.05 KB, text/plain)
2010-07-05 02:27 EDT, Giovanni Bacaro
no flags Details

  None (edit)
Description Giovanni Bacaro 2010-07-05 02:27:22 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/twistd -r gtk2 --pidfile /tmp/vmc.pid -noy /usr/share/vodafone-mobile-connect/gtk-tap.py -l /dev/null
component: python-twisted-core
executable: /usr/bin/twistd
kernel: 2.6.33.5-124.fc13.i686
package: python-twisted-core-8.2.0-5.fc13
reason: _twistd_unix.py:80:checkPID:OSError: [Errno 1] Operation not permitted: '/tmp/vmc.pid'
release: Fedora release 13 (Goddard)

backtrace
-----
_twistd_unix.py:80:checkPID:OSError: [Errno 1] Operation not permitted: '/tmp/vmc.pid'

Traceback (most recent call last):
  File "/usr/bin/twistd", line 21, in <module>
    run()
  File "/usr/lib/python2.6/site-packages/twisted/scripts/twistd.py", line 27, in run
    app.run(runApp, ServerOptions)
  File "/usr/lib/python2.6/site-packages/twisted/application/app.py", line 694, in run
    runApp(config)
  File "/usr/lib/python2.6/site-packages/twisted/scripts/twistd.py", line 23, in runApp
    _SomeApplicationRunner(config).run()
  File "/usr/lib/python2.6/site-packages/twisted/application/app.py", line 410, in run
    self.preApplication()
  File "/usr/lib/python2.6/site-packages/twisted/scripts/_twistd_unix.py", line 193, in preApplication
    checkPID(self.config['pidfile'])
  File "/usr/lib/python2.6/site-packages/twisted/scripts/_twistd_unix.py", line 80, in checkPID
    os.remove(pidfile)
OSError: [Errno 1] Operation not permitted: '/tmp/vmc.pid'

Local variables in innermost frame:
pid: 2746
why: OSError(3, 'No such process')
pidfile: '/tmp/vmc.pid'
Comment 1 Giovanni Bacaro 2010-07-05 02:27:25 EDT
Created attachment 429467 [details]
File: backtrace
Comment 2 John Slade 2010-09-13 05:39:37 EDT
Package: python-twisted-core-8.2.0-5.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Logged in
2. Started vodafone mobile connect
3.
Comment 3 Julian Sikorski 2010-09-23 16:38:26 EDT
Hi, I am the new twisted stack co-maintainer. A rebase to 10.1.0 was just submitted as an update to F-14. If that's not a problem, could you please test whether the bug is still present there? Thanks.
Comment 4 Julian Sikorski 2011-05-08 02:14:40 EDT

*** This bug has been marked as a duplicate of bug 702481 ***
Comment 5 Julian Sikorski 2011-05-08 02:14:56 EDT

*** This bug has been marked as a duplicate of bug 702841 ***

Note You need to log in before you can comment on or make changes to this bug.