This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 702481 - (F15Blocker-sugar) Fedora 15 Sugar blocker bug tracker
Fedora 15 Sugar blocker bug tracker
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Bill Nottingham
AcceptedNTH
:
Depends On: 697649 702480
Blocks: F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-05-05 15:30 EDT by Adam Williamson
Modified: 2014-03-16 23:27 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 06:16:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2011-05-05 15:30:19 EDT
This bug acts as a tracker for issues critical to the Sugar spin for Fedora 15.
Comment 1 Adam Williamson 2011-05-05 15:31:20 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Adam Williamson 2011-05-05 15:31:57 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2011-05-06 12:51:08 EDT
Marking 'acceptednth' as this is just a tracker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 satellitgo 2011-05-06 17:20:06 EDT
*sugar-read 
https://bugzilla.gnome.org/show_bug.cgi?id=624780
https://bugzilla.gnome.org/show_bug.cgi?id=639758

*Central Avitar in network neighborhood f1 disappears after several minutes
http://bugs.sugarlabs.org/ticket/2519

*Neighborhood view is sometimes greyed out or owner buddy is missing)
http://bugs.sugarlabs.org/ticket/2483  (see patch)
https://bugzilla.redhat.com/show_bug.cgi?id=647414
http://bugs.sugarlabs.org/ticket/2395
http://dev.laptop.org/ticket/10671

*Irregular behavior of telepathy-gabble in sugar 0.89.6
http://bugs.sugarlabs.org/ticket/2387

*SoaS-nightly Compose:(422)jabber only works on wired connection after gdm
http://bugs.sugarlabs.org/ticket/2798#comment:1

*SoaS/Sugar spin needs additional firewall ports open for Salut to work.  
https://bugzilla.redhat.com/show_bug.cgi?id=699432

*[tracking] new dependency on gnome-keyring-daemon
http://bugs.sugarlabs.org/ticket/2339

*Fedora 14 SoaS repeatedly prompts for gnome-keyring password at first login  
https://bugzilla.redhat.com/show_bug.cgi?id=649013

*sugar-desktop gnome-keyring-pam-2.91.93-1.fc15 (i686) does not work-pops up 11 times  (edit)  
https://bugzilla.redhat.com/show_bug.cgi?id=690586

*Drop --start and --foreground option when autostarted via dbus activation
https://bugzilla.gnome.org/show_bug.cgi?id=628302

*f15-RC2-Gnome sugar-emulator does not access keyring but works if gdm logged in as sugar
http://bugs.sugarlabs.org/ticket/2652

*[abrt] telepathy-gabble-0.10.3-1.fc14: __strcmp_ia32: Process /usr/libexec/telepathy-gabble was killed by signal 11 (SIGSEGV) 
https://bugzilla.redhat.com/show_bug.cgi?id=647414

partial List. 
Will enter sugarlabs bugs in bugzilla if not entered

Tom Gilliard
satellt on #sugar IRC freenode
Comment 5 satellitgo 2011-05-06 17:23:28 EDT
*synaptic (yum installed from netinstall of sugar-desktop only) has error and will not reload packages.
https://bugzilla.redhat.com/show_bug.cgi?id=702706
Comment 6 Peter Robinson 2011-05-07 13:42:19 EDT
(In reply to comment #4)
> *sugar-read 
> https://bugzilla.gnome.org/show_bug.cgi?id=624780
> https://bugzilla.gnome.org/show_bug.cgi?id=639758

Known issue. Unlikely to be fixed for release.

> *Central Avitar in network neighborhood f1 disappears after several minutes
> http://bugs.sugarlabs.org/ticket/2519
> 
> *Neighborhood view is sometimes greyed out or owner buddy is missing)
> http://bugs.sugarlabs.org/ticket/2483  (see patch)
> https://bugzilla.redhat.com/show_bug.cgi?id=647414
> http://bugs.sugarlabs.org/ticket/2395
> http://dev.laptop.org/ticket/10671
>
> *Irregular behavior of telepathy-gabble in sugar 0.89.6
> http://bugs.sugarlabs.org/ticket/2387

I believe the above 3 issues are the same. I'm looking to add the patch from 2483 to mitigate it. In the case of F-15 the NM issue will also contribute. F-14/SoaSv4 or earlier releases aren't relevant here unless they are still present in F-15/SoaSv5

> *SoaS-nightly Compose:(422)jabber only works on wired connection after gdm
> http://bugs.sugarlabs.org/ticket/2798#comment:1

This is due to NetworkManager changes.

> *SoaS/Sugar spin needs additional firewall ports open for Salut to work.  
> https://bugzilla.redhat.com/show_bug.cgi?id=699432
> 
> *[tracking] new dependency on gnome-keyring-daemon
> http://bugs.sugarlabs.org/ticket/2339

Long fixed.

> *Fedora 14 SoaS repeatedly prompts for gnome-keyring password at first login  
> https://bugzilla.redhat.com/show_bug.cgi?id=649013

Old release. This is fixed in SoaS.

> *sugar-desktop gnome-keyring-pam-2.91.93-1.fc15 (i686) does not work-pops up 11
> times  (edit)  
> https://bugzilla.redhat.com/show_bug.cgi?id=690586

As above.

> *Drop --start and --foreground option when autostarted via dbus activation
> https://bugzilla.gnome.org/show_bug.cgi?id=628302

Its not clear what this has to do with SoaS. Is it for emulator?

> *f15-RC2-Gnome sugar-emulator does not access keyring but works if gdm logged
> in as sugar
> http://bugs.sugarlabs.org/ticket/2652

This is out of scope for SoaS. It needs to be fixed upstream.

> *[abrt] telepathy-gabble-0.10.3-1.fc14: __strcmp_ia32: Process
> /usr/libexec/telepathy-gabble was killed by signal 11 (SIGSEGV) 
> https://bugzilla.redhat.com/show_bug.cgi?id=647414

Again, sugar-emulator, out of scope for SoaS.
Comment 7 Julian Sikorski 2011-05-08 02:14:40 EDT
*** Bug 611400 has been marked as a duplicate of this bug. ***
Comment 8 Julian Sikorski 2011-05-08 02:15:40 EDT
Sorry for the noise, I made a typo.
Comment 9 Peter Robinson 2011-05-08 09:33:07 EDT
Just submitted the following update to fix a number of issues:

https://admin.fedoraproject.org/updates/sugar-0.92.1-3.fc15,sugar-record-90-1.fc15,sugar-speak-25-1.fc15,csound-5.13.0-1.fc15

There's also been updates to the spin .ks to fix other updates.

Outstanding:
- NetworkManager issues
- sugar-presence-service not starting (needed for eToys)
- sugar-read
Comment 10 Adam Williamson 2011-05-09 11:08:34 EDT
it's usually best not to use tracker bugs for discussion. it gets very confusing.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 satellitgo 2011-05-13 20:31:23 EDT
http://bugs.sugarlabs.org/ticket/2845

F15 Jabber fills up with duplicate avitars that constantly change colors en-mass.
In latest updated HD install of @sugar-desktop in DVD F15 RC2 there is a rogue avitar that duplicates itself until it fills up the f1 neighborhood view. All instances change colors en-mass and have the same name. (Cebal)

telepathy-mission-control-5.7.10-1.fc15.i686
Updated to
 https://admin.fedoraproject.org/updates/telepathy-mission-control-5.7.11-1.fc15
still present after update
Comment 12 satellitgo 2011-05-13 21:17:11 EDT
see testing here for Test Report and  Activity failures
http://wiki.sugarlabs.org/go/Community/Distributions/Fedora-SoaS#Release_Candidate_3
Comment 13 satellitgo 2011-05-15 20:07:50 EDT
Fedora-15-Nightly-20110515.07-i686-Live-soas.iso
sugar-activity:
etoys 116
Error will not run
To fix:
in root terminal:

touch ~/.sugar/default/buddy-icon.jpg
Comment 14 Simon Schampijer 2011-05-16 10:08:08 EDT
SPS 0.90.2 http://koji.fedoraproject.org/koji/buildinfo?buildID=236974 will fix the issue for you regarding Etoys.
Comment 15 satellitgo 2011-05-16 13:07:19 EDT
http://serverbeach1.fedoraproject.org/pub/alt/stage/15.RC3/Live/i686/Fedora-15-i686-Live-SoaS.iso
and
http://koji.fedoraproject.org/koji/getfile?taskID=3072699&name=Fedora-15-Nightly-20110515.07-i686-Live-soas.iso
CD boot:
 Hangs Up Boot at:
 Started: Avahi mDNS/DNS-SD Stack
(5 minute wait).........
........................
then resumes: 
 gdm Live System User
 Click to change color
 add password for keychain (7 repeats as cannot write to keychain)

Why the 5 minute pause in boot sequence? (Looks like a timeout)
Comment 16 satellitgo 2011-05-16 13:20:08 EDT
I just timed it again 5 1/2 minutes pause in boot
Comment 17 satellitgo 2011-05-16 13:49:48 EDT
on 3rd try Boot from CD
same delay with selinux=0 and setenforce=0 on boot line
it pauses on:
Started: Avahi mDNS/DNS-SD Stack
Started Network Manager
(5 minute wait).........
........................
sed: can't read /etc/rc.d/init.d/halt: No such file or directory
........................
Starting Sandbox:
then resumes: 
 gdm Live System User
 Click to change color
 add password for keychain;OK;(7 repeats Cancel as cannot write to keychain)
Comment 18 Julian Sikorski 2011-05-23 10:54:11 EDT
*** Bug 706879 has been marked as a duplicate of this bug. ***
Comment 19 Peter Robinson 2011-09-12 06:16:37 EDT
All issues resolved. SoaS 5 will be released shortly.

Note You need to log in before you can comment on or make changes to this bug.