This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 61158 - /sbin/installkernel in Pensacola doesn't reflect grub.
/sbin/installkernel in Pensacola doesn't reflect grub.
Status: CLOSED DUPLICATE of bug 53557
Product: Red Hat Public Beta
Classification: Retired
Component: mkinitrd (Show other bugs)
pensacola
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-14 10:39 EST by Heather Conway
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 16:28:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Heather Conway 2002-03-14 10:39:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
/sbin/installkernel in Pensacola doesn't reflect GRUB so make install fails 
with the following message:
+exec /sbin/installkernel 2.4.9-26beta.31custom bzImage /usr/src/linux-2.4.9-
26beta.31/System.map ''
/etc/lilo.conf:  No such file or directory
make[1]: *** [install] Error 1
make[1]: Leaving directory '/usr/src/linux-2.4.9-26beta.31/arch/i386/boot
make: *** [install] Error 2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install Pensacola with GRUB instead of lilo
2.configure the kernel and compile with make install w/o 
editing /sbin/installkernel & commenting out line 29
3.
	

Actual Results:  The kernel failed to compile until I commented out the 
reference to lilo in /sbin/installkernel

Expected Results:  /sbin/installkernel should be changed to reflect either GRUB 
or lilo instead of just lilo

Additional info:
Comment 1 Arjan van de Ven 2002-03-19 13:32:15 EST
rpm -qf /sbin/installkernel
Comment 2 Heather Conway 2002-03-21 16:28:00 EST
rpm -qf /sbin/installkernel == mkinitrd-3.2.6-1
Comment 3 Erik Troan 2002-05-21 18:32:12 EDT
fixed for release, but only grub is supported now :-(

*** This bug has been marked as a duplicate of 53557 ***

Note You need to log in before you can comment on or make changes to this bug.