This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 611781 - PKG_CHECK_MODULES macro fails with autoconf 2.66 (perhaps)
PKG_CHECK_MODULES macro fails with autoconf 2.66 (perhaps)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autoconf (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
http://lists.gnu.org/archive/html/aut...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-06 10:05 EDT by Mamoru TASAKA
Modified: 2012-02-29 09:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 09:22:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2010-07-06 10:05:53 EDT
Description of problem:
For example, try
- unpack glib-2.25.10.tar.bz2 in glib2-2.25.10-3.fc14.src.rpm
- cd glib-2.25.10/
- then try $ autoreconf -fi

Then autoreconf fails like:
----------------------------------------------------------
configure:27088: error: possibly undefined macro: AS_MESSAGE_LOG_FDdnl
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1
----------------------------------------------------------

The lines around newly generated configure line 27088 are:
----------------------------------------------------------
 27083  Consider adjusting the PKG_CONFIG_PATH environment variable if you
 27084  installed software in a non-standard prefix.
 27085  
 27086  Alternatively, you may set the environment variables PCRE_CFLAGS
 27087  and PCRE_LIBS to avoid the need to call pkg-config.
 27088  See the pkg-config man page for more details." "$LINENO" AS_MESSAGE_LOG_FDdnl
 27089  
----------------------------------------------------------
And I see similar lines in /usr/share/aclocal/pkg.m4

Once report to pkgconfig because AS_MESSAGE_LOG_FD can be seen
also in other m4 files (like po.m4, libtool.m4,...)

Version-Release number of selected component (if applicable):
pkgconfig-0.25-1.fc14.i686
autoconf-2.66-2.fc14.noarch

How reproducible:
100%
Comment 1 Mamoru TASAKA 2010-07-06 10:07:32 EDT
(In reply to comment #0)
> Once report to pkgconfig because AS_MESSAGE_LOG_FD can be seen
> also in other m4 files (like po.m4, libtool.m4,...)

I wanted to say "once reporting to autoconf"
Comment 2 Mamoru TASAKA 2010-07-07 01:06:19 EDT
It seems this issue was also reported on upstream mailing list:
http://lists.gnu.org/archive/html/autoconf/2010-07/msg00011.html
Comment 3 Andreas Schwab 2010-07-07 04:11:37 EDT
It's a bug in pkg.m4.

--- pkg-config-0.25/pkg.m4.~1~	2009-12-06 21:39:02.000000000 +0100
+++ pkg-config-0.25/pkg.m4	2010-07-07 10:07:12.000000000 +0200
@@ -135,7 +135,7 @@ $$1_PKG_ERRORS
 Consider adjusting the PKG_CONFIG_PATH environment variable if you
 installed software in a non-standard prefix.
 
-_PKG_TEXT])dnl
+_PKG_TEXT])
         ])
 elif test $pkg_failed = untried; then
      	AC_MSG_RESULT([no])
@@ -146,7 +146,7 @@ path to pkg-config.
 
 _PKG_TEXT
 
-To get pkg-config, see <http://pkg-config.freedesktop.org/>.])dnl
+To get pkg-config, see <http://pkg-config.freedesktop.org/>.])
         ])
 else
 	$1[]_CFLAGS=$pkg_cv_[]$1[]_CFLAGS
Comment 4 Mamoru TASAKA 2010-07-07 04:37:47 EDT
(In reply to comment #3)
Well, removing dnl will perhaps "fix" this issue. 

The problem is whether autoconf says "dnl" in this usage 
is not supported or this is a regression in autoconf.
I see many "similar" dnl usage in other m4 files under /usr/share/aclocal.
Comment 5 Mamoru TASAKA 2010-07-07 04:41:18 EDT
I once want to revet the component to autoconf to see
the comment from autoconf maintainer anyway, because this
may affect other m4 files.
Comment 6 Matthias Clasen 2010-07-07 11:25:41 EDT
I don't think this is a bug in pkg.m4.

At least, I don't see anything in the autoconf manual that would forbid the use of dnl in certain places.
Comment 7 Colin Walters 2010-07-07 12:34:56 EDT
Can we revert autoconf until a decision is made on where the bug lies, so we can build things in the meantime?
Comment 8 Karsten Hopp 2010-07-12 14:26:14 EDT
You need pkgconfig-0.25-2.fc14 which has a fix for this issue
Comment 9 Colin Walters 2010-07-12 14:49:10 EDT
Can I ask that for future autotools uploads, basic smoke testing is made of major consumers of the stack?  Regardless of whether or not it's a bug in pkgconfig, it brought a lot of rawhide builds to a halt.
Comment 10 Matthias Clasen 2010-07-12 21:18:03 EDT
> You need pkgconfig-0.25-2.fc14 which has a fix for this issue    

I've put a workaround in pkgconfig merely to keep rawhide going. I still consider this a regression in autoconf that I would like to see addressed.
Comment 11 Karsten Hopp 2010-07-13 09:56:30 EDT
Upstream isn't sure if this is a bug in pkg.m4 or a regression in autoconf, see
http://lists.gnu.org/archive/html/autoconf/2010-07/msg00031.html

I still believe that a part of the changes in 
http://bugs.freedesktop.org/show_bug.cgi?id=13892
is causing this and CC'd the author of that patch for comments.
Stepan, what's your opinion on this ?
Comment 12 Andreas Schwab 2010-07-23 06:06:50 EDT
It is not a bug in autoconf because in principle autoconf macros do not generate trailing newlines as documented in (autoconf) Autoconf Language.  So it is the responsibility of the caller to add approriate whitespace to separate tokens.
Comment 13 Bug Zapper 2010-07-30 08:27:39 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Karsten Hopp 2012-02-29 09:22:06 EST
closing per comment #12

Note You need to log in before you can comment on or make changes to this bug.