Bug 6120 - Stock kernel 2.2.12 does not support disks >32GB
Stock kernel 2.2.12 does not support disks >32GB
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 8590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-20 00:46 EDT by jered
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-14 19:20:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jered 1999-10-20 00:46:48 EDT
The stock 2.2.12 kernel does not support disks >32GB. This
bit me while trying to install on those spiffy new IBM
DeskStar 37GP hard drives.  This problem is because Linux
stores the number of cylinders in a short (to save those
precious 2 extra bytes, sigh) and so overflows when the
number of cylinders is greater than 64k.

There is a patch for this, from Andre Hedrick. It's rather
large, though, as in addition to fixing this it adds
extensive additional support for a number of UDMA chipsets.
It can be found at:
http://www.us.kernel.org/pub/linux/kernel/people/hedrick/ide.2.2.12.19991014.patch.gz

--Jered
jered@mit.edu

(Oh, did I mention that my BIOS didn't support the drive
either? But, that's not your problem. I just *love* PC
hardware! Heheeeeeee.....)
Comment 1 Cristian Gafton 2000-01-04 17:26:59 EST
Assigned to dledford
Comment 2 Bill Nottingham 2000-02-05 21:25:59 EST
*** Bug 8590 has been marked as a duplicate of this bug. ***
Comment 3 terbak 2000-02-14 19:20:59 EST
I've got that same IBM 37.5 GB disk, and was unable to use the whole disk with
2.2.12-20. Kernel 2.2.14 solved the problem, and it's up and running nicely.

If your BIOS doesn't recognize your big harddisk (mine hangs while
detecting/configuring, Award 4.51PG), then you might want to do as I did. I
went into the "Integrated ..."-menu in my Award BIOS, and chose "Primary slave
PIO Mode" as Mode4 instead of the default "Auto". As a result, my harddisk went
from 2 MB/s to 8 MB/s, and it doesn't lag the machine any more. I first tried
some twinkling with hdparm -XA/-d/-u/ and so on.. But the BIOS-change was the
thing that "turned it on", so to speak.

The RedHat kernels don't activate dma by default, the stock config of 2.2.14
does. Hdparm -d /dev/hdx is a good thing to try.

Anyhow, I was just wondering what the difference between (U)DMA vs UDMA
actually is? It seems to be that (U)DMA means enabled but not supported by
BIOS, while UDMA means enabled and supported by BIOS. Are there any performance
issues here? My 37.5 GB disk runs with 8.6 MB/s with hdparm -t, and my old 6 GB
disk runs with > 9 MB/s.

Regards,

Terje Bakken
terbak@add.no
Comment 4 Alan Cox 2000-08-08 09:56:43 EDT
Since it works in 6.2 - closed

Note You need to log in before you can comment on or make changes to this bug.