Bug 612283 - The qpid::messaging API sometimes uses exceptions from the qpid:: namespace
Summary: The qpid::messaging API sometimes uses exceptions from the qpid:: namespace
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qpid-cpp   
(Show other bugs)
Version: 6.0
Hardware: All Linux
urgent
medium
Target Milestone: rc
: ---
Assignee: Kim van der Riet
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Keywords:
Depends On: 610156
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 18:48 UTC by Ted Ross
Modified: 2010-11-10 21:27 UTC (History)
4 users (show)

Fixed In Version: qpid-cpp-0.7.946106-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 610156
Environment:
Last Closed: 2010-11-10 21:27:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ted Ross 2010-07-07 18:48:38 UTC
+++ This bug was initially created as a clone of Bug #610156 +++

Description of problem:

There is at least one case in which an exception is thrown from the API that does not derive from qpid::messaging::MessagingException.  This is an ABI problem.

Version-Release number of selected component (if applicable):

RHEL6 snapshot 7


How reproducible:

100%

Steps to Reproduce:

Use the following sequence in the C++ API:

  using namespace qpid::messaging;

  Connection conn = Connection("localhost");
  Session    sess = conn.createSession();

  
Actual results:

Because the connection is not open, the createSession call throws an exception (expected) but the exception is "qpid::Exception" (not expected).


Expected results:

I expect an exception derived from qpid::messaging::MessagingException

--- Additional comment from gsim@redhat.com on 2010-07-01 15:21:57 EDT ---

Fixed on trunk (r959721) and in release repo (http://mrg1.lab.bos.redhat.com/git/?p=qpid.git;a=commitdiff;h=9a005978daf378f235f2806a1e50eeb0dd44bd94).

Comment 3 Kim van der Riet 2010-07-15 11:20:47 UTC
Fixed in build qpid-cpp-0.7.946106-4.

Comment 5 releng-rhel@redhat.com 2010-11-10 21:27:47 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.