Bug 612415 - [abrt] crash in system-config-printer-1.2.3-3.fc13: jobviewer.py:465:__init__:GError: Icon 'printer' not present in theme
[abrt] crash in system-config-printer-1.2.3-3.fc13: jobviewer.py:465:__init__...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:ac35e483
:
: 625423 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 03:23 EDT by Steve Kelem
Modified: 2010-09-15 03:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: system-config-printer-1.2.4-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 01:28:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.51 KB, text/plain)
2010-07-08 03:23 EDT, Steve Kelem
no flags Details

  None (edit)
Description Steve Kelem 2010-07-08 03:23:05 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: python /usr/share/system-config-printer/applet.py
component: system-config-printer
executable: /usr/share/system-config-printer/applet.py
kernel: 2.6.33.5-124.fc13.x86_64
package: system-config-printer-1.2.3-3.fc13
reason: jobviewer.py:465:__init__:GError: Icon 'printer' not present in theme
release: Fedora release 13 (Goddard)

backtrace
-----
jobviewer.py:465:__init__:GError: Icon 'printer' not present in theme

Traceback (most recent call last):
  File "/usr/share/system-config-printer/applet.py", line 439, in <module>
    trayicon=trayicon)
  File "/usr/share/system-config-printer/jobviewer.py", line 465, in __init__
    self.icon_jobs = theme.load_icon (ICON, 22, 0)
GError: Icon 'printer' not present in theme

Local variables in innermost frame:
text: <gtk.CellRendererText object at 0x1bdc190 (GtkCellRendererText at 0x1c4c580)>
trayicon: True
exit_handler: None
specific_dests: None
setter: <bound method JobViewer._set_job_size_text of <jobviewer.JobViewer instance at 0x1bd7c68>>
title: 'my jobs'
suppress_icon_hide: False
self: <jobviewer.JobViewer instance at 0x1bd7c68>
theme: <gtk.IconTheme object at 0x1bdc460 (GtkIconTheme at 0x1896440)>
cell: <gtk.CellRendererText object at 0x1bdc140 (GtkCellRendererText at 0x1c4c4a0)>
my_jobs: True
printers: <gtk.Menu object at 0x1bd2e10 (GtkMenu at 0x1794c90)>
ellipsize: False
parent: None
bus: <dbus._dbus.SystemBus (system) at 0x17da590>
action_name: 'close'
skip: False
job_action_group: <gtk.ActionGroup object at 0x17feeb0 (GtkActionGroup at 0x1c58ad0)>
icon: <gtk.CellRendererPixbuf object at 0x1bdc0a0 (GtkCellRendererPixbuf at 0x1c5ec40)>
name: 'Size'
column: <gtk.TreeViewColumn object at 0x1bdc0f0 (GtkTreeViewColumn at 0x1c6a6c0)>
item: <gtk.ToolButton object at 0x1bd2e60 (GtkToolButton at 0x1c68190)>
action: <gtk.Action object at 0x1bd2d70 (GtkAction at 0x1c5e8e0)>
loop: <glib.MainLoop object at 0x7f54005e2630>

How to reproduce
-----
1. I don't know what caused this problem. I wasn't printing anything.
2.
3.
Comment 1 Steve Kelem 2010-07-08 03:23:07 EDT
Created attachment 430258 [details]
File: backtrace
Comment 3 Steve Kelem 2010-07-12 22:24:36 EDT
Package: system-config-printer-1.2.3-3.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. I don't know what caused this problem. I booted and got the crash message. I wasn't printing anything, but there are 2 items in the print queue from a few days ago.
2.
3.
Comment 4 Jiri Popelka 2010-08-19 09:36:52 EDT
*** Bug 625423 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2010-08-26 07:53:08 EDT
system-config-printer-1.2.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc13
Comment 6 Fedora Update System 2010-08-26 07:55:41 EDT
system-config-printer-1.2.4-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc14
Comment 7 Fedora Update System 2010-08-26 14:36:02 EDT
system-config-printer-1.2.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc14
Comment 8 Fedora Update System 2010-09-13 14:08:12 EDT
system-config-printer-1.2.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/system-config-printer-1.2.4-2.fc14
Comment 9 Fedora Update System 2010-09-15 01:27:49 EDT
system-config-printer-1.2.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-09-15 03:17:09 EDT
system-config-printer-1.2.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.