Bug 612469 - clisp-2.49 is available
clisp-2.49 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clisp (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 06:03 EDT by Upstream Release Monitoring
Modified: 2011-03-02 22:12 EST (History)
4 users (show)

See Also:
Fixed In Version: clisp-2.49-3.fc15
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-21 23:54:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2010-07-08 06:03:57 EDT
Latest upstream release: 2.49
Current version in Fedora Rawhide: 2.47
URL: http://ftp.gnu.org/gnu/clisp/latest/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 1 Adam Stokes 2010-11-08 23:01:41 EST
Hi, This release has been out since July would someone please update this package?

Thanks!
Comment 2 Account closed by user 2010-11-27 10:05:45 EST
2.47 is two years old(2008-10-23) !!

2.49 (2010-07-07)
=================

User visible changes
--------------------

* New command line option -disable-readline lets working around bugs and
  incompatibilities between readline CLISP was built against and the
  library actually installed.
  See <http://clisp.cons.org/impnotes/clisp.html#opt-norl> for details.

* FFI:OPEN-FOREIGN-LIBRARY now accepts the :REQUIRE argument.
  See <http://clisp.cons.org/impnotes/dffi.html#dffi-open-lib> for details.

* New user variable CUSTOM:*USER-LIB-DIRECTORY* is respected by REQUIRE
  and used by "clisp-link install".
  Dynamic modules are now the default build option.
  See <http://clisp.cons.org/impnotes/require.html> and
  <http://clisp.cons.org/impnotes/clisp-link.html> for details.

* Function RENAME-FILE now accepts :IF-EXISTS argument which determines
  the action when the destination exists, unless, of course, *ANSI* is T.
  See <http://clisp.cons.org/impnotes/file-func.html#rename-file> for details.

* The replacement value entered by the user in STORE-VALUE and USE-VALUE
  restarts is now EVALuated.

* The old user variable CUSTOM:*PRINT-CLOSURE* now controls interpreted
  closure output too (RFE#3001956). This is a tricky feature, read up!
  See <http://clisp.cons.org/impnotes/multi-rep.html#pr-closure>.

* Module readline now supports readline 6.1.
  (Older versions are, of course, still supported).
  See <http://clisp.cons.org/impnotes/readline-mod.html> for details.

* Module pcre now supports pcre 8.01.
  (Older versions are, of course, still supported).
  See <http://clisp.cons.org/impnotes/pcre.html> for details.

* Module libsvm does not come with the upstream sources anymore, install
  locally and pass --with-libsvm-prefix to the top-level configure instead.
  All upstream versions up to 2.91 are supported.
  See <http://clisp.cons.org/impnotes/libsvm.html> for details.

* Module berkeley-db now supports Berkeley-DB 4.8.
  (Older versions are, of course, still supported).
  See <http://clisp.cons.org/impnotes/berkeley-db.html> for details.

* Module postgresql now supports PostgreSQL 8.4.
  (Older versions are, of course, still supported).
  See <http://clisp.cons.org/impnotes/postgresql.html> for details.

* Module pari has been updated to support both 64 & 32 bit platforms
  with and without GMP.
  See <http://clisp.cons.org/impnotes/pari.html> for details.

* New functions OS:VERSION-COMPARE et al call strverscmp.
  See <http://clisp.cons.org/impnotes/syscalls.html#strverscmp> for details.

* Bug fixes:
  + Do not eliminate function calls which are advertised to have
    exceptional situation in unsafe code (bug#2868166).
  + Fix an internal error in DECLAIM on bad OPTIMIZE quality (bug#2868147).
  + CLEAR-INPUT now clears the EOF condition on file streams (bug#2902716).
  + When quitting on a signal, never enter the debugger (bug#2795278).
  + Respect :FULL T in DIRECTORY :WILD-INFERIORS (bug#3009966).
  + Handle TWO-WAY-STREAM and ECHO-STREAM correctly by
    (SETF STREAM-EXTERNAL-FORMAT) (bug#3020933).
  + Fix unbuffered output pipe stream initialization (bug#3024887).

* ANSI compliance:
  + Implement the ANSI issue COMPILER-DIAGNOSTICS:USE-HANDLER: use the
    CL Condition System for compiler diagnostics.
  + STREAM-ELEMENT-TYPE on empty CONCATENATED-STREAMs now returns NIL
    because nothing can be read from such streams (bug#3014921).


2.48 (2009-07-28)
=================

User visible changes
--------------------

* Multiple threads of execution are now experimentally supported
  (not ready for prime time yet).
  Thanks to  Vladimir Tzankov <vtzankov@gmail.com>.
  See <http://clisp.cons.org/impnotes/mt.html> for details.

* Module libsvm has been upgraded to the upstream version 2.89.
  See <http://clisp.cons.org/impnotes/libsvm.html> for details.

* Module Berkeley-DB now supports Berkeley DB 4.7.
  (older versions 4.* are, of course, still supported).
  See <http://clisp.cons.org/impnotes/berkeley-db.html> for details.

* Module readline now supports readline 6.0.
  (older versions 5.* are, of course, still supported).
  See <http://clisp.cons.org/impnotes/readline-mod.html> for details.

* Passing :EXECUTABLE 0 to EXT:SAVEINITMEM results in an executable
  image which delegates processing of all the usual CLISP command line
  options to the :INIT-FUNCTION.
  See <http://clisp.cons.org/impnotes/image.html> for details.

* Driver clisp accepts "-b" to print the installation directory.
  See <http://clisp.cons.org/impnotes/clisp.html#opt-printlibdir> for details.

* Add file clisp.m4 so that the packages which use CLISP can check
  whether it is properly installed and has the required version.

* POSIX:COPY-FILE now accepts :METHOD :HARDLINK-OR-COPY.
  See <http://clisp.cons.org/impnotes/syscalls.html#copy-file> for details.

* New function POSIX:WAIT calls waitpid or wait4.
  See <http://clisp.cons.org/impnotes/syscalls.html#wait> for details.

* New function EXT:TRIM-IF removes leading and trailing matches.
  See <http://clisp.cons.org/impnotes/seq-func-ext.html#trim-if> for details.

* New user command "LocalSymbols" (abbreviated ":ls").
  See <http://clisp.cons.org/impnotes/repl.html#debugger-main-deb-step>
  for details.

* Commands "add" and "create" replace "add-module-set", "add-module-sets" and
  "create-module-set" in clisp-link.
  See <http://clisp.cons.org/impnotes/modules.html#clisp-link> for details.

* Bug fixes:
  + Better support of :START and :END arguments in NEW-CLX (bug#2159172).
  + Fix LOAD-LOGICAL-PATHNAME-TRANSLATIONS when *LOAD-PATHS* contains
    wild pathnames (introduced in 2.47) (bug#2198109).
  + Module NEW-CLX now has the XLIB:QUEUE-EVENT function,
    implemented by Philippe Brochard <hocwp@free.fr>.
  + Extend the domain of LOG to larger BIGNUMs and RATIOs (bug#1007358).
  + Avoid a segfault on (EXPT <HUGE> <HUGE>) (bug#2807311).
  + Fix interaction of finalizers and weak objects (bug#1472478).

* ANSI compliance:
  + Implement the ANSI (IGNORE #'FUNCTION) declaration.
Comment 3 Fedora Admin XMLRPC Client 2011-02-03 18:05:20 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Update System 2011-02-11 16:02:24 EST
clisp-2.49-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/clisp-2.49-1.fc14
Comment 5 Fedora Update System 2011-02-11 16:02:38 EST
clisp-2.49-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/clisp-2.49-3.fc15
Comment 6 Fedora Update System 2011-02-11 16:02:50 EST
clisp-2.49-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/clisp-2.49-1.fc13
Comment 7 Fedora Update System 2011-02-12 22:23:20 EST
clisp-2.49-3.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update clisp'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/clisp-2.49-3.fc15
Comment 8 Fedora Update System 2011-02-21 23:54:13 EST
clisp-2.49-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2011-02-21 23:54:50 EST
clisp-2.49-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-03-02 22:12:13 EST
clisp-2.49-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.