Bug 61272 - kernel panic on first boot
Summary: kernel panic on first boot
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2002-03-15 20:16 UTC by Issue Tracker
Modified: 2007-04-18 16:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 19:43:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial capture of cciss system (DL380) kernel panic (8.70 KB, text/plain)
2002-03-20 21:32 UTC, Mike McLean
no flags Details

Description Issue Tracker 2002-03-15 20:16:08 UTC
Description of Problem:
Server : DL360 G2 
OS      : RedHat 8.0 beta 1  && beta 2
Boot ctlr : Embedded Smart Array 5i ctlr (cciss - RAID 1) 

RedHat 8.0 installation completed on DL 360G2(GRUB). At the end of installation
following error messages obeserved on the screen. 

                                            
/usr/lib/anaconda/iw/progress_gui.py:98: DeprecationWarning : Use
GtkListStore/GtkTreeView 
apply(self.dist.set_text, self.status["remaining"]["time"]+("%s"
%formatTime(remainingTime),) 
                                            
/usr/lib/anaconda/iw/progress_gui.py:98: DeprecationWarning : 
self.totalprogress.update (float(self.sizeComplete) / self.toatlSize. 

Rebooted the system after installation. kernel panic is observed with the
folowing message. 

mount : error 2 mounting ext 3 
pivtroot: pivot_root(/sysroot, /sysroot/initrd) failed : 2 
Kernel panic : No init found : Try passinf init = option to kernel. 

This also happens on DL 330G2..

Comment 1 Jeremy Katz 2002-03-18 20:03:37 UTC
There's at least some confusion here since the messages given would only occur
in beta1 and not in beta2.  What does the bootloader config look like?

Comment 2 Mike McLean 2002-03-19 19:16:59 UTC
I'm seeing this with Skipjack-re0318.1 on 2 different DL380s.

One has the Smart Array 5i (cciss) controller.  The other has an "Integrated
Smart Array Controller (ver 1.40)" (cpqarray).

Both are giving me the kernel panic as above (although I have not personally
observed the end of installation message -- these wer kickstart installs).

Comment 3 Mike McLean 2002-03-20 21:31:13 UTC
With a newer tree (Skipjack-re0320.0) I'm still seeing the cciss lock, but the
cpqarray seems to have booted.

I have serial captured the boot messages, will attach.

Comment 4 Mike McLean 2002-03-20 21:32:42 UTC
Created attachment 49267 [details]
serial capture of cciss system (DL380) kernel panic

Comment 5 Mike McLean 2002-03-20 21:35:06 UTC
In the above capture, there is a notable pause (several seconds) between the
following two lines:

blk: queue f7fb9e1c, I/O limit 4095Mb (mask 0xffffffff)
Loading sym53c8xx module




Comment 6 Matt Wilson 2002-03-21 16:21:42 UTC
Is this system set up in the lab?

Comment 7 Ben Levenson 2002-03-21 16:35:49 UTC
At least one of these boxes (the 2-U DL380) has a symbios SCSI adapter in it. 
I'm guessing that the panic has to do w/ the 'mkinitrd' errors I found in the
install.log (after booting w/ linux rescue).
see bug# 60242

Comment 8 Jeremy Katz 2002-03-23 04:50:49 UTC
Fixed in mkinitrd-3.3.6 and newer

Comment 9 Michael Fulbright 2002-04-05 00:35:32 UTC
Can the bug reporter please verify this is fixed against a recent tree?

Comment 10 Michael Fulbright 2002-04-09 18:59:53 UTC
Could compaq please test the latest Skipjack beta so we can confirm this fix?

Comment 11 Mike McLean 2002-04-10 19:43:41 UTC
I haven't seen this bug with any of the recent trees (and that would include
Skipjack public beta 2).  My testing includes the two machines in the lab that
manifested the bug before (one cciss and one cpqarray).

Comment 12 Jeremy Katz 2002-04-10 22:23:18 UTC
Sounds good; thanks for testing Mike


Note You need to log in before you can comment on or make changes to this bug.