Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612769 - snd-hda-intel with codec: Conexant 5069 doesn't mute speakers when headphones are plugged in
snd-hda-intel with codec: Conexant 5069 doesn't mute speakers when headphones...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
13
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 20:48 EDT by jropella
Modified: 2011-06-29 09:47 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 537986
Environment:
Last Closed: 2011-06-29 09:47:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info (23.39 KB, application/octet-stream)
2010-07-08 20:48 EDT, jropella
no flags Details

  None (edit)
Description jropella 2010-07-08 20:48:19 EDT
Created attachment 430508 [details]
alsa-info

+++ This bug was initially created as a clone of Bug #537986 +++

Description of problem: Plugging in headphones doesn't mute speakers on HP G60 laptop using snd-hda-intel driver with Conexant 5067 codec. I tried loading the module with the various Conexants models listed in /usr/share/doc/kernel-doc-2.6.31.5/Documentation/sound/alsa/HD-Audio-Models.txt, but none changed this behavior.


Version-Release number of selected component (if applicable): alsa-lib.x86_64-1.0.21-3.fc12


How reproducible: 100%


Steps to Reproduce:
1. Load snd-hda-intel driver with or without model=... option.
2. Plug in headphones.
3. Play audio.
  
Actual results: Audio plays through both headphones and speakers when headphones are plugged in.


Expected results: Audio plays only through headphones when they are plugged in.


Additional info: Created file /etc/modprobe.d/snd-hda-intel.conf with the line options snd-hda-intel model=... I am opening a new bug because I don't see this issue reported against this codec.

--- Additional comment from jruemker@redhat.com on 2010-02-26 14:04:59 EST ---

Created an attachment (id=396632)
conexant fix for ideapad

I have the same problem on my lenovo ideapad u150 with the Conexant CX20582 (Pebble) codec.  I found this patch which supposedly has been submitted upstream:

   http://www.galexander.org/lenovo/patch_conexant.patch
   http://www.galexander.org/lenovo/

It is not in the latest alsa-driver-1.0.22.1 (ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.22.1.tar.bz2) yet.  The attached patch, derived from the above, applied against that version fixes the problem for me.  I'm not sure if this will apply for the original reporter or not, but I recommend at least downloading the upstream alsa-driver and giving it a try.  Just do:

  # tar -xvjf alsa-driver-1.0.22.1.tar.bz2
  # cd alsa-driver-1.0.22.1
  # ./configure
  # make
  # make install

This will overwrite the drivers provided by the kernel.  After a reboot, if that doesn't work then try patching it with the included patch.

I also added this to my /etc/modprobe.d/alsa.conf (although it probably wasn't necessary, as the added quirk in the patch likely would have picked up my model correctly):

   options snd-hda-intel model=ideapad 

Jaroslav:  Any way to get this patch included in the Fedora kernel?  It relies on several upstream bits, so it'd either require a rebase of the driver or a backport of the patch.  Would this be possible?  Or do you have a way to ensure this at least gets included upstream?  I'd prefer to not have to keep compiling the upstream drivers after every update.

Let me know if there's anything else I can do to help or test.

Thanks,
John

--- Additional comment from rmonk@redhat.com on 2010-03-26 15:38:51 EDT ---

Just as an FYI, this patch also fixes the Toshiba T115D-S1125 with the same Conexant chipset (so long as you add the model=ideapad).

--- Additional comment from eli@orbsky.homelinux.org on 2010-04-30 13:33:32 EDT ---

I have the same problem on a Toshiba Qosmio x500. I will be trying the workaround filed in this bug report.

--- Additional comment from eli@orbsky.homelinux.org on 2010-04-30 16:13:31 EDT ---

OK... I installed alsa-driver-1.0.23.1.tar.bz2 and configured

hda-intel.conf to include:

options snd-hda-intel model=dell-vostro and everything is working just fine.

--- Additional comment from jruemker@redhat.com on 2010-06-21 15:35:52 EDT ---

Still broken in F13.

--- Additional comment from florent.angly@gmail.com on 2010-06-24 08:38:51 EDT ---

I have the same problem on an Asus UL30Vt in Fedora 13 (alsa-lib 1.0.23).
Comment 1 Steven Rosenberg 2010-07-22 18:14:55 EDT
I have this same problem on a Lenovo G555 in Fedora 13 x86_64 - also uses the Conexant 5069
Comment 2 Florent Angly 2010-07-22 21:44:48 EDT
I checked my alsa-info and found out that my chip is different: it's a Realtek ALC269. I'm happy to open another bug report if needed.
Comment 3 Clemens Buchacher 2010-08-14 16:55:10 EDT
This change 7b2bfdbc (ALSA: hda - Add initial support for Thinkpad T410s HDA codec) in 2.6.35-rc1 seems to add some functionality for the 5069 codec. Unfortunately, I cannot test if it fixes the problem right now.
Comment 5 Steven Rosenberg 2010-08-17 13:59:36 EDT
I made the comment about the Lenovo G555 above: https://bugzilla.redhat.com/show_bug.cgi?id=612769#c1

I want to report that I tried adding:

options snd-hda-intel model=auto

or

options snd-hda-intel model=ideapad

to either /etc/modprobe.d/sound.conf or /etc/modprobe.d/hda-intel.conf (neither file was in the default; I created both)

None of these fixes works in Fedora 13 on my setup (Conexant 5069).
Comment 6 Clemens Buchacher 2010-11-11 19:16:01 EST
I've been using hda_analyzer.py from git://git.alsa-project.org/alsa.git to turn speakers/headphones on/off. It's not exactly a solution, but it works.

Clemens
Comment 7 Richard Marko 2010-11-11 19:35:05 EST
F14:
- jack sense works fine with options snd-hda-intel model=ideapad
- mic doesn't (none of the models helped)

F13:
- mic works fine
- jack sense doesn't
Comment 8 Bug Zapper 2011-06-01 10:22:45 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2011-06-29 09:47:28 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.