Bug 61278 - strange messages from startx
strange messages from startx
Status: CLOSED DUPLICATE of bug 63117
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-15 16:12 EST by Bill Nottingham
Modified: 2014-03-16 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 15:41:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2002-03-15 16:12:25 EST
Running startx prints the versions of net-tools and hostname to stdout/stderr.

i.e.:

# startx
net-tools version 1.60
hostname 1.100 (2001-04-14)
Comment 1 Mike A. Harris 2002-03-16 04:30:56 EST
Sounds to me like your hostname command doesn't understand some parameter
being passed to it perhaps.  What does running it with "set -vx" show?
Comment 2 Bill Nottingham 2002-03-20 23:19:28 EST
It appears to be because the startx script is redirecting the output of hostname
through grep, but hostname prints its version to stderr instead of stdout...
Comment 3 Bill Nottingham 2002-04-10 18:25:58 EDT

*** This bug has been marked as a duplicate of 63117 ***
Comment 4 Mike A. Harris 2002-04-11 12:32:47 EDT
Fixed in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.