Bug 613073 - SELinux is preventing /usr/bin/file "getattr" access on /lib/modules.
SELinux is preventing /usr/bin/file "getattr" access on /lib/modules.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Miroslav Grepl
setroubleshoot_trace_hash:2e6ead9d983...
:
: 613558 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 12:06 EDT by Iwao Yagami
Modified: 2010-08-10 17:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-44.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 17:41:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iwao Yagami 2010-07-09 12:06:36 EDT
Summary:

SELinux is preventing /usr/bin/file "getattr" access on /lib/modules.

Detailed Description:

[file has a permissive type (boinc_t). This access was not denied.]

SELinux denied access requested by file. It is not expected that this access is
required by file and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:boinc_t:s0
Target Context                system_u:object_r:modules_object_t:s0
Target Objects                /lib/modules [ dir ]
Source                        file
Source Path                   /usr/bin/file
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           file-5.04-5.fc13
Target RPM Packages           filesystem-2.4.31-1.fc13
Policy RPM                    selinux-policy-3.7.19-33.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.6-147.fc13.x86_64 #1 SMP Tue
                              Jul 6 22:32:17 UTC 2010 x86_64 x86_64
Alert Count                   3
First Seen                    Sat 10 Jul 2010 12:48:44 AM JST
Last Seen                     Sat 10 Jul 2010 12:59:47 AM JST
Local ID                      f7134a07-98f9-4572-9e43-5bccfadcbdfa
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278691187.810:23230): avc:  denied  { getattr } for  pid=2748 comm="file" path="/lib/modules" dev=sda3 ino=309 scontext=unconfined_u:system_r:boinc_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1278691187.810:23230): arch=c000003e syscall=4 success=yes exit=0 a0=7fffb991ff36 a1=7fffb991fae0 a2=7fffb991fae0 a3=7fffb9919770 items=0 ppid=2741 pid=2748 auid=501 uid=489 gid=476 euid=489 suid=489 fsuid=489 egid=476 sgid=476 fsgid=476 tty=(none) ses=1 comm="file" exe="/usr/bin/file" subj=unconfined_u:system_r:boinc_t:s0 key=(null)



Hash String generated from  catchall,file,boinc_t,modules_object_t,dir,getattr
audit2allow suggests:

#============= boinc_t ==============
allow boinc_t modules_object_t:dir getattr;
Comment 1 Miroslav Grepl 2010-07-12 05:18:57 EDT
*** Bug 613558 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2010-07-12 17:09:31 EDT
Did you execute yum update from that directory /lib/modules?
Comment 3 Iwao Yagami 2010-07-14 22:01:14 EDT
No, the update was initiated through the default GUI software updater.
Comment 4 Miroslav Grepl 2010-08-02 08:53:50 EDT
Fixed in selinux-policy-3.7.19-42.fc13.
Comment 5 Fedora Update System 2010-08-06 09:41:30 EDT
selinux-policy-3.7.19-44.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-44.fc13
Comment 6 Fedora Update System 2010-08-06 17:00:03 EDT
selinux-policy-3.7.19-44.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-44.fc13
Comment 7 Fedora Update System 2010-08-10 17:39:55 EDT
selinux-policy-3.7.19-44.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.