Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 613558 - SELinux is preventing /usr/bin/boinc_client "getattr" access on /home.
SELinux is preventing /usr/bin/boinc_client "getattr" access on /home.
Status: CLOSED DUPLICATE of bug 613073
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:845f2934b3a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 05:09 EDT by Patrick C. F. Ernzer
Modified: 2010-07-12 05:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 05:18:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2010-07-12 05:09:41 EDT
Summary:

SELinux is preventing /usr/bin/boinc_client "getattr" access on /home.

Detailed Description:

[boinc_client has a permissive type (boinc_t). This access was not denied.]

SELinux denied access requested by boinc_client. It is not expected that this
access is required by boinc_client and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:boinc_t:s0
Target Context                system_u:object_r:home_root_t:s0
Target Objects                /home [ dir ]
Source                        boinc_client
Source Path                   /usr/bin/boinc_client
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           boinc-client-6.10.45-1.r21128svn.fc13
Target RPM Packages           filesystem-2.4.31-1.fc13
Policy RPM                    selinux-policy-3.7.19-33.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.6-147.fc13.x86_64 #1 SMP Tue Jul 6 22:32:17
                              UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Mon 12 Jul 2010 11:37:20 AM EEST
Last Seen                     Mon 12 Jul 2010 11:37:20 AM EEST
Local ID                      579f352a-b717-4f67-8e21-3adcf9babac3
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278923840.758:15): avc:  denied  { getattr } for  pid=2449 comm="boinc_client" path="/home" dev=dm-12 ino=2 scontext=system_u:system_r:boinc_t:s0 tcontext=system_u:object_r:home_root_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1278923840.758:15): arch=c000003e syscall=4 success=yes exit=0 a0=7fff04a52ccc a1=7fff04a530b0 a2=7fff04a530b0 a3=3 items=0 ppid=1 pid=2449 auid=4294967295 uid=488 gid=470 euid=488 suid=488 fsuid=488 egid=470 sgid=470 fsgid=470 tty=(none) ses=4294967295 comm="boinc_client" exe="/usr/bin/boinc_client" subj=system_u:system_r:boinc_t:s0 key=(null)



Hash String generated from  catchall,boinc_client,boinc_t,home_root_t,dir,getattr
audit2allow suggests:

#============= boinc_t ==============
allow boinc_t home_root_t:dir getattr;
Comment 1 Patrick C. F. Ernzer 2010-07-12 05:10:34 EDT
probably related to 612560
Comment 2 Miroslav Grepl 2010-07-12 05:18:57 EDT

*** This bug has been marked as a duplicate of bug 613073 ***

Note You need to log in before you can comment on or make changes to this bug.