Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 613086 - Use ip instead of ifconfig for IPoIB interfaces:
Use ip instead of ifconfig for IPoIB interfaces:
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rdma (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Doug Ledford
Gurhan Ozen
:
Depends On:
Blocks: 621266
  Show dependency treegraph
 
Reported: 2010-07-09 12:34 EDT by Gurhan Ozen
Modified: 2013-11-03 21:00 EST (History)
2 users (show)

See Also:
Fixed In Version: rdma-1.0-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 621266 (view as bug list)
Environment:
Last Closed: 2010-11-10 16:28:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2010-07-09 12:34:56 EDT
Description of problem:
Rdma init script is utilizing ifconfig utility to control IPoIB interfaces which is producing lotsa of warning messages such as:

"Ifconfig uses the ioctl access method to get the full address information, which limits hardware addresses to 8 bytes.
Because Infiniband address has 20 bytes, only the first 8 bytes are displayed correctly.
Ifconfig is obsolete! For replacement check ip.
"

Probably ip should be used in favor of ifconfig. 

Version-Release number of selected component (if applicable):
rhel6-beta2

How reproducible:
Very

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Doug Ledford 2010-08-03 02:51:35 EDT
Changes made, will be tested tomorrow and checked in after successful tests.
Comment 3 Doug Ledford 2010-08-04 11:53:53 EDT
Note: I changed all usage of ifconfig to ip in the files owned by the rdma package.  However, ifup-aliases from initscripts still uses ifconfig and on IPoIB interfaces it is still noisy.  We would need to clone this bug against initscripts and get ifup-aliases modified in order to fully resolve the issue.
Comment 5 Gurhan Ozen 2010-08-12 14:17:12 EDT
Verifying this bug, but as comment #3 mentioned ifup- aliases still utilize ifconfig , so if someone's to do say, ifup ib0, s/he would still get the noise.
Comment 6 releng-rhel@redhat.com 2010-11-10 16:28:24 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.