Bug 613104 - 60b2 installs in a 512MB RAM KVM guest failing sometimes
60b2 installs in a 512MB RAM KVM guest failing sometimes
Status: CLOSED DUPLICATE of bug 612525
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 13:43 EDT by Patrick C. F. Ernzer
Modified: 2010-07-09 15:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-09 14:56:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2010-07-09 13:43:36 EDT
Description of problem:
I see random failures when trying to install RHEL 6.0 Beta 2 inside a KVM guest running on Fedora 13 x86_64 host.

Version-Release number of selected component (if applicable):
6.0 Beta 2

How reproducible:
25% to 40% of test installs fail

Steps to Reproduce:
1. install F13 x86_64 on IBM LS21
2. fully update F13
3. create a LV for the KVM guest (either by allowing virt-install on the first test run to create an LV or vie virt-manager) and use that LV for all future tests
4. configure bridged networking (doubtful this is related, but both on my tests at home yesterday and the tests on LS21 today, I do use bridged networking)
5. virt-install -n 512test -r 512 --vcpus=1 --location=ftp://myserver/pub/RHEL-6.0-Beta-2/Server/x86_64/os -x "console=ttyS0,115200 ks=http://myserver/kickstart/pcfe/RHEL60-beta2-minimaltesting-x86_64-ks.cfg" --os-type=linux --os-variant=rhel6 --nographics --hvm --disk vol=vg_bcblade02/KVM_512_test --network bridge=br0
6. if install went through fine, disconnect from console
7. virsh destroy 512test ; virsh undefine 512test
8. repeat steps 5 through 7 a few times (I did 10 testruns)
  
Actual results:
between 25% and 40% of the installs fail

Expected results:
deterministic install results

Additional info: (please do not mind the odd formatting, gnome sticky notes on my notebook is acting up and was refusing me to copy from th enote directly, so I extraced my failure notes from it's file)
1 failed like this:
Running anaconda 13.21.50, the Red Hat Enterprise Linux system installer - please wait.
install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.


1 just hung on a screen that has only the bottom line
  <Tab>/<Alt-Tab> between elements   |  <Space> selects   |  <F12> next screen
(decided after ~5 mins it was hung)


1 hung for 10 minutes on mlocate install beforew I killed it

1 gave
     │                  Packages completed: 129 of 376                   │      
     │                                                                   │      
     │ install exited abnormally [1/1] -10.el6.x86_64 (1 MB)             │      
     │ Kernel module management utilitiThe system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

1 gave
     │                  Packages completed: 161 of 376                   │      
     │                                                                   │      
     │ install exited abnormally [1/1] 86_64 (5 MB)                      │      
     │ Utility for secure communicationThe system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.
Comment 1 Patrick C. F. Ernzer 2010-07-09 13:45:22 EDT
the kickstart file I used for all this has: (only the important bits)

bootloader --location=mbr

#Autopartition
zerombr
clearpart --all --initlabel
autopart

%packages
@core
@base
#@firmware
@console-internet
@network-tools
@system-admin-tools
Comment 3 Chris Lumens 2010-07-09 14:56:16 EDT

*** This bug has been marked as a duplicate of bug 612525 ***

Note You need to log in before you can comment on or make changes to this bug.