Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612525 - RHEL 6B2 install bombs out during graphical install on KVM
RHEL 6B2 install bombs out during graphical install on KVM
Status: CLOSED DUPLICATE of bug 607650
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
: 613104 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 09:05 EDT by Michael De La Rue
Modified: 2013-01-09 17:50 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 16:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a full tarball of the contents of the /tmp directory from the crashed server (30.35 KB, application/x-bzip-compressed-tar)
2010-07-08 09:05 EDT, Michael De La Rue
no flags Details
/tmp files from my first install attempt (30.37 KB, application/x-bzip-compressed-tar)
2010-07-08 11:24 EDT, Michael De La Rue
no flags Details

  None (edit)
Description Michael De La Rue 2010-07-08 09:05:21 EDT
Created attachment 430341 [details]
a full tarball of the contents of the /tmp directory from the crashed server

Description of problem:
When I try to install RHEL6 beta 2 under RHEL 5.5 in a KVM then 

Version-Release number of selected component (if applicable):
kvm-83-164.el5_5.12
install-cds/RHEL6.0-20100622.1-Workstation-x86_64-DVD1.iso
(SHA266 = 272c6fbf1a423e5bab6fddb101b6a4c96b57bf196fa2b26991f55202e0fa715e)

How reproducible:
Each time tried.  

Steps to Reproduce:
1. virt-install --name=rhel6b2-test2 --ram=1024 --vcpus=1 --os-type=linux --os-variant=rhel6 --accelerate --cdrom=install-cds/RHEL6.0-20100622.1-Workstation-x86_64-DVD1.iso --disk path=/var/lib/libvirt/images/rhel6b2-test2.img,size=10,sparse=false --vnc --force --noautoconsole
2. take defaults all the way through install except tell to take entire disk
3. get to select installation packages ; leave as desktop
4. press next 
5. CRASH
  
Actual results:
install exited abnormally [1/1]

Expected results:
system should install and work

Additional info:
* Text mode install seems to work okay (edit install command line add "nomodeset text" at end).
* The first time I ran this through the X server log showed the X server bombing out.  This time round there is no such thing, but something on console 6 seems to have hung though I can bet back and forward to it.
* I still have the VMs live so can provide access to the server for MM to log in.
Comment 2 Chris Lumens 2010-07-08 09:40:27 EDT
I don't see anything in your logs that indicates the nature of the problem.  If you're receiving a traceback, can you also make sure /tmp/anaconda-tb-* is attached to this file?  If it's a stack trace, can you attach a screenshot of tty1?
Comment 3 Michael De La Rue 2010-07-08 11:20:38 EDT
That's a complete dump of /tmp/ there was no more. Also looking at the first console there's nothing between the start of graphical install and the message install exited abnormally [1/1]

On the other hand the VM is still active so if you can suggest how I can trigger the traceback you want I can do that.  

I attempted this install before and had a problem at more or less the same stage though the X server crashed fully.  There is also no /tmp/anaconda-tb-* file there either.  I'm attaching the /tmp files from that as well just in case they provide inspiration.  

Incidentally I should point out that on this machine there are several other VMs, but RHEL 5 and Ubuntu running and they seem to have no problem.
Comment 4 Michael De La Rue 2010-07-08 11:24:26 EDT
Created attachment 430397 [details]
/tmp files from my first install attempt

I did a previous install.  I'm not sure about the exact procedure used; approximately select workstation and full disk install; this is the set of /tmp files produced that time.  In this case the X server actually crashed out fully.  I suspect that it's just a different symptom of the same root cause, but can't be sure.  

Again, this is all the files from /tmp but the VM is still running if you want e.g. a signal sent to some process or something.
Comment 5 Brian Lane 2010-07-08 14:52:17 EDT
This may be related to bug 610255
Comment 6 Chris Lumens 2010-07-08 14:53:27 EDT
What happens if you increase the memory for your VM when doing a graphical install?
Comment 7 Michael De La Rue 2010-07-09 12:08:28 EDT
With 4096M of memory the install completes and appears successful.
Comment 8 Chris Lumens 2010-07-09 14:56:16 EDT
*** Bug 613104 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Berrange 2010-07-15 15:44:23 EDT
Libvirt doesn't have any bearing on anaconda using too much memory inside the guest. We merely create a KVM virtual machine with the requested amount of RAM. How the guest OS uses that RAM is its own decision.
Comment 11 Dor Laor 2010-07-15 16:50:30 EDT
It might be another incarnation of Bug 607650 - Install exited abnormally while installing packages. Adding Avi to the CC list. Reported can try the brew build on that bug
Comment 12 Andrea Arcangeli 2010-07-15 17:47:40 EDT
I agree it worth testing with the fix for bug 607650. I don't think there's a backport to rhel5 host yet but there is a rpm for rhel6 host availabile in bug 607650.
Comment 13 Chris Lumens 2010-07-16 09:55:22 EDT
Putting in needinfo until we can get results back for comment #11 and #12.
Comment 14 David Cantrell 2010-07-22 15:19:52 EDT
Dor,

Can we dupe this one against bug #607650?
Comment 15 Dor Laor 2010-07-22 16:28:55 EDT

*** This bug has been marked as a duplicate of bug 607650 ***

Note You need to log in before you can comment on or make changes to this bug.