Bug 613118 - Glitches with GMA Mobile 945 and compiz enabled.
Summary: Glitches with GMA Mobile 945 and compiz enabled.
Keywords:
Status: CLOSED DUPLICATE of bug 618679
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-09 18:34 UTC by Tom London
Modified: 2018-04-11 13:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-13 19:06:53 UTC


Attachments (Terms of Use)
Updated intel-dri2 patch (shamelessly adapted from 7.8.1-intel-dri2-damage.patch) (718 bytes, patch)
2010-07-10 00:16 UTC, Tom London
no flags Details | Diff

Description Tom London 2010-07-09 18:34:00 UTC
Description of problem:
I'm seeing a regression of "corrupted screen/text" on my Thinkpad X200 (only) with compiz enabled.

This appears similar to https://bugzilla.redhat.com/show_bug.cgi?id=577142

Started failing with:
xorg-x11-server-common-1.8.99.904-1.20100702.fc14.x86_64
xorg-x11-server-Xorg-1.8.99.904-1.20100702.fc14.x86_64
xorg-x11-drv-intel-2.12.0-4.fc14.x86_64
libdrm-devel-2.4.21-3.fc14.x86_64
mesa-dri-drivers-7.9-0.2.fc14.x86_64
mesa-libGL-devel-7.9-0.2.fc14.x86_64
mesa-libGLU-devel-7.9-0.2.fc14.x86_64
mesa-libGLU-7.9-0.2.fc14.x86_64
libdrm-debuginfo-2.4.21-3.fc14.x86_64
mesa-debuginfo-7.9-0.2.fc14.x86_64
compiz-0.8.6-1.fc14.x86_64
mesa-libGL-7.9-0.2.fc14.x86_64
mesa-dri-drivers-experimental-7.9-0.2.fc14.x86_64
libdrm-2.4.21-3.fc14.x86_64

Seems to work just fine if I revert mesa packages to 
mesa-libGLU-7.8.1-2.fc13.x86_64
mesa-libGLU-devel-7.8.1-2.fc13.x86_64
mesa-debuginfo-7.8.1-2.fc13.x86_64
mesa-libGL-7.8.1-2.fc13.x86_64
mesa-libGL-devel-7.8.1-2.fc13.x86_64
mesa-dri-drivers-7.8.1-2.fc13.x86_64
mesa-dri-drivers-experimental-7.8.1-2.fc13.x86_64

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.8.99.904-1.20100702.fc14.x86_64
xorg-x11-server-Xorg-1.8.99.904-1.20100702.fc14.x86_64
xorg-x11-drv-intel-2.12.0-4.fc14.x86_64
libdrm-devel-2.4.21-3.fc14.x86_64
mesa-dri-drivers-7.9-0.2.fc14.x86_64
mesa-libGL-devel-7.9-0.2.fc14.x86_64
mesa-libGLU-devel-7.9-0.2.fc14.x86_64
mesa-libGLU-7.9-0.2.fc14.x86_64
libdrm-debuginfo-2.4.21-3.fc14.x86_64
mesa-debuginfo-7.9-0.2.fc14.x86_64
compiz-0.8.6-1.fc14.x86_64
mesa-libGL-7.9-0.2.fc14.x86_64
mesa-dri-drivers-experimental-7.9-0.2.fc14.x86_64
libdrm-2.4.21-3.fc14.x86_64

How reproducible:
Screen gets messed up every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2010-07-09 20:54:24 UTC
BTW, glitching continues with:

Jul 08 17:24:40 Updated: mesa-dri-drivers-7.9-0.5.fc14.x86_64
Jul 08 17:24:41 Updated: mesa-libGL-7.9-0.5.fc14.x86_64
Jul 08 17:24:41 Updated: mesa-libGLU-7.9-0.5.fc14.x86_64
Jul 08 17:24:44 Updated: mesa-dri-drivers-experimental-7.9-0.5.fc14.x86_64
Jul 08 17:24:47 Updated: mesa-libGL-devel-7.9-0.5.fc14.x86_64
Jul 08 17:24:48 Updated: mesa-libGLU-devel-7.9-0.5.fc14.x86_64

Comment 2 Tom London 2010-07-09 22:37:10 UTC
7.8.1-2 applied 'mesa-7.8.1-intel-dri2-damage.patch'.

Don't see this on the latest packages.

Don't suppose its still needed?

Comment 3 Tom London 2010-07-10 00:16:13 UTC
Created attachment 430778 [details]
Updated intel-dri2 patch (shamelessly adapted from 7.8.1-intel-dri2-damage.patch)

This patch appears to "make it work for me" on my ThinkPad X200.

Of course, I don't understand if this is "really right"......

Comment 4 pankaj pandey 2010-07-14 18:08:22 UTC
I'm also having this issue on intel 965M laptop.
Also i can see that the Xorg process uses one complete core (100 %) of my dual core laptop. It may probably related since both problems started around the same time.

Comment 5 Tom London 2010-07-20 14:16:37 UTC
The patch in https://bugzilla.redhat.com/show_bug.cgi?id=613118#c3 still seems to be needed in mesa-7.9-0.6.fc14.x86_64.rpm.

Without it, I get screen corruption, glitches, etc.

With the patch, all is fine.

Comment 6 Bug Zapper 2010-07-30 12:29:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Gene Snider 2010-08-05 22:07:47 UTC
Is that patch going to go into mesa-7.9*.fc14 any time soon?  I'm currently running the latest F13 mesa, 7.8.1-8.fc13, in F14 to avoid artifacts in compiz.

Thanks,
Gene

Comment 8 Tom London 2010-08-24 13:57:33 UTC
Latest mesa update continues regression and does not fix glitches/artifacts:

mesa-dri-drivers-experimental-7.9-0.7.fc15.x86_64
mesa-libGL-7.9-0.7.fc15.i686
mesa-debuginfo-7.9-0.6.local.fc15.x86_64
mesa-libGL-7.9-0.7.fc15.x86_64
mesa-libGL-devel-7.9-0.7.fc15.x86_64
mesa-dri-drivers-7.9-0.7.fc15.x86_64
mesa-libGLU-7.9-0.7.fc15.x86_64
mesa-libGLU-devel-7.9-0.7.fc15.x86_64
mesa-dri-drivers-7.9-0.7.fc15.i686
mesa-libGLU-7.9-0.7.fc15.i686

Changing this back to Rawhide.

Any hope on a fix for this? Compiz is unusable on my system this way....

[I'll try applying the patch described https://bugzilla.redhat.com/show_bug.cgi?id=613118#c3 and report if it 'works'.]

Comment 9 Tom London 2010-08-24 14:54:40 UTC
I did a local build to 7.9-0.7 adding the patch described in https://bugzilla.redhat.com/show_bug.cgi?id=613118#c3 and installed.

All appears working.

Is there something preventing this regression from being nailed?  Is upstream aware of this?

Comment 10 Gene Snider 2010-09-04 21:37:07 UTC
Is a non-functioning compiz considered a beta blocker by chance?  I tried the rawhide (F15) build, since it's a newer git than the F14 version.  It has the same glitches/artifacts as the current F14 version.  As I mentioned in Comment 7, using mesa-7.8.1-8.fc13 is the only way I've been able to run compiz without rebuilding as Tom London describes.

Gene

Comment 11 Matěj Cepl 2010-09-13 13:46:58 UTC
Maybe related to bug 618679

Comment 12 Matěj Cepl 2010-09-13 18:38:29 UTC
(In reply to comment #10)
> Is a non-functioning compiz considered a beta blocker by chance?

No, compiz is not part of the standard installation of Fedora and it is kind of a dead-end project anyway ... the next default Gnome window manager will be gnome-shell.

Comment 13 Adel Gadllah 2010-09-13 19:06:53 UTC
(In reply to comment #11)
> Maybe related to bug 618679

Yes it is; I am marking as dup and submitting a more useful comment there ;)

*** This bug has been marked as a duplicate of bug 618679 ***

Comment 14 Fedora Update System 2010-09-13 20:42:32 UTC
xorg-x11-drv-intel-2.12.0-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.12.0-6.fc14


Note You need to log in before you can comment on or make changes to this bug.