Bug 613401 - Regression : Resume with USB remote fails (upstream patch available)
Regression : Resume with USB remote fails (upstream patch available)
Status: CLOSED DUPLICATE of bug 617559
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://bugzilla.kernel.org/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-11 06:56 EDT by Didier
Modified: 2010-08-28 19:30 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-28 19:30:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Allow remote wakeup if it is enabled, even if no interface drivers actually want it. (1.23 KB, patch)
2010-07-11 06:56 EDT, Didier
no flags Details | Diff

  None (edit)
Description Didier 2010-07-11 06:56:37 EDT
Created attachment 430980 [details]
Allow remote wakeup if it is enabled, even if no interface drivers actually want it.

Description of problem:
Resuming a suspended machine by means of an USB remote/receiver (e.g. Philips eHome Infrared Receiver + MCE remote) fails

Version-Release number of selected component (if applicable):
kernel-2.6.33.6-147.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. Suspend machine
2. Press Power Toggle button on USB IR remote
3. Machine fails to resume, as the USB receiver is not powered.

Additional info:

- Regression from F12, kernel 2.6.32 (confirmed with kernel-2.6.32.12-115.fc12.x86_64) ;
- Upstream patch available at https://bugzilla.kernel.org/show_bug.cgi?id=16043 .

The patch supplied by Alan Stern applies cleanly to the latest stable kernel release (2.6.33.6-147.fc13.x86_64), following the Fedora kernel recompilation guidelines (http://fedoraproject.org/wiki/Docs/CustomKernel) ; patch attached.

It would be much appreciated if the patch could be backported to F13's kernel.
Comment 1 Chuck Ebbert 2010-08-28 19:30:15 EDT

*** This bug has been marked as a duplicate of bug 617559 ***

Note You need to log in before you can comment on or make changes to this bug.